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Signal Generator Features
Signal Generator Features
• N5181A, analog models: 100 kHz to 1, 3, or 6 GHz

N5182A, vector models: 100 kHz to 3 or 6 GHz

• electronic attenuator

• step & list sweep of frequency, power, or frequency and power

vector models can include waveforms in list sweep

• user flatness correction

• automatic leveling control (ALC); power calibration

• 10 MHz reference oscillator with external output

• flexible reference input, 1 – 50 MHz (Option 1ER)

• GPIB, USB 2.0, and 100Base- T LAN interfaces

• analog modulation: AM, FM, and ΦM (Option UNT)

• external AM, FM, and ΦM inputs (Option UNT)

• pulse modulation (Option UNU)

• narrow pulse modulation (Option UNW)

• SCPI and IVI- COM driver 

• 8648/ESG code compatible

• LXI Class C compliant

• multiple baseband generator synchronization when using multiple signal generators (master/slave 
setup)

• external analog I/Q inputs (vector models)

• phase noise interference (vector models, Option 432)

• analog differential I/Q outputs (vector models, Option 1EL)

• arbitrary I/Q waveform playback up to 125 MSa/s (vector models, Option 654)

• with Signal Studio Software, vector models can generate 802.11 WLAN, W- CDMA, cdma2000, 
1xEV- DO, GSM, EDGE, and more

For more details on hardware, firmware, software, and documentation features and options, refer to 
the data sheet shipped with the signal generator and available from the Agilent Technologies website. 

1. Open: http://www.agilent.com/find/mxg

2. Select the desired model number.

3. In the options and price list section, click price list.
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Modes of Operation
Modes of Operation
Depending on the model and installed options, the Agilent MXG signal generator provides up to four 
basic modes of operation: continuous wave (CW), swept signal, analog modulation, and digital 
modulation.

Continuous Wave

In this mode, the signal generator produces a continuous wave signal. The signal generator is set to 
a single frequency and power level. Both the N5182A and N5181A can produce a CW signal.

Swept Signal

In this mode, the signal generator sweeps over a range of frequencies and/or power levels. Both the 
N5182A and N5181A provide list and step sweep functionality.

Analog Modulation

In this mode, the signal generator modulates a CW signal with an analog signal. The analog 
modulation types available depend on the installed options. 

Option UNT provides AM, FM, and ΦM modulations. Some of these modulations can be used together. 

Options UNU and UNW provide standard and narrow pulse modulation capability, respectively.

Digital Modulation (N5182A with Options 651, 652, or 654 Only)

NOTE The internal baseband generator speed upgrade Options 670, 671, and 672 are option 
upgrades that require Option 651 and 652 to have been loaded at the factory (refer to the 
Data Sheet for more information). Any references to 651, 652, or 654 are inclusive of 671, 
672, and 674.

In this mode, the signal generator modulates a CW signal with a arbitrary I/Q waveform. I/Q 
modulation is only available on the N5182A. An internal baseband generator (Option 651, 652, or 
654) adds the following digital modulation formats:

• Custom Arb Waveform Generator mode can produce a single- modulated carrier or 
multiple- modulated carriers. Each modulated carrier waveform must be calculated and generated 
before it can be output; this signal generation occurs on the internal baseband generator. Once a 
waveform has been created, it can be stored and recalled, which enables repeatable playback of 
test signals. To learn more, refer to “Using the Arbitrary Waveform Generator” on page 181.

• Multitone mode produces up to 64 continuous wave signals (or tones). Like the Two Tone mode, 
the frequency spacing between the signals and the amplitudes are adjustable. To learn more, refer 
to “Creating a Custom Multitone Waveform” on page 199.

• Two- tone mode produces two separate continuous wave signals (or tones). The frequency spacing 
between the signals and the amplitudes are adjustable. To learn more, refer to “Creating a Custom 
Two- Tone Waveform” on page 199.

• Dual ARB mode is used to control the playback sequence of waveform segments that have been 
written into the ARB memory located on the internal baseband generator. These waveforms can 
be generated by the internal baseband generator using the Custom Arb Waveform Generator 
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Signal Generator Overview
Front Panel Overview
mode, or downloaded through a remote interface into the ARB memory. To learn more, refer 
to“Dual ARB Player” on page 82.

Front Panel Overview

1. Host USB

Use this universal serial bus (USB) to connect a memory stick for data transfer. You can connect or 
disconnect a USB device without shutting down or restarting the signal generator. The instrument 
also has a rear- panel device USB connector (see page 13) used to remotely control the instrument.

2. Display

The LCD screen provides information on the current function. Information can include status 
indicators, frequency and amplitude settings, and error messages. Labels for the softkeys are located 
on the right- hand side of the display. See also, “Front Panel Display” on page 8.

3. Softkeys

A softkey activates the function indicated by the displayed label to the left of the key.

4. Numeric Keypad

The numeric keypad comprises the 0 through 9 hardkeys, a decimal point hardkey, a minus sign 
hardkey, and a backspace hardkey. See “Entering and Editing Numbers and Text” on page 27.

Connector Type A

USB Protocol 2.0

22. Power Switch and LEDs 

21. More and LED 

20. Return 

18. Knob 

19. Incr Set 
15. Page Down 

16. I Input 

17. Q Input 

12. RF 
Output 

13. RF On/Off and LED 

14. Mod On/Off and LED 

7. MENUS 
and
10. Help 

11. Preset 
and User 
Preset 

9. Local 
Cancel/(Esc) 

5. Arrows and Select 

6. Page Up 

8. Trigger 

4. Numeric 
Keypad 3. Softkeys 2. Display 1. Host USB 

MXG Vector Signal Generator
N5181A 100 kHz - 6 GHz
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5. Arrows and Select

The Select and arrow hardkeys enable you to select items on the signal generator’s display for editing. 
See “Entering and Editing Numbers and Text” on page 27.

6. Page Up

In a table editor, use this hardkey to display a previous page. See “Example: Using a Table Editor” on 
page 28. When text does not fit on one page in the display area, use this key in conjunction with the 
Page Down key (page 6) to scroll text.

7. MENUS

These hardkeys open softkey menus that enable you to configure instrument functions or access 
information.

8. Trigger

When trigger mode is set to Trigger Key, this hardkey initiates an immediate trigger event for a 
function such as a list or step sweep.

9. Local Cancel/(Esc)

This hardkey deactivates remote operation and returns the signal generator to front panel control, 
cancels an active function entry, and cancels long operations (such an IQ calibration).

10. Help

Use this key to display a description of any hardkey or softkey. See “Viewing Key Descriptions” on 
page 26.

See page 53

See page 48

See page 41

See page 29

See page 67

See page 71

Active only on 
vector models.

See page 29

See page 31

See page 17

See page 26

See page 81

Reserved for 
future use.
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Front Panel Overview
11. Preset and User Preset

These hardkeys set the signal generator to a known state (factory or user- defined). See “Presetting 
the Signal Generator” on page 26.

12. RF Output

13. RF On/Off and LED

This hardkey toggles the operating state of the RF signal present at the RF OUTPUT connector. The 
RF On/Off LED lights when RF output is enabled.

14. Mod On/Off and LED

This hardkey enables or disables the modulation of the output carrier signal by an active modulation 
format. This hardkey does not set up or activate a format (see “Modulating the Carrier Signal” on 
page 40).

The MOD ON/OFF LED lights when modulation of the output is enabled.

15. Page Down

In a table editor, use this hardkey to display the next page. See “Example: Using a Table Editor” on 
page 28. When text does not fit on one page in the display area, use this key in conjunction with the 
Page Up key (page 5) to scroll text.

16. I Input (vector models only)

See also, “I/Q Modulation” on page 138.

Connector Standard:
Option 1EM:
Impedance:

female Type- N
Rear panel female Type- N
50Ω

Damage Levels 50Vdc, 2W maximum RF power

Connector Type: female BNC Impedance: 50Ω
Signal An externally supplied analog, in- phase component of I/Q modulation.

The signal level is  = 0.5 Vrms for a calibrated output level.

Damage Levels 1Vrms
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17. Q Input (vector models only)

See also, “I/Q Modulation” on page 138.

18. Knob

Rotating the knob increases or decreases a numeric value, or moves the highlight to the next digit, 
character, or item in a list. See also, “Front Panel Knob Resolution” on page 19.

19. Incr Set 

This hardkey enables you to set the increment value of the currently active function. The increment 
value also affects how much each turn of the knob changes an active function’s value, according to 
the knob’s current ratio setting (see “Front Panel Knob Resolution” on page 19).

20. Return 

This hardkey enables you to retrace key presses. In a menu with more than one level, the Return key 
returns to the prior menu page.

21. More and LED

When a menu contains more softkey labels than can be displayed, the More LED lights and a More 
message displays below the labels. To display the next group of labels, press the More hardkey.

22. Power Switch and LEDs

This switch selects the standby mode or the power on mode. In the standby position, the yellow LED 
lights and all signal generator functions deactivate. The signal generator remains connected to the 
line power, and some power is consumed by some internal circuits. In the on position, the green LED 
lights and the signal generator functions activate.

Connector Type: female BNC Impedance: 50Ω
Signal An externally supplied analog, quadrature- phase component of I/Q modulation.

The signal level is  = 0.5 Vrms for a calibrated output level.

Damage Levels 1Vrms
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Front Panel Display
Front Panel Display

1. Active Function Area

This area displays the currently active function. For example, if frequency is the active function, the 
current frequency setting appears. If the currently active function has an increment value associated 
with it, that value also appears. 

2. Frequency Area

This area displays the current frequency setting.

5. Error Message Area 6. Text Area 7. Softkey Label Area 

4. Amplitude Area 3. Annunciators 2. Frequency Area 1. Active Function Area 

Scroll Bar
If there is more 
text than can be 
displayed on one 
screen, a scroll 
bar appears here. 
Use the Page Up 
and Page Down 
keys to scroll 
through the text.
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Signal Generator Overview
Front Panel Display
3. Annunciators

Annunciators show the status of some of the signal generator functions, and indicate error 
conditions. An annunciator position may be used by more than one annunciator; in this case, only 
one of the functions sharing a given position can be active at a given time.

This annunciator appears when...

ΦM Phase modulation is on. If you turn frequency modulation on, the FM annunciator replaces ΦM.

ARB The ARB generator is on.

ALC OFF The ALC circuit is disabled. The UNLEVEL annunciator appears in the same position if the ALC is enabled and 
is unable to maintain the output level.

AM Amplitude modulation is on.

ARMED A sweep has been initiated and the signal generator is waiting for the sweep trigger event.

ATTNHOLD The attenuator hold function is on. When this function is on, the attenuator is held at its current setting.

BBG DAC A DAC overflow is occurring, adjust the runtime scaling adjust until the BBG DAC annunciator turns off. 
Another annunciator, UNLOCK, appears in the same position and has priority over the BBG DAC annunciator 
(see UNLOCK, below).

DETHTR The ALC detector heater is not up to temperature. To meet ALC specifications the heater must be at 
temperature.

AWGN Real Time I/Q Baseband additive white Gaussian noise is on.

DIGBUS The digital bus is in use.

DIGMOD Custom Arb waveform generator is on.

ERR An error message is placed in the error queue. This annunciator does not turn off until you either view all of 
the error messages or clear the error queue (see “Reading Error Messages” on page 53).

EXTREF An external frequency reference is applied.

FM Frequency modulation is on. If you turn phase modulation on, the ΦM annunciator replaces FM.

I/Q I/Q vector modulation is on.

L The signal generator is in listener mode and is receiving information or commands over the GPIB, USB, or 
VXI- 11/Sockets (LAN) interface.

M-TONE Multitone waveform generator is on.

MULT A frequency multiplier is set (see “Setting a Frequency Multiplier” on page 63).

OFFS An output offset is set (see “Setting an Output Offset” on page 61).

PN Phase noise interference is on.

PULSE Pulse modulation is on.

R The signal generator is remotely controlled over the GPIB, USB, or VXI- 11/Sockets (LAN) interface. When the 
signal generator is in remote mode, the keypad is locked out. To unlock the keypad, press Local.

REF An output reference is set (see “Setting an Output Reference” on page 62).

S The signal generator has generated a service request (SRQ) over the GPIB, USB, or VXI- 11/Sockets (LAN) 
interface.

SWEEP The signal generator is currently sweeping in list or step mode.

SWMAN The signal generator is in manual sweep mode.

T The signal generator is in talker mode and is transmitting information over the GPIB, USB, or VXI- 11/Sockets 
(LAN) interface.

T-TONE Two-Tone waveform generator is on.

UNLEVEL The signal generator is unable to maintain the correct output level. This is not necessarily an indication of 
instrument failure; unleveled conditions can occur during normal operation. Another annunciator, ALC OFF, 
appears in the same position when the ALC circuit is disabled (see ALC OFF, above).
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4. Amplitude Area

This area displays the current output power level setting.

5. Error Message Area

This area displays abbreviated error messages. If multiple messages occur, only the most recent 
message remains displayed. See “Reading Error Messages” on page 53.

6. Text Area

This area displays signal generator status information, such as the modulation status, and other 
information such as sweep lists and file catalogs. This area also enables you to perform functions 
such as managing information (entering information, and displaying or deleting files).

7. Softkey Label Area

This area displays labels that define the function of the softkeys located immediately to the right of 
the display. Softkey labels change, depending on the function selected.

UNLOCK Any of the phase locked loops cannot maintain phase lock. To determine which loop is unlocked, examine the 
error messages (see “Reading Error Messages” on page 53).

WINIT The signal generator is waiting for you to initiate a single sweep.

This annunciator appears when...
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Rear Panel Overview
Rear Panel Overview

1. AC Power Receptacle

The AC power cord receptacle accepts a three- pronged AC power cord that is supplied with the 
signal generator. For details on line setting requirements and the power cord, see the 
Installation Guide.

2. SWEEP OUT 

3. AM 

4. FM 

5. PULSE 

6. TRIG IN 

7. TRIG OUT 

8. REF IN 

10. GPIB 

11. LAN 

12. Device USB 

9. 10 MHz OUT 

1. AC Power Receptacle 

Option 1EM
only 

See page 6

Digital Modulation Connectors (vector models only) on page 14
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Rear Panel Overview
2. SWEEP OUT

3. AM

4. FM

5. PULSE

6. TRIG IN

7. TRIG OUT

Connector female BNC
Can drive 2 kΩ.

Impedance <1Ω

Signal Voltage range: 0 to +10V, regardless of sweep width
In swept mode: beginning of sweep = 0V; end of sweep = +10V
In CW mode: no output

This is a multiple use connector. For signal routing selections, see pages 39 and 71.

Connector female BNC Impedance nominally 50Ω
Signal An externally supplied ±1Vp signal that produces the indicated depth.

Damage Levels 5Vrms and 10Vp

Connector female BNC Impedance nominally 50Ω
Signal An externally supplied ±1Vp signal that produces the indicated deviation

Damage Levels 5Vrms and 10Vp

Connector female BNC Impedance nominally 50Ω
Signal Externally supplied: +1V = on; 0V = off 

Damage Levels 5Vrms and 10Vp

Connector female BNC Impedance high Z

Signal An externally supplied TTL or CMOS signal for triggering operations, such as 
point- to- point in manual sweep mode or an LF sweep in external sweep mode.
Triggering can occur on either the positive or negative edge.

Damage Levels ≤ −0.5V and ≥ +5.5V

Connector female BNC Impedance nominally 50Ω
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8. REF IN

In its factory default mode, the signal generator can detect a valid reference signal at this connector 
and automatically switch from internal to external reference operation. See “Presetting the Signal 
Generator” on page 26. With Option 1ER (flexible reference input), you must explicitly tell the signal 
generator the external reference frequency you wish to use; enter the information through the front 
panel or over the remote interface.

9. 10 MHz OUT

10. GPIB

This connector enables communication with compatible devices such as external controllers, and is 
one of three connectors available to remotely control the signal generator (see also 11. LAN and 
12. Device USB).

11. LAN

The signal generator supports local area network (LAN) based communication through this connector, 
which enables a LAN- connected computer to remotely program the signal generator. The LAN 
interface is LXI class C compliant; it does not support auto−MDIX. The signal generator is limited to 
100 meters on a single cable (100Base- T). For more information on the LAN, refer to the 
Programming Guide.

12. Device USB

Use this universal serial bus (USB) connector to connect a PC to remotely control the signal 
generator.

Signal A TTL signal that is high at the start of a dwell sequence, or when waiting for the point 
trigger in manual sweep mode. 
It is low when the dwell is over, or when the point trigger is received. 
The logic polarity can be reversed.

This is a multiple use connector. For signal routing selections, see pages 39 and 71.

Connector female BNC Impedance nominally 50Ω
Signal An externally supplied −3.5 to +20 dBm signal from a timebase reference that is 

within ±1 ppm.

Connector female BNC Impedance nominally 50Ω
Signal A nominal signal level greater than 4 dBm.

Connector Mini- B

USB Protocol Version 2.0
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Digital Modulation Connectors (vector models only)

I OUT, Q OUT,  OUT,  OUT

EXT CLK

EVENT 1

Connector Type: female BNC Impedance: 50Ω
DC- coupled

Signal

I OUT The analog, in- phase component of I/Q modulation from the internal baseband generator.

Q OUT The analog, quadrature- phase component of I/Q modulation from the internal baseband 
generator.

 OUT Used in conjunction with the I OUT connector to provide a balanceda baseband stimulus.

aBalanced signals are signals present in two separate conductors that are symmetrical relative to ground, and are opposite in polarity 
(180 degrees out of phase).

 OUT Used in conjunction with the Q OUT connector to provide a balanceda baseband stimulus.

Damage Levels > 1 Vrms DC Origin Offset typically <10 mV

Output Signal Levels into a 50Ω Load

• 0.5Vpk, typical, corresponds to one unit length of the I/Q vector

• 0.69Vpk (2.84 dB), typical, maximum crest factor for peaks for π/4 DQPSK, alpha = 0.5

• 0.71Vpk (3.08 dB), typical, maximum crest factor for peaks for π/4 DQPSK, alpha = 0.35

• Typically 1Vp- p maximum

Connector female BNC Impedance nominally 50Ω

Signal An externally supplied TTL or CMOS bit clock signal where the rising edge aligns with the 
beginning data bit. 
The falling edge is used to clock external signals.
This signal is used with digital modulation applications.

Damage Levels > +8 and < −4V Maximum Clock Rate 50 MHz

Connector female BNC Impedance: nominally 50Ω

Signal A pulse that can be used to trigger the start of a data pattern, frame, or timeslot. 
Adjustable to ± one timeslot; resolution = one bit
Markers
Each Arb- based waveform point has a marker on/off condition associated with it. 
Marker 1 level = +3.3V CMOS high (positive polarity selected); –3.3V CMOS low (negative 
polarity selected). 
Output on this connector occurs whenever Marker 1 is on in an Arb- based waveform (see 
“Using Waveform Markers” on page 96).

Damage Levels >+8 and <−4V

I Q

I

Q
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PAT TRIG

DIGITAL BUS I/O

This is a proprietary bus used by Agilent Technologies signal creation software. This connector is not 
operational for general purpose use. Signals are present only when a signal creation software option 
is installed (for details, refer to http://www.agilent.com/find/signalcreation).

AUX I/O

Connector female BNC Impedance: nominally 50Ω

Signal A TTL/CMOS low to TTL/CMOS high, or TTL/CMOS high to TTL/CMOS low edge trigger. 
The input to this connector triggers the internal digital modulation pattern generator to start a 
single pattern output or to stop and re- synchronize a pattern that is being continuously output. 
To synchronize the trigger with the data bit clock, the trigger edge is latched, then sampled 
during the falling edge of the internal data bit clock. 
This is the external trigger for all ARB waveform generator triggers.

Minimum Trigger Input Pulse Width (high or low) = 100 ns

Minimum Trigger Delay (trigger edge to first bit of frame) = 1.5 to 2.5 bit clock periods

Damage Levels > +8 and < −4V

View looking into rear panel female 50-pin connector
25 1

2650

Pin 1 = Event 1
Pin 2 = Event 2
Pin 3 = Event 3
Pin 4 = Event 4
Pin 5 = Sample Rate Clock Out
Pin 6 = Patt Trig 2

Pins 7–25 = Reserved*

Pins 26–50 = Ground

*Future Capability

Event 1, 2, 3, and 4 (pins 1 − 4)
A pulse that can be used to trigger the start of a data pattern, frame, or timeslot. 
Adjustable to ± one timeslot; resolution = one bit

Markers
Each Arb- based waveform point has a marker on/off condition associated with it. 
Marker level = +3.3V CMOS high (positive polarity selected); –3.3V CMOS low (negative polarity 
selected).

Patt Trig 2 (pin 6)
A TTL/CMOS low to TTL/CMOS high, or TTL/CMOS high to TTL/CMOS low edge trigger. 
The input to this connector triggers the internal digital modulation pattern generator to start a single pattern output or to stop and 
re-synchronize a pattern that is being continuously output. 

To synchronize the trigger with the data bit clock, the trigger edge is latched, then sampled during the falling edge of the internal data bit 
clock. 

This is an external trigger for all ARB waveform generator triggers. Minimum pulse width = 100 ns. Damage levels: > +5.5 and < −0.5V.

Sample Rate Clock Out (pin 5)
This output is used with an internal baseband generator. This pin relays a CMOS bit clock signal for synchronizing serial data. 
Damage levels: > +5.5 and < −0.5V.

The AUX I/O connector is a shielded .050 series board mount connector.
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2 Setting Preferences & Enabling Options

The Utility menu provides access to both user and remote operation preferences, and to the menus in 
which you can enable instrument options.

page 18

Front Panel Knob Resolution on page 19

page 19

Enabling an Option on page 24

GPIB Address and Remote Language on page 21
Configuring the LAN Interface on page 22
Enabling LAN Services: Browser, Sockets, and VXI-11 on page 22
Configuring the Remote Languages on page 23

User Preferences

Remote Operation 

Setting Time and Date on page 20

Upgrading Firmware on page 20
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User Preferences
User Preferences
From the Utility menu, you can set the following user preferences:

• Display Settings, below

• Power On and Preset on page 19

• Front Panel Knob Resolution on page 19

Display Settings

NOTE With both brightness and contrast set to minimum, the display may be too dark to see the 
softkeys. If this happens, use the figure above to locate the brightness and contrast softkeys 
and adjust their values so that you can see the display.

Range: 0—100

Range: 35—55

Range: 1—12 hours, in 1 hour increments

Light Only: turns the display light off, leaving the text visible at a low intensity. 

Light & Text: turns the display light and the text off.
If the display remains unchanged for long periods of time, use this mode to 
prevent the text from burning the display.

When on, commands executed through 
the remote control bus update the signal 
generator display accordingly.

Bright without color

Utility > Display

See also, Using the Secure Display (Option 006 Only) on page 

For details on each key, use key help
as described on page 26.

page 216

Dark text on a light 
background.

Light text on a dark 
background.
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User Preferences
Power On and Preset

Front Panel Knob Resolution

Select the GPIB language desired after a preset.
See also, the Programming Guide and the SCPI Reference.

Utility > Power On/Preset >

Restores persistent settings 
(those unaffected by a power 
cycle, preset, or recall)
to their factory defaults.

Available only when 8648 is either the selected preset language or 
the selected remote language (see page 21).

Note
To define a user preset, set the instrument up as desired and press User Preset > Save User Preset.

Makes the increment value of the current function the active entry.

Utility > 
Instrument Adjustments >

The increment value and the step/knob ratio determine how much each 
turn of the knob changes the active function value.

For example, if the increment value of the active function is 10 dB and the 
step/knob ratio is 50 to 1, each turn of the knob changes the active 
function by 0.2 dB (1/50th of 10 dB). 

To change the amount for each turn of the knob, modify the increment 
value, the step/knob ratio, or both.

For details on each key, use key help
as described on page 26.
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Upgrading Firmware
Setting Time and Date

The signal generator’s firmware tracks the 
time and date, and uses the latest time 
and date as its time/date reference point.

Setting the Time or Date Forward

If you set the time or date forward, be aware that you are using up any installed time- based licenses, 
and that you are resetting the signal generator’s time/date reference point. When you set a new time 
or date that is later than the signal generator’s current reference point, that date becomes the new 
reference point. If you then set the date back, you run the risk described in the next section.

Setting the Time or Date Backward

When you set the time back, the signal generator notes that the time has moved back from the 
reference point. If you set the time back more a few hours, you disable the signal generator’s ability 
to use time- based licenses, even if there is no license installed at the time that you set the time back. 
In this case, you can reenable the signal generator’s ability to use time- based licenses by moving the 
clock forward to the original time or simply waiting that length of time.

Upgrading Firmware
For information on new firmware releases, go to http://www.agilent.com/find/upgradeassistant.

Changing the time or date can 
adversely affect the signal 
generator’s ability to use time−based 
licenses, even if a time−based 
license is not installed.

Utility > 
Instrument Adjustments >CAUTION

Original time/date reference point

Time

New time/date reference point
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Remote Operation Preferences
Remote Operation Preferences
For details on operating the signal generator remotely, refer to the Programming Guide.

GPIB Address and Remote Language

page 22

page 22

NOTES

USB is also available. It is not shown in the menu because it requires no configuration.

For details on using the instrument remotely, see the Programming Guide.

Select the desired language.

This setting is not persistent and is cleared by performing a 
instrument Preset. In most cases, it is best to use Utility > 
Power On/Preset > Language for a permanent language 
change. See page 23.

For details on each key, use key help as described on page 26.
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Remote Operation Preferences
Configuring the LAN Interface

Enabling LAN Services: Browser, Sockets, and VXI-11

NOTES
Use a 100Base-T LAN cable to connect the 
signal generator to the LAN. 

Use a crossover cable to connect the signal 
generator directly to a PC.

For details on using the instrument remotely, refer 
to the Programming Guide and to 
www.agilent.com and search on FAQs: Hardware 
Configurations and Installation for the Agilent 
MXG.

Utility > I/O Config

Below

Listed in the 
Programming Guide

Enable remote (browser) access to 
the instrument’s file system.

Use a browser to control the 
signal generator.

Utility > I/O Config

For details on each key, use key help
as described on page 26.

License Manager Server (On) 
allows updates of the 
instrument licenses, disable for 
additional instrument security.
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Remote Operation Preferences
Configuring the Remote Languages

Select the desired Remote language.

Utility > I/O Config >

For details on each key, use key help
as described on page 26.

This is the 3rd 
System 
Language key 
menu.
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Enabling an Option
Enabling an Option
There are two ways to enable an option: 

• Use the License Manager software utility:

1. Run the utility and follow the prompts.

2. Download the utility from www.agilent.com/find/LicenseManager and select license (.lic) files 
from an external USB memory drive.

• Use SCPI commands, as described in the Programming Guide.

Viewing Options and Licenses

Utility > 
Instrument Info

Service Software Licenses 

Waveform licenses from some 
Instrument options appear 
here. A check mark means that 
an option is enabled.

For details on each key, use key help
as described on page 26.

Signal Studio applications appear here.

appear here.
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3 Basic Operation

This chapter introduces fundamental front panel operation. For information on remote operation, 
refer to the Programming Guide.

• Presetting the Signal Generator, below

• Viewing Key Descriptions, below

• Entering and Editing Numbers and Text on page 27

• Setting Frequency and Power (Amplitude) on page 29

• Configuring a Swept Output on page 31

• Modulating the Carrier Signal on page 40

• Working with Files on page 41

• Reading Error Messages on page 53
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Presetting the Signal Generator
Presetting the Signal Generator

Viewing Key Descriptions

To return the signal generator to a known state, press either Preset or User Preset.

Preset is the factory preset; User Preset is a custom preset* (see also, page 19). 

To reset persistent settings (those unaffected by preset, user preset, or power cycle),
press: Utility > Power On/Preset > Restore System Defaults.

*You can create more than one user preset by giving each saved state file a different name (see Figure 3-7 on page 51).

The Help hardkey enables you to display a description of any hardkey or softkey.
To display help text:

1. Press Help.

2. Press the desired key.
The help displays and the key’s normal function does not execute.
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Entering and Editing Numbers and Text
Entering and Editing Numbers and Text

Entering Numbers and Moving the Cursor

Entering Alpha Characters

Data entry softkeys appear in 
various menus. If their meaning 
is not clear in context, use the 
help key (described on page 26) 
to display an explanation. Use 
the softkey next to the alpha 
table for help on the table.

Selecting data that accepts 
alpha characters, displays one of 
the menus shown at right.

Use the arrow keys or knob to 
highlight the desired letter, then 
press the Select hardkey (or the 
softkey next to the alpha table). 
To correct errors, use Bk Sp or 
Clear Text.

To terminate the entry, press the Enter softkey.

A subset of this menu appears for hexadecimal characters. The character menu displays only the 
letters A through F (use the numeric keypad for other values).

Up/down arrow keys increase/decrease a selected (highlighted) numeric value, and move the cursor vertically.

To specify a negative value, enter the
negative sign either before or after

Backspace moves the cursor to the left,
deleting characters as it goes.

Left/right arrow keys move the cursor horizontally.

Page up/down keys move tables of data up and down within the display area.

 

Use the number keys and decimal point to enter numeric data.

Note: Rotating the knob increases or
decreases a numeric value, changes a 
highlighted digit or character, or steps 
through lists or items in a row.

See also, Front Panel Knob Resolution on page 19

the numeric value (this key is a toggle).

For details on each key, see page 26.

Use the Select hardkey to choose part of an entry, as when entering alpha 
characters. In some menus, the Select key also acts as a terminator, and is 
equivalent to the Enter softkey.

to move the cursor 
within the active value 
rather than within the 
alpha table, turn the 
alpha table off.

Add/edit comments for saved 
instrument state files (see page 48).

Note: File names are limited to 25 characters.
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Entering and Editing Numbers and Text
Example: Using a Table Editor

Table editors simplify configuration tasks. The following procedure describes basic table editor 
functionality using the List Mode Values table editor.

1. Preset the signal generator: Press Preset.

2. Open the table editor: Press Sweep > More > Configure List Sweep.

The signal generator displays the editor shown in the following figure.

3. Highlight the desired item: use the arrow keys or the knob to move the cursor. 

4. (Optional) Display the selected item in the active function area: Press Select.

5. Modify the value:

• If the value is displayed in the active function area, use the knob, arrow keys, or numeric 
keypad to modify the value.

• If the value is not displayed in the active function area, use the numeric keypad to enter the 
desired value (which then appears in the active function area).

6. Terminate the entry:

• If available, press the desired units.
• If units are not displayed, press either Enter (if available) or Select.

The modified item is displayed in the table.

Cursor

Table Editor Softkeys Table Editor Name Table Items

Displays the active item as you edit it. Highlighting indicates the selected item. To make this the active (editable) 
item, either press Select, or simply enter the desired value.

Table items are also 
called data fields.

Used to load, navigate, modify, and 
store table item values. For details 
on each key, use the key help: 
Press the Help hardkey and then 
the desired key.

Active Function Area

Current / Total Number of Pages

Indicates that 
another menu 
is available; to 
display the 
second menu, 
press More.

(vector models only)
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Setting Frequency and Power (Amplitude)

Figure 3-1 Frequency and Amplitude Softkeys

Example: Configuring a 700 MHz, −20 dBm Continuous Wave Output
1. Preset the signal generator.

The signal generator displays its maximum specified frequency and minimum power level (the 
front panel display areas are shown on page 8).

2. Set the frequency to 700 MHz: Press Freq > 700 > MHz. 

The signal generator displays 700 MHz in both the FREQUENCY area of the display and the active 
entry area.

3. Set the amplitude to −20 dBm: Press Amptd > –20 > dBm.

The display changes to −20 dBm in the AMPLITUDE area of the display, and the amplitude value 
becomes the active entry. Amplitude remains the active function until you press another function 
key.

4. Turn on the RF Output: Press RF On/Off.

The RF Output LED lights, and a 700 MHz, −20 dBm CW signal is available at the RF OUTPUT 
connector.

 

page 59

To display the next menu, press More.

page HI

For details on each key, use key help
as described on page 26.

page 30
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Using an External Reference Oscillator

When using an external reference, you can select either narrow or wide bandwidth mode.

Figure 3-2 Using an External Reference Oscillator

 

For details on each key, use key help as described on page 26.

Range: 1 - 50 MHz

For guaranteed operation below 2 MHz, select Narrow bandwidth; in Wide bandwidth, 
operation using frequencies below 2 MHz is not guaranteed.

Freq > More

Int = uses the signal generator’s internal reference oscillator.

Auto = uses the signal generator’s internal reference unless a signal is present at the rear 
panel REF IN connector. If an external signal is present, that signal is used as the 
reference.

Figure 3-2 illustrates the better close in phase noise of the wide bandwidth mode. If the 
external reference you are using is noisy or spurious, use the narrow bandwidth mode.

With Wide bandwidth selected, If you select a frequency less than 2 MHz, the signal 
generator displays a warning message.
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Configuring a Swept Output
The signal generator has two methods of sweeping through a set of frequency and amplitude points:

Step sweep (page 32) provides a linear or logarithmic progression from one selected frequency, or 
amplitude, or both to another, pausing at linearly or logarithmically spaced points (steps) along the 
sweep. The sweep can progress forward, backward, or manually. 

List sweep (page 34) enables you to enter frequencies and amplitudes at unequal intervals, in 
nonlinear ascending, descending, or random order. List sweep also enables you to copy the current 
step sweep values, include an Arb waveform in a sweep (on a vector instrument), and save list sweep 
data in the file catalog (page 46).

Figure 3-3 Sweep Softkeys

Sweep without waiting for 
a trigger at each point. 
Point Trigger pauses for the dwell 
time prior to the first sweep. See 
page 64.

Apply a TTL/CMOS signal to the 
Trigger In connector.

Periodically issue a trigger event to 
whatever selects it as a source.

Using timer trigger with single 
sweep results in a delay prior to the 
first sweep. See page 64.

Trigger on a remote command.

Down sweeps from 
stop to start 
frequency/amplitude.

Up sweeps from start 
to stop 
frequency/amplitude.

page 34

The selected sweep type determines the displayed parameter. 
Selecting step sweep also displays the step spacing (Lin or Log).

On vector models:
Available when 
Sweep Type = List

page 38

During a sweep, the swept parameter (frequency, amplitude, or both) turns grey and changes as the parameter sweeps.

Progress Bar: very fast sweeps can 
appear to sweep randomly or backward.

page 39

For details on each key, use key help as described on page 26.

 page 32

Does not effect 
Sweep Out BNC 
or TRig Out BNC 
signals that are 
routed as Source 
Settled (See 
page 39).
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Step Sweep

Step sweep provides a linear or logarithmic progression from one selected frequency, or amplitude, or 
both, to another, pausing at linearly or logarithmically spaced points (steps) along the sweep. The 
sweep can progress forward, backward, or be changed manually. 

Figure 3-4 Sweep Softkeys

Example: Configuring a Continuous, Linear Step Sweep

1. Preset the instrument and open the Sweep/List menu: Press Preset > SWEEP.

Because continuous is the default sweep repeat selection, and linear is the default step spacing 
selection, you do not need to set these parameters.

2. Open the step sweep menu: Press Configure Step Sweep.

3. Set the following parameters:

4. Sweep both frequency and amplitude: Press Return > Return > Sweep > Freq Off On > Amptd Off On.

A continuous sweep begins, from the start frequency/amplitude to the stop frequency/amplitude. 
The SWEEP annunciator displays, and sweep progress is shown in the frequency display, the 
amplitude display, and the progress bar.

Output: A signal that continuously sweeps from 500 to 600 MHz and from −20 to 0 dBm, with a 
dwell time of 500 ms at each of six equally−spaced points.

Start frequency 500 MHz: Press Freq Start > 500 > MHz

Stop frequency 600 MHz: Press Freq Stop > 600 > MHz

Amplitude at the beginning of the sweep, −20 dBm: Press Amptd Start > −20 > dBm

Amplitude at the end of the sweep, 0 dBm: Press Amptd Stop > 0 > dBm.

6 sweep points: Press # Points > 6 > Enter

Dwell time at each point, 500 milliseconds: Press More > Step Dwell > 500 > msec

Dwell Time = the time that the signal is settled and you can make 
a measurement before the sweep moves to the next point.

(Point-to-point time is the sum of the value set for the dwell plus 
processing time, switching time, and settling time.) 

Lin = steps equally spaced over the sweep; the output changes 
linearly.

Log = step spacing increases logarithmically over the sweep; the 
output changes exponentially.

Step Sweep and List Sweep dwell times are set independently.

For details on each key, use key help
as described on page 26.
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5. Turn the RF output on: Press RF On/Off. 

The RF LED lights, and the continuous sweep is available at the RF Output connector.
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List Sweep

List sweep enables you to enter frequencies and amplitudes at unequal intervals in nonlinear 
ascending, descending, or random order. List sweep also enables you to copy the current step sweep 
values, include a waveform in a sweep (on a vector instrument), and save list sweep data in the file 
catalog (page 46). Dwell time is editable at each point.

Figure 3-5 List Sweep Configuration Softkeys and Display

see page 35

The selected sweep determines which dwell time the signal generator uses. Step Sweep dwell 
time is the same at each point; List Sweep dwell time can be different at each point.

Dwell Time = the time that the signal is settled and you can make a measurement before the 
sweep moves to the next point.

Point-to-Point Time = the sum of the value set for the dwell plus processing time, switching 
time, and settling time. 

Each line defines the 
corresponding point in 
the sweep. For example, 
line 1 defines point 1.

page 32

Available only on vector models, 
and 
only when Sweep Type = List.

Displays the selected 
sweep type parameters 
(see page 35)

Vector models only

page 39

For details on each key, use key help
as described on page 26.

Available only when 
waveform entry is selected
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Example: Configuring a List Sweep Using Step Sweep Data
1. Set up the desired step sweep, but do not turn the sweep on. This example uses the step sweep 

configured on page 32.

2. In the SWEEP menu, change the sweep type to list: 
Press SWEEP > Sweep Type List Step to highlight List. 

The display shows sweep list parameters, as shown below.

3. Open the List Sweep menu: Press More > Configure List Sweep.

4. Clear any previously set values from the menu and load the points defined in the step sweep into 
the list: Press More > Preset List > Preset with Step Sweep > Confirm Preset. 

The display updates with the values loaded from the step sweep, as shown.

5. Sweep frequency and amplitude: Press SWEEP (hardkey) > Sweep > Freq Off On > Amptd Off On.

Setting the sweep turns on the sweep function; a continuous sweep begins. On the display, the 
SWEEP annunciator appears, and the progress bar shows the progression of the sweep.

6. If not already on, turn the RF output on: Press RF On/Off. 
The RF Output LED lights, and a continuous sweep is available at the RF OUTPUT connector.

Vector Models:

Presetting the list clears 
any previously selected 
waveforms. 

For information on 
selecting a list sweep 
waveform, see Example: 
Editing List Sweep 
Points on page 36.

Waveforms are available 
only on vector models.
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Example: Editing List Sweep Points

If you are not familiar with table editors, refer to page 28.

1. Create the desired list sweep. This example uses the list sweep created in the previous example.

2. If sweep is on, turn it off. Editing list sweep parameters with sweep on can generate an error. 

3. Ensure that the sweep type is set to list: Press SWEEP > Sweep Type List Step to highlight List. 

4. In the List Mode Values table editor, change the point 1 dwell time (defined in row 1) to 100 ms:

a. Press More > Configure List Sweep.
b. Highlight the point 1 dwell time.
c. Press 100 > msec.

The next item in the table (the frequency value for point 2) highlights.

5. Change the selected frequency value to 445 MHz: Press 445 > MHz.

6. Add a new point between points 4 and 5: Highlight any entry in row 4 and press Insert Row. 

This places a copy of row 4 below row 4, creating a new point 5, and renumbers subsequent rows.

7. Shift frequency values down one row, beginning at point 5: Highlight the frequency entry in row 
5, then press More > Insert Item.

This places a copy of the highlighted frequency value in row 6, shifting the original frequency 
values for rows 6 and 7 down one row. The new row 8 contains only a frequency value (the 
power and dwell time entries do not shift down).

8. Change the still- active frequency value in row 5 to 590 MHz: Press 590 > MHz. The power in row 5 
is now the active parameter.

9. Insert a new power value (−2.5 dBm) for point 5, and shift down the original power values for 
points 5 and 6 by one row: Press Insert Item > −2.5 > dBm. 

10. To complete the entry for point 8, insert a duplicate of the point 7 dwell time by shifting a copy 
of the existing value down: Highlight the dwell time in row 7 and press Insert Item.

11. For an analog instrument, go to step 14. For a vector instrument, continue with step 12.

12. Select a waveform for point 2:

a. Highlight the waveform entry for point 2 and press the More > Select Waveform.
The signal generator displays the available waveforms, as shown in the following example.

b. Highlight the desired waveform (in this example, SINE_TEST) and press either the Select 
hardkey or the Select Waveform softkey.

Either select a waveform,

or 

select no modulation.
36 Agilent N5181A/82A MXG Signal Generators User’s Guide



Basic Operation
Configuring a Swept Output
13. As desired, repeat step 12 for the remaining points for which you want to select a waveform. The 
following figure shows an example of how this might look.

14. Turn sweep on: 
Press Return > Return > Return > Sweep > Freq Off On > Amptd Off On > Waveform Off On.

15. If it is not already on, turn the RF output on: 
Press RF On/Off. 

The SWEEP annunciator appears on the display, indicating that the signal generator is sweeping, 
and the progress bar shows the progression of the sweep. 

NOTE If the instrument is in manual sweep (page 38), the active row (row 6 in the figure above) is 
the selected (manual) point, and the signal generator outputs the settings for that selection 
when the RF output is on.

Example: Using a Single Sweep
1. Set up either a step sweep (page 32) or a list sweep (page 35).

2. In the List/Sweep menu, set the sweep repeat to single: 
Press Sweep Repeat Single Cont to highlight Single.

Sweep does not occur until you trigger it.

Note that the WINIT annunciator appears on the display, indicating that the sweep is waiting to 
be initiated.

3. If not already on, turn the RF output on: Press RF On/Off.

4. Initiate the sweep: Press Single Sweep.

A single repetition of the configured sweep is available at the RF Output connector. 

As the signal generator sweeps, the SWEEP annunciator replaces WINIT on the display, and the 
progress bar shows the progression of the sweep. 

At the end of the sweep, there is no progress bar, and the WINIT annunciator replaces SWEEP.

The empty entry is equivalent to 
choosing CW (no modulation).
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Example: Manual Control of Sweep
1. Set up either a step sweep (page 32) or a list sweep (page 35).

2. In the Sweep/List menu, select a parameter to sweep: Press Sweep > parameter > Return.

3. Select manual mode: Press More > Manual Mode Off On.

When you select manual mode, the current sweep point becomes the selected manual point.

4. If it is not already on, turn the RF output on: Press RF On/Off.

5. Select the desired point to output: Press Manual Point > number > Enter.

The progress bar changes to indicate the selected point.

6. Use the knob or arrow keys to move from point to point. As you select each point, the RF output 
changes to the settings in that selection.

The parameters of the selected sweep point (point 3 
of 6 in this example) define the signal available at the 
RF Output connector.

When you enter a manual point, 
the progress bar moves to and 
stops at the selected point.

The SWMAN annunciator 
indicates that the sweep 
is in manual mode.

When you turn manual mode on, the 
current sweep point becomes the 
manual point.

The currently sweeping 
parameter stops and 
displays the selected point.
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Routing Signals

Sweep > More > More > Route Connectors

Select the signal that you want routed 
to each output connector.

For details on each key, use key help
as described on page 26.

These 
softkeys are 
only available 
for the 
N5182A with 
a BBG.

These softkeys are only 
available on a N5182A 
with a BBG. 

This softkey controls the 
Event 2 marker control 
(N5182A only) on the rear 
panel TRIG OUT BNC 
connector.Source Settled is not effected by Trig 

Out Polarity Neg Pos softkey 
selections (see page 31).
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Modulating the Carrier Signal
To modulate the carrier signal, you must have both 

• an active modulation format
and

• modulation of the RF output enabled

Example
1. Preset the signal generator.

2. Turn on AM modulation: Press AM > AM Off On (requires Option UNT).

You can turn on the modulation format before or after setting signal parameters.

The modulation format generates, but does not yet modulate the carrier signal.

Once the signal generates, an annunciator showing the name of the format appears, indicating 
that a modulation format is active.

3. Enable modulation of the RF output: Press the Mod On/Off key until the LED lights.

If you enable modulation without an active modulation format, the carrier signal does not 
modulate until you subsequently turn on a modulation format.

NOTE

NOTE To turn modulation off, press the Mod On/Off key until the LED turns off.

When the Mod On/Off key is off, the carrier signal is not modulated, even with an active 
modulation format.

 

Annunciator indicates active AM modulation

AM modulation format on.

A lit LED indicates that any 
active modulation format can 
modulate the carrier.
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4. To make the modulated carrier available at the RF output connector, press the RF On/Off key until 
the LED lights.

Simultaneous Modulation

NOTE The Agilent MXG is capable of simultaneous modulation. All modulation types (AM, FM, φM, 
and Pulse) may be simultaneously enabled. But, there are some exceptions. Refer to 
Table 3- 1.

Working with Files

• File Softkeys on page 43

• Viewing a List of Stored Files on page 44

• Storing a File on page 45

• Loading (Recalling) a Stored File on page 46

• Moving a File from One Media to Another on page 47

• Working with Instrument State Files on page 48

• Selecting the Default Storage Media on page 52

The signal generator recognizes several types of files, such as instrument state files, license files, and 
list sweep files. Files can be stored either in the signal generator’s internal storage or on the USB 
media. This section provides an overview of how to navigate the signal generator’s file menus, and 
how to view, store, load, and move files.

See also: “Using Analog Modulation (Option UNT Only)” on page 67
“Using Pulse Modulation (Option UNU or UNW)” on page 71
“I/Q Modulation” on page 138

Table 3-1 Simultaneous Modulation Type Combinations

AMa

aLinear AM and Exponential AM cannot be enabled simultaneously. Refer to Chapter 5.

FM φM Pulseb

bPulse modulation requires Option UNU or UNW. Refer to Chapter 6.

AM - - x x x

FM x - - not applicable x

φM x not applicable - - x

Pulse x x x - -
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See also: Storing, Loading, and Playing a Waveform Segment on page 84.
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File Softkeys

Instrument operating parameters (see page 48).

Sweep data from the List Mode Values table editor.

User flatness calibration corrections.

page 214

Note: Available file types depend on the installed options.

Waveform files and their 
associated marker and 
header information.

For details on each key, use key help as described on page 26.

Deletions require confirmation

Available only with USB connected 
(i.e. Without external USB connected, 
softkeys are greyed out).

page 52

This key changes, depending on 
the selected file. See page 46.

Shows the current directory

page 47

page 47

Requires 
confirmation

The display indicates when the current directory is the default storage path. 
For information on setting the default storage path, see page 52.

When you connect USB media to the instrument, the signal generator displays the USB Media menu and the message External USB Storage attached. When you 
disconnect the USB media, the message External USB Storage detached displays. When you open the External Media menu without USB media connected, the 
signal generator displays the message External Media Not Detected.

The signal generator does not 
format USB media or change file 
permissions. Use a computer to 
perform these operations.

Available only when the 
current directory is not the 
top level directory.

Display internal or USB files, 
depending on the selected
storage media. 
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Viewing a List of Stored Files

The information in this section is provided with the assumption that default storage media is set to 
Auto, as described on page 52.

Viewing a List of Files Stored in the Signal Generator
1. If USB media is connected, disconnect it. The signal generator’s storage media switches to 

internal, so you can now use the file catalogs to see files stored in the signal generator.

2. Select the desired file catalog: Press File > Catalog Type > desired catalog (in this example, All). The 
selected files appear in alphabetical order by file name, as shown in the following figure. 

Viewing a list of Files Stored on USB Media

With USB media connected, you can view files on USB media using either the file catalogs, which can 
display only a selected type of file, or the USB File Manager, which displays all files.

Using the File Catalogs:

• With the USB media connected, select the desired file catalog: press File > Catalog Type > 
desired catalog. The selected files appear in alphabetical order by file name. 

Using the USB File Manager:

• With USB media connected, open the USB File Manager: press File > More > USB File Manager. 
The instrument displays the default directory on the USB Media, as shown in the following figure. 
Note that when you attach USB media, the display goes directly to this menu.

The selected file catalog and 
the storage media

Use the Page Up and Page Down 
hardkeys to scroll through the 
contents of the directory.
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Storing a File

Several menus enable you to store instrument parameters. For example, you can store instrument 
states, lists, and waveforms.

• An instrument state file contains instrument settings. For this type of file, use the Save hardkey 
shown in Figure 3- 6 on page 48.

• For other types of data, use the Load/Store softkey (shown below) that is available through the 
menu used to create the file. 

Use this menu to enter the file name, 
as described on page 27.

For details on each key, use key help as described on page 26.

File Type
List
State
Waveform
User Flatness
User Preset

Save From
Sweep menu
Save menu
Mode menu
Amplitude menu
User Preset menu

File Length (including extension)

Internal Media: 25 characters

USB Media: 39 characters
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Loading (Recalling) a Stored File

There are several ways to load (recall) a stored file.

• For an instrument state file, use the Recall hardkey shown in Figure 3- 6 on page 48.

• For other types of data, use the Load/Store softkey (shown below) that is available through the 
menu used to create the file. 

Loading a File From USB Media

To load a file from USB media, use the USB file manager shown below.

File Type
List
State
Waveform
User Flatness
User Preset

Recall From
Sweep menu
Save menu
Mode menu
Amplitude menu
User Preset menu

This key changes, depending 

on the selected file. 

File > Catalog Type > <type> > More > USB File Manager 
or
File > More > USB File Manager
or
Insert the USB media

Copy & Select User Flatness
Copy & Play Waveform

Copy & Play Sequence

Enter Directory
Recall Instrument State
Load List

Install licenses
No action (USB disconnected)
Use As

If the signal generator does not recognize the 
file, you must select how the file is to be used.

File Type
List
State
Waveform
User Flatness
User Preset
License

Extension
.list
.state
.waveform
.uflat
.uprst
.lic

Pressing Select with file highlighted...
loads list and starts sweep
load instrument state
loads and plays waveform
loads and applies user flatness
loads and executes user preset
installs purchased license

For details on each key, use key help as described on page 26.
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Moving a File from One Media to Another

Use the USB Media Manager to move files between USB and internal media.

Selecting a waveform or 
an unknown file type 
displays this softkey.

File > Catalog Type > <type> > More > USB File Manager
or
File > More > USB File Manager
or
Insert the USB media

For details on each key, use key help as described on page 26.

This key changes, 
depending on the selected 
file. See page 46

Whether a menu is available 

depends on the selected file. 

Requires confirmation

Catalog Type Menu
page 43

Requires confirmation

Moves up one 
directory level
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Working with Instrument State Files
• Saving an Instrument State on page 49.

• Saving a User Preset on page 49.

• Recalling an Instrument State on page 49.

• Recalling an Instrument State and Associated Waveform File on page 50.

• Recalling an Instrument State and Associated List File on page 50.

• Moving or Copying a Stored Instrument State on page 51.

Figure 3-6 Save and Recall Softkeys

The following information is not stored in a state file:

System Security Level List Mode Freq Hostname Remote Language FM Deviation

System Security Level Display List Mode Power IP Address FTP Server PM Deviation

System Security Level State List Mode Dwell Subnet Mask Manual DHCP MAC

Web Server (HTTP) List Mode Sequence Default Gateway VXI- 11 SCPI User Power Correction

Sockets SCPI (TELNET) Display State On/Off ARB Files List Files I/Q Calibration Data

When saved to the signal generator, instrument settings 
(states) save to instrument state memory. Instrument state 
memory is divided into 10 sequences (0 through 9); each 
sequence comprises 100 registers (00 through 99).

Delete softkeys in the Save and Recall menus enable you 
to delete the contents of a specific register, or the contents 
of all sequences in the state file catalog. 

The signal generator requires that you confirm a deletion.

For details on each key, use key help
as described on page 26.
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Saving an Instrument State
1. Preset the signal generator and set the following:

2. (Optional, vector models only) Associate a waveform file with these settings: 

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight the desired file and press Select Waveform. If the file is not listed, you must first 

move it from internal or external media to BBG media, see page 84. 

3. Select the desired memory sequence (for this example, 1): Press Save > Select Seq > 1 > Enter.

4. Select the desired register (in this example, 01): Press Select Reg > 1 > Save Reg. 

If a waveform is currently selected, saving the instrument state also saves a pointer to the 
waveform file name. 

5. Add a descriptive comment to sequence 1 register 01: 

Press Add Comment to Seq[1] Reg[01], enter the comment and press Enter. The comment appears in 
the Saved States list when you press Recall. If the instrument state has an associated waveform, 
entering the waveform name in the comment makes it easy to identify which instrument state 
applies to which waveform. 

Saving a User Preset

A user preset is a special type of instrument state file.

1. Preset the signal generator and set as desired.

2. Press User Preset > Save User Preset.

This saves a state file named USER_PRESET, which the signal generator recognizes as containing 
user preset information.

You can set up several preset conditions under different names:

1. After you save a user preset, rename it to something other than USER_PRESET (see page 51). 

2. Save as many user presets as you wish, renaming the USER_PRESET file each time.

3. Give the desired file the name USER_PRESET.

Recalling an Instrument State
1. Preset the signal generator.

2. Press Recall.

The Select Seq softkey shows the last sequence used, and the display lists any states stored in the 
registers in that sequence; RECALL Reg is the active entry. 

3. Select the desired instrument state: 

If the desired state is listed in the currently selected sequence, press desired number > Enter.
If not, press Press Select Seq > desired number > Enter > RECALL Reg > desired number > Enter.

• Frequency: 800 MHz • Amplitude: 0 dBm • RF: on
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Recalling an Instrument State and Associated Waveform File 
1. Ensure that the desired waveform file exists, and that it is in BBG media (page 84). 

If the waveform file is not in BBG media, this procedure generates an error.

Recalling an instrument state with an associated waveform file recalls only the waveform name. It 
does not recreate the waveform file if it was deleted, or load the file into BBG media if it is in 
internal or USB media.

2. Recall the desired instrument state (see previous example).

3. View the waveform file name recalled with the instrument state: press Mode > Dual ARB.

The name is displayed as the selected waveform. 

4. Turn on the waveform file: Press Mode > Dual ARB > ARB Off On.

Recalling an Instrument State and Associated List File 

Recalling an instrument state recalls only the list sweep setup. It does not recall the frequency 
and/or amplitude values. Because you must load the list file from the file catalog, when you store a 
list file, be sure to give it a descriptive name (up to 25 characters).

1. Recall the desired instrument state (see previous example).

2. Load the desired list file: 

a. Press Sweep > More > Configure List Sweep > More > Load/Store.

b. Highlight the desired file and press Load From Selected File > Confirm Load From File.

Editing The Comment on an Instrument Comment

Use the following steps to change a comment on an instrument state saved using the Save key. This 
is not the file name that appears in the State catalog (which is the file’s memory location).

1. Press Save

2. Highlight the desired register

3. Press Edit Comment In Seq[n] Reg [nn].

4. Press Re-SAVE Seq[n] Reg[nn]. 

This overwrites previously saved instrument state settings with the new comment. 
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Basic Operation
Working with Files
Moving or Copying a Stored Instrument State

Figure 3-7 Instrument State File Catalog

A user- created state file’s default name is its memory location (sequence and register).

To move the file, rename it to the desired sequence and register; you can not give a file the same 
name as an existing file. If you rename a state file to something other than a valid sequence/register 
name, the file does not appear in either the Save or Recall menu.

Sequence Register

The signal generator recognizes only the file named USER_PRESET as user preset information (page 49). 
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Basic Operation
Working with Files
Selecting the Default Storage Media

You can configure the signal generator to store user files to either the internal storage or to external 
USB media. To automatically switch between USB media and internal storage, depending on whether 
USB media is attached, select Automatically Use USB Media If Present. To avoid storing any confidential 
information in the instrument, select Use Only USB Media. To avoid storing any confidential information 
to USB media, select Use Only Internal Storage.

This selection is unaffected by power−cycle or preset.

File > More > 

Current 
selection

Memory in the instrument is used, and USB media is ignored.

Media attached to the front panel USB connector is used, and no user 
data is stored to internal storage.

This is the recommended selection. When USB media is attached to the 
front panel, it is the selected media; when USB media is not attached, 
internal storage is used.

For details on each key, use key help as described on page 26.

Select the directory on the USB media to be used for all file operations 
when USB media is attached and enabled.
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Basic Operation
Reading Error Messages
Reading Error Messages
If an error condition occurs, the signal generator reports it to both the front panel display error 
queue and the SCPI (remote interface) error queue. These two queues are viewed and managed 
separately; for information on the SCPI error queue, refer to the Programming Guide.

Error Message Format

In the front panel display 
error queue, error 
messages display on an 
enumerated (“1 of N”) 
basis.

Characteristic Front Panel Display Error Queue

Capacity (#errors) 30

Overflow Handling Drops the oldest error as each new error comes in.

Viewing Entries Press: Error > View Next (or Previous) Error Page

Clearing the Queue Press: Error > Clear Error Queue(s)

Unresolved Errorsa

aErrors that must be resolved. For example, unlock.

Re- reported after queue is cleared.

No Errors
When the queue is empty (every error in the queue has been read, or the queue is cleared), the 
following message appears in the queue:
No Error Message(s) in Queue 0 of 0

Error Number Error Message
Error Description

(May be truncated on the display)

−222 Data out of range; value clipped to lower limit.

Indicates that the user has entered a deviation, depth, or internal 
source frequency that is beyond the specific limits 

Explanation is provided in the Error Message file (see page 226)
(This is not displayed on the instrument)

Message number and longer description

new indicates a message generated 
since messages were last viewed.

The annunciator indicates an unviewed message.

Error messages appear in the lower-left corner 
of the display as they occur.
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Reading Error Messages
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4 Optimizing Performance

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting the power level and frequency, refer to 
Chapter 3, “Basic Operation,” on page 25 and familiarize yourself with the information in that 
chapter.

• Using User Flatness Correction on page 56

• Using Unleveled Operating Modes on page 59

• Using an Output Offset, Reference, or Multiplier on page 61

• Using Free Run, Step Dwell, and Timer Trigger on page 64

• Using a USB Keyboard on page 66
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Optimizing Performance
Using User Flatness Correction
Using User Flatness Correction
User flatness correction enables you to adjust the RF output amplitude for up to 1601 sequential 
linearly or arbitrarily spaced frequency points to compensate for external losses in cables, switches, 
or other devices. 

You can create and save individual user flatness correction tables, which enables you to recall 
different correction arrays for various test setups or frequency ranges (see page 58).

Figure 4-1 User Flatness Correction Softkeys

Basic Procedure
1. Create a user flatness array: Enter the user flatness correction values.

2. Optionally, save the user flatness correction data.

3. Apply user flatness correction to the RF Output.

Confirm

For details on each key, use key help
as described on see page 26.
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Optimizing Performance
Using User Flatness Correction
Example: A 500 MHz to 1 GHz Flatness Correction Array with 10 Correction Values

Create the User Flatness Array

1. Configure the signal generator:

a. Preset the signal generator.

b. Open the User Flatness table editor and preset the cal array:
Press Amptd > More > User Flatness > Configure Cal Array > More > Preset List > Confirm Preset.

c. In the Step Array menu, enter the desired flatness- corrected frequencies: 

d. Populate the user flatness correction array with the step array configured in the previous 
step: 

Press Return > Load Cal Array From Step Array > Confirm Load From Step Data.

e. Set the output amplitude to 0 dBm.

f. Turn on the RF output.

2. Connect the power meter to the RF output and manually enter the correction values:

a. Open the User Flatness table editor and highlight the frequency value in row 1: 
Press More > User Flatness > Configure Cal Array.

The RF output changes to the frequency value of the table row containing the cursor. 

b. Note the value measured by the power meter.

c. Subtract the measured value from 0 dBm

d. Highlight the correction value in row 1.

e. Press Select > the difference calculated in step c > Enter.

The signal generator adjusts the output amplitude based on the correction value entered.

f. If the power meter does not read 0 dBm, adjust the value in step e until it does.

g. Highlight the frequency value in the next row. 

h. Repeat steps b through g for this and the remaining rows.

The user flatness correction array title displays User Flatness:, without a name, indicating that 
the current user flatness correction array data has not been saved to the file catalog.

Press Configure Step Array > 

Freq Start > 500 > MHz >

Freq Stop > 1 > GHz >

# of Points > 10 > Enter
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Optimizing Performance
Using User Flatness Correction
Optional: Save the User Flatness Correction Data

1. Press Load/Store > Store to File.

2. Enter a file name (for this example, FLATCAL1) and press Enter.

The user flatness correction array file is now stored in the file catalog as a UFLT file. Any user 
flatness correction files saved to the catalog can be recalled, loaded into the correction array, and 
applied to the RF output to satisfy specific RF output flatness requirements.

3. Press Return.

Enable the Flatness Correction at the RF Output

• Press Return > Flatness Off On.

The UF annunciator appears in the AMPLITUDE area of the display, and the correction data in the 
array is applied to the RF output.

Recalling and Applying a User Flatness Correction Array

The following example assumes that a user flatness correction array has been created and stored. If 
not, perform the Example: A 500 MHz to 1 GHz Flatness Correction Array with 10 Correction 
Values on page 57.

1. Preset the signal generator.

2. Recall the desired User Flatness Correction file:

a. Press AMPTD > More > User Flatness > Configure Cal Array > More > Preset List > Confirm Preset.

b. Press More > Load/Store.

c. Highlight the desired file.

d. Populate the user flatness correction array with the data contained in the selected file: 
Press Load From Selected File > Confirm Load From File.

The user flatness correction array title displays User Flatness: Name of File.

3. Apply the correction data in the array to the RF output: Press Return > Flatness Off On.
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Optimizing Performance
Using Unleveled Operating Modes
Using Unleveled Operating Modes

Figure 4-2 Power Search and ALC Off Softkeys

ALC Off Mode

Turning ALC off deactivates the signal generator’s automatic leveling circuitry, enabling you to 
measure the output at a specific point in a test setup and adjust as required for the desired power 
level at that point. Turning ALC off is useful when the modulation consists of very narrow pulses 
that are below the pulse width specification of the ALC, or when the modulation consists of slow 
amplitude variations that the automatic leveling would remove.

1. Preset the signal generator.

2. Set the desired frequency.

3. Set the desired amplitude.

4. Connect the power meter to the point at which you want a specific power level.

5. Turn the RF output on.

6. Deactivate the signal generator’s automatic leveling control: Press AMPTD > ALC Off On to 
highlight Off.

7. Adjust the signal generator’s amplitude until the power meter measures the desired level.

Available only when
ALC = Off

Available only when
Power Search Reference =

Available only when 
Power Search = Span 

Auto: The calibration routine executes whenever 
output frequency or amplitude changes.

Span: Pressing Do Power Search executes the 
power search calibration routine once over a 
selected frequency range.

The corrections are stored and used whenever you 
tune the signal generator to within the calibrated 
frequency range.

For details on each key, use key help
as described on see page 26.

RMS: Value is a DC 
bias equivalent to the 
value derived from the 
file header or the 
calculated value from 
the current I/Q data.
Fixed: Uses a fixed 
1.0V DC bias value 
(Same value is used 
with Ext I/Q data).
Manual: Allows user to 
specify the DC bias 
voltage value (0-1V).
Modulated: Uses the 
AC bias from the actual 
modulating signal.

Manual

User: Enables the 
user to set the 
signal generator 
frequency settings.

Full: The signal 
generator selects 
its full frequency 
range for the power 
search.

Only available when 
I/Q is on and I/Q 
Source is set to 
External.
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Optimizing Performance
Using Unleveled Operating Modes
Power Search Mode

Refer to Figure 4- 2 on page 59. Power search executes a routine that temporarily activates the ALC, 
calibrates the power of the current RF output, and then disconnects the ALC circuitry. 

NOTE For the power search routine to execute, RF must be on and ALC must be off.

Example: Automatic Power Search
1. Preset the signal generator.

2. Set the desired frequency.

3. Set the desired amplitude.

4. Turn the RF output on.

5. Deactivate the signal generator’s automatic leveling control: 

Press AMPTD > ALC Off On to highlight Off

Deactivating the signal generator’s automatic leveling control is a significant instrument change 
that automatically initiates a power search.

When set to Auto, power search automatically executes when a significant instrument setting changes. 
The Do Power Search feature enables you to execute a power search to compensate for other changes, 
such as temperature drift or a change in the external input.
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Optimizing Performance
Using an Output Offset, Reference, or Multiplier
Using an Output Offset, Reference, or Multiplier

Setting an Output Offset

Using an output offset, the signal generator can output a frequency or amplitude that is offset 
(positive or negative) from the entered value.

RF Output = entered value − offset value

Displayed Value = output frequency + offset value

To set an offset:

• Frequency: Press Freq > Freq Offset > offset value > frequency unit.

• Amplitude: Press Amptd > More > Amptd Offset > offset value > dB.

Examples

When using the signal generator as a local oscillator (LO), you can use the offset to display the 
frequency of interest, as illustrated below:

Parameter
Example

#1
Example

#2
Example

#3 Comments

Entered (and displayed) Value: 300 MHz 300 MHz 2 GHz The entered value must be positive.

Offset: 50 MHz −50 MHz −1 GHz An offset value can be positive or negative.

Output Frequency: 250 MHz 350 MHz 3 GHz The signal generator alerts you if the 
output frequency or amplitude is out of range.

Indicates that an offset is on

IF AmplifierRF Amplifier Mixer Filter

Signal Generator
(local oscillator)

Output Frequency = 1000 MHz

IF = 321 MHz

Antenna tuned to 1321 MHz

Selected Offset

321 MHz

−679 MHz

SIgnal Generator Display

1321 MHz  (Antenna Frequency)

321  MHz (IF Output)

IF Output
321 MHz
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Optimizing Performance
Using an Output Offset, Reference, or Multiplier
Setting an Output Reference

Using an output reference, the signal generator can output a frequency or amplitude that is offset 
(positive or negative) by the entered value from a chosen reference value. 

RF Output = reference value + entered value

To set a reference:

1. Set the frequency or amplitude to the value you want as the output reference level.

2. Frequency: Press Frequency > Freq Ref Set 
The frequency displays 0.00 Hz, indicating that this is the RF output frequency “zero level.” 
All frequencies entered are interpreted as being relative to this reference frequency.

Amplitude: Press Amptd > More > Amptd Ref Set
The amplitude displays 0.00 dB, indicating that this is the RF output amplitude “zero level.”
All amplitudes entered are interpreted as being relative to this reference amplitude.

Examples

To set a new frequency or amplitude reference, turn the frequency reference off, and then follow the 
steps above.

Parameter Example
#1

Example
#2

Example
#3

Comments

Reference: 50 MHz 50 MHz 2 GHz A reference value must be positive.

Entered (and displayed) Value: 2 MHz −2 MHz −1 GHz The entered value can be positive or negative.

Output Frequency: 52 MHz 48 MHz 1 GHz
The signal generator alerts you if the output frequency or 
amplitude is out of range.

Indicates that a reference is on
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Optimizing Performance
Using an Output Offset, Reference, or Multiplier
Setting a Frequency Multiplier

Using a frequency multiplier, the signal generator can display a frequency that is the multiple 
(positive or negative) of the output value. 

Displayed Value = multiplier value × output frequency

Output Frequency = displayed value ÷ multiplier value

To set a frequency multiplier:

1. Press Frequency > Freq Multiplier > multiplier value > x.

2. Set the desired frequency.
The display equals the output frequency times the multiplier value.

Examples

When using the signal generator as the input to a system, you can set the frequency multiplier so 
that the signal generator displays the output of the system, as illustrated below using a doubler:

Parameter
Example

#1
Example

#2
Example

#3 Comments

Frequency Multiplier: 3 −3 4 A multiplier value can be positive or negative.

Entered (and displayed) Value: 600 MHz −600 MHz 8 GHz

Output Frequency: 200 MHz 200 MHz 2 GHz The signal generator alerts you if the output frequency is 
out of range.

Indicates that a frequency multiplier is on

Signal Generator Doubler

Output = 4 GHz
X2

Input = 2 GHz Selected
Multiplier

2

Signal Generator
Output

2 GHz

Entered/Displayed
Frequency

4 GHz
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Optimizing Performance
Using Free Run, Step Dwell, and Timer Trigger
When measuring mixers, the frequency multiplier and frequency offset are often used together. In the 
upconverter example below, the multiplier is set to −1 and the offset is set to 3 GHz so that the 
signal generator displays fRF.

Using Free Run, Step Dwell, and Timer Trigger
Free Run, Step Dwell (time), and Timer Trigger can be used to adjust the time spent at any point in 
a Step Sweep or a List Sweep. There are two possible measurement combinations:

Free Run with Step Dwell time (Figure 4- 3 on page 65) the signal generator waits for the signal to 
settle and then waits for the Step Dwell time, then it jumps to the next frequency point. In addition, 
the time to complete the entire sweep can vary. There is always a minimum value of Step Dwell for 
each frequency point. The minimum Step Dwell timing for any point is fixed at a value of 100 us. The 
time between frequency points is the sum of the settling time, plus the Step Dwell time. The settling 
time is dependent on frequency, amplitude, band crossings, and other factors, so the time between 
frequency points can vary. 

Timer Trigger instead of Free Run (Figure 4- 3 on page 65) the signal generator generates equally 
spaced triggers, and it moves to the next point at each trigger. This has the advantage that the time 
between points is consistent and the overall sweep time is consistent. But, if the trigger is too fast, 
the signal may not have time to settle before jumping to the next point.

Understanding Free Run, Step Dwell, and Timer Trigger Setup

If the signal is to be settled for a minimum specific time at each point and it is not important if the 
point- to- point time is consistent, use Free Run and Set Dwell time.

If the signal’s point- to- point time requires consistency but the specific settling time at each point can 
vary, then use the Timer Trigger. Avoid using too fast of a sweep which does not allow the signal 
generator to settle.

If the signal needs to be settled for a specific minimum time and consistent point- to- point time is 
required, then you should set the Timer Trigger to be the sum of the switching time (900 us or 5 ms, 
depending on options) plus the minimum settled time that is needed to make the measurement.

If the measurement requires external equipment synchronization, consider using hardware triggers. 

Mixer

Signal Generator
(local oscillator)

fLO = 800 − 600 MHz

fIF = 3000 MHz

Selected
Multiplier

−1

−1

Signal Generator
Output (fLO)

800 MHz

600 MHz

fRF = 2200 - 2400 MHz

Selected
Offset

3000 MHz

3000 MHz

Entered/Displayed
Frequency
(fRF)

2200 MHz

2400 MHz
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Optimizing Performance
Using Free Run, Step Dwell, and Timer Trigger
Figure 4-3 Free Run, Set Dwell, and Timer Trigger Softkeys

Sweep > Configure Step 
Sweep > More 

Use Step Dwell with Free Run when additional measurement wait 
time is desired after settling.

If the signal is to be settled for a minimum specific time at each point 
and it is not important if the point-to-point time is consistent, use 
Step Dwell and Free Run time.

Sweep > More 

If the signal’s point-to-point time 
requires consistency but the 
specific settling time at each point 
can vary, then use the Timer 
Trigger. Avoid using too fast of a 
sweep which does not allow the 
signal generator to settle. 
If the signal needs to be settled for 
a specific minimum time and 
consistent point-to-point time is 
required, then you should set the 
Timer Trigger to be the sum of the 
switching time (900 us (Option 
UNZ) or 5 ms (Standard)) plus the 
minimum settled time that is 
needed to make the measurement.
Example: If you need the signal to 
remain settled for 3 ms, and you 
have Option UNZ which settles in 
0.9 ms, then set the time trigger to 
the sum which is 3.9 ms.For details on each key, use key help as described on see page 26.
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Optimizing Performance
Using a USB Keyboard
Using a USB Keyboard
You can use a USB keyboard to remotely control the RF output state, the modulation state, and to 
select a memory sequence and register. 

The register selection, RF output state, and modulation state are affected by power cycle or preset, 
but the USB keyboard control state and the sequence selection are not.

Turning the USB keyboard control off disables the USB 
keyboard; it has no effect on the Auto Recall softkeys.

For details on each key, use key help as described on see page 26.

USB Keyboard Key

Delete, Enter

Insert

Home, Up Arrow

End, Down Arrow

Page Up, Right Arrow, +

Page Down, Left Arrow, -

Signal Generator Function

RF On/Off

Mod On/Off

Next Sequence

Previous Sequence

Recall Next State Register

Recall Previous State Register
66 Agilent N5181A/82A MXG Signal Generators User’s Guide



5 Using Analog Modulation (Option UNT Only)

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting the power level and frequency, refer to 
Chapter 3, “Basic Operation,” on page 25 and familiarize yourself with the information in that 
chapter.

• The Basic Procedure on page 68

• Using an External Modulation Source on page 69

• Removing a DC Offset on page 69

Figure 5-1 Analog Modulation Softkeys

page 69page 69 page 69

For details on each key, use key help
as described on see page 26.
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Using Analog Modulation (Option UNT Only)
The Basic Procedure
The Basic Procedure
1. Preset the signal generator.

2. Set the carrier (RF) frequency.

3. Set the RF amplitude.

4. Configure the modulation:

5. Turn on the modulation:

The appropriate modulation annunciator displays, indicating that you enabled modulation.

6. Turn on the RF output.

The RF output LED lights, indicating that the signal is transmitting from the RF output connector.

If the modulation does not seem to be working properly, refer to “No Modulation at the RF Output” 
on page 221.

See also “Modulating the Carrier Signal” on page 40.

AM FM  ΦM

a. Press AM

b. Set the AM type (linear or exponential): 
AM Type to highlight desired type

c. Set the depth: 
AM Depth > value 

d. Set the rate: 
AM Rate > value > frequency unit

a. Press FM/ΦM

b. Set the deviation: 
FM Dev > value > frequency unit

c. Set the rate: 
FM Rate > value > frequency unit

a. Press FM/ΦM > FM ΦM

b. Set the BW (normal or high):
FM ΦM to highlight desired type

c. Set the deviation: 
ΦM Dev > value > pi rad

d. Set the rate: 
ΦM Rate > value > frequency unit

AM FM  ΦM

AM Off On softkey to On FM Off On softkey to On  ΦM Off On softkey to On
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Using Analog Modulation (Option UNT Only)
Using an External Modulation Source
Using an External Modulation Source

Removing a DC Offset

To eliminate an offset in an externally applied FM or ΦM signal, perform a DCFM or DCΦM 
Calibration.

NOTE You can perform this calibration for internally generated signals, but DC offset is not usually 
a characteristic of an internally generated signal.

1. Set up and turn on the desired modulation.

2. Press FM/ΦM > More > DCFM/DCΦM Cal.

Performing the calibration with a DC signal applied removes any deviation caused by the DC signal, 
and the applied DC level becomes the new zero reference point. When you disconnect the DC signal, 
perform the calibration again to reset the carrier to the correct zero reference.

AM input

Rear panel inputs are
described on page 11

FM or ΦM input

Default

Select to use external modulation

Currently selected modulation.
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Using Analog Modulation (Option UNT Only)
Using an External Modulation Source
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6 Using Pulse Modulation (Option UNU or UNW)

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting the power level and frequency, refer to 
Chapter 3, “Basic Operation,” on page 25 and familiarize yourself with the information in that 
chapter.

• Pulse Characteristics on page 73

• The Basic Procedure on page 75

• Example on page 75
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Using Pulse Modulation (Option UNU or UNW)
Figure 6-1 Pulse Softkeys

page 75

page 75

Latency from the external 
pulse input to the pulse 
sync output ≈ 50−60 ns.

Width Period
50 ns > 50 ns

For details on each key, use key help
as described on page 26.

Determines how the signal generator 
responds to an external pulse signal.
Normal = high state.
Invert = low state.

Low = settled

TTL signal

See also, 
page 12 and 

Select the signal 
that you want 
routed to each 
output connector.

This is the 2nd page of 
the Menu.

Select which marker to 
route to the Event 1 BNC. Select which 

marker to 
route to the 
Trig out BNC.

These 
softkeys are 
only available 
for the 
N5182A.

These 
softkeys are 
only available 
for the 
N5182A.
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Using Pulse Modulation (Option UNU or UNW)
Pulse Characteristics
Pulse Characteristics

NOTE When using very narrow pulses that are below the signal generator’s ALC pulse width 
specification, or leveled pulses with an unusually long duty cycle, it is often useful to turn 
ALC off (see page 59).

Pulse Source Type Perioda

aAll delays, widths, and periods have a resolution of 10 ns.

Width & Delaya Uses Trigger Eventb,

bA signal at the rear panel pulse connector must be held high for at least 20 ns to trigger an internally generated pulse.

Square Internal free run pulse train with 
50% duty cycle.

Determined by 
user defined rate.

 

Free Run
(default) Internal free run pulse train User Defined User Defined 

Triggered Internal pulse train  User Defined ✓

Adjustable
Doublet

Two internal pulse trains for each 
trigger event. 

User Defined:

First pulse is relative to the 
rising edge of trigger signal.

Second pulse is relative to the 
rising edge of first pulse.

See Figure 6- 2 on page 74

✓

Trigger
Doublet

Two internal pulse trains for each 
trigger event.



The first pulse follows the 
trigger signal.

Second pulse is user defined.

See Figure 6- 3 on page 74

✓

Gated Internal gated pulse train  User Defined ✓

External External pulse signal at the rear 
panel Pulse connector

  

External pulse input

Rear panel inputs are described on page 11
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Using Pulse Modulation (Option UNU or UNW)
Pulse Characteristics
Figure 6-2 Adjustable Doublet

Figure 6-3 Trigger Doublet

The delay of the first pulse is measured from 
the leading edge of the external trigger signal.

Delay Width

RF Output

External
Trigger

The delay of the second pulse is measured from 
the leading edge of the first pulse.

Delay Width

Pulse 2Pulse 2

Pulse 1Pulse 1

The delay of the second pulse is measured from 
the leading edge of the external trigger signal.

Delay Width

RF Output

External
Trigger

The first pulse follows the 
external trigger signal.

Pulse 1 Pulse 1
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Using Pulse Modulation (Option UNU or UNW)
The Basic Procedure
The Basic Procedure
1. Preset the signal generator.

2. Set the carrier (RF) frequency.

3. Set the RF amplitude.

4. Configure the modulation:

a. Set the pulse source: Press Pulse > Pulse Source > selection

b. Set the parameters for the selected pulse source:

5. Turn on the modulation: Pulse Off On softkey to On.

The the PULSE annunciator lights, indicating that you enabled modulation.

6. Output the modulated signal from the signal generator: Press the front panel RF On Off key.

The RF output LED lights, indicating that the signal is transmitting from the RF output connector.

See also, “Modulating the Carrier Signal” on page 40.

Example
The following example uses the factory preset pulse source and delay.

1. Preset the signal generator.

2. Set the frequency to 2 GHz.

3. Set the amplitude to 0 dBm.

4. Set the pulse period to 100 microseconds: Press Pulse > Pulse Period > 100 > usec.

5. Set the pulse width to 24 microseconds: Press Pulse > Pulse Width > 24 > usec

6. Turn on both the pulse modulation and the RF output. 

The PULSE annunciator displays and the RF output LED lights.

If the modulation does not seem to be working properly, refer to “No Modulation at the RF Output” 
on page 221. 

Square Free Run (default) Triggered Adjustable Doublet Trigger Doublet Gated External

Pulse Rate      

 Pulse Period    Pulse Period 

 Pulse Delay Pulse Delay Pulse Delay Pulse Delay  

 Pulse Width Pulse Width Pulse Width Pulse Width Pulse Width 

   Pulse 2 Delay   

   Pulse 2 Width   

Output: A 2 GHz, 0 dBm carrier modulated by a 24 µs pulse that has a period of 100 µs.
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Example
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7 Basic Digital Operation—No BBG Option Installed

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting power level and frequency, refer to Chapter 
3, “Basic Operation,” on page 25 and familiarize yourself with the information in that chapter.

See Also: “Adding Real- Time Noise to a Dual ARB Waveform” on page 164
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I/Q Modulation
I/Q Modulation
The following factors contribute to the error vector magnitude:

• Differences in amplitude, phase, and delay between the I and Q channels

• DC offsets

The I/Q menu provides adjustments to compensate for some of the differences in the I and Q signals 
or to add impairments.

See also, “Modulating the Carrier Signal” on page 40.

Figure 7-1 I/Q Display and Softkeys

The following table shows common uses for the adjustments.

Table 7-1 I/Q Adjustments Uses

I/Q Adjustment Effect Impairment

Offset Carrier Feedthrough dc offset

Quadrature Angle
EVM error phase skew

I/Q Images I/Q path delay

This panel displays the external 
I/Q signal routing.

This panel displays the current status and settings 
of the I/Q adjustments. Grey text indicates I/Q 
adjustments are off.

For details on each key, use key help
as described on page 26.

Offsets the phase of the Q signal relative to the phase of the 
I signal. The quadrature adjustment key is in units of 
degrees. This adjustment is not calibrated. 

Sets the dc offset
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I/Q Modulation
Configuring the Front Panel Inputs

The Agilent MXG accepts externally supplied analog I and Q signals through the front- panel I Input 
and Q Input for modulating onto the carrier.

1. Connect I and Q signals to the front panel connectors. For voltage levels, refer to “Front Panel 
Overview” on page 4. 

a. Connect an analog I signal to the signal generator’s front- panel I Input.

b. Connect an analog Q signal to the signal generator’s front- panel Q Input.

2. Turn on the I/Q modulator: Press I/Q Off On to On.

3. Configure the RF output:

a. Set the carrier frequency.

b. Set the carrier amplitude.

c. Turn the RF output on.

4. Make adjustments to the I/Q signals (page 78) as needed.
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I/Q Modulation
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8 Basic Digital Operation (Option 651/652/654)

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting power level and frequency, refer to Chapter 
3, “Basic Operation,” on page 25 and familiarize yourself with the information in that chapter.

The features described in this chapter are available only in vector signal generators with Option 651, 
652, or 654.

• Waveform File Basics on page 82

• Storing, Loading, and Playing a Waveform Segment on page 84

• Waveform Sequences on page 87

• Saving a Waveform’s Settings & Parameters on page 91

• Using Waveform Markers on page 96

• Triggering a Waveform on page 112

• Clipping a Waveform on page 119

• Scaling a Waveform on page 128

• Setting the Baseband Frequency Offset on page 135

• I/Q Modulation on page 138

• Multiple Baseband Generator Synchronization on page 144

• Waveform 5- Pack Licensing (Options 221- 229) on page 150

See Also: 

• “Adding Real- Time Noise to a Dual ARB Waveform” on page 164

• “Real- Time Phase Noise Impairment” on page 170

• Chapter 12, “Multitone and Two- Tone Waveform Generator (Option 430),” on page 199
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Waveform File Basics
Waveform File Basics
There are two types of waveform files: 

• A segment is a waveform file that you download to the signal generator.

For information on creating and downloading waveform files, refer to the Programming Guide. 

• A sequence is a file you create in the signal generator that contains pointers to one or more 
waveform files (segments, other sequences, or both). 

For information on creating sequences, see page 87.

Signal Generator Memory

The signal generator has two types of memory:

• Volatile memory, baseband generator (BBG) media, where waveform files are played from or 
edited.

• Non- volatile memory, either internal (int) or external (USB) media, where waveform files are 
stored.

Dual ARB Player

The dual ARB waveform player enables you to play, rename, delete, store, and load (external or 
internal) waveform files in addition to building waveform sequences. The dual ARB waveform player 
also provides markers (page 96), triggering (page 112), clipping (page 119), and scaling (page 128) 
capabilities.

Most procedures in this section start from the Dual ARB menu, shown below. 
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Basic Digital Operation (Option 651/652/654)
Waveform File Basics
Figure 8-1 Dual ARB Softkeys

page 164

page 11

page 128

page 11

page 84

If you set the ARB sample clock when the dual ARB 
is off, the new setting is applied when the dual ARB 
player is turned on; this setting survives toggling 
the Dual ARB player off and on.

page 39

page 91

page 112

For details on each key, use key help
as described on page 26.

Note: This is the
first of two 
Arb menus.

Note: This is second of 
two Arb menus.

page 87

page 135

page 128

page 128

page 137

page 144

These softkeys are 
only available in 
the Dual ARB’s 
Arb Setup menu.

page 96

Available with 
N5182A opt 22x.

page 150
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Basic Digital Operation (Option 651/652/654)
Storing, Loading, and Playing a Waveform Segment
Storing, Loading, and Playing a Waveform Segment
Before using this information, you should be familiar with the signal generator’s file menus. If you 
are not, refer to Working with Files on page 41 and familiarize yourself with that information.

See also: Waveform Sequences on page 87.

The signal generator has two types of waveform media: non- volatile (internal or USB), and volatile 
(BBG). BBG media is also called “working” media, because before you can play, edit, or include a 
waveform file in a sequence, the waveform file must be loaded into BBG media.

Figure 8-2 Waveform Segment Softkeys

Loading a Waveform Segment into BBG Media

Waveforms must reside in BBG media before they can be played, edited, or included in a sequence. 
Cycling power or rebooting the signal generator deletes the files in BBG media.

NOTE Each time the instrument powers up, two factory- supplied segments are automatically 
created in BBG media: RAMP_TEST_WFM and SINE_TEST_WFM.

There are additional sample waveforms that are available in the internal storage and that 
can be loaded into memory. Refer to www.agilent.com and search on “Factory Default 
N5182A” and “waveforms”.

1. Press Mode > Dual ARB > Select Waveform > Waveform Segments.

2. Press Load Store to highlight Load, then, using the arrow keys, highlight the desired waveform 
segment.

3. If there is already a copy of this segment in the currently selected media and you do not want to 
overwrite it, rename the waveform segment before you load it (refer to the previous procedure).

page 96

For details on each key, use key help
as described on page 26.

Note: When a sequence is selected, this key name 
changes to Show Waveform Sequence Contents.

Use the arrow keys or knob to 
highlight a letter or character.

These keys change to indicate the default media. 
For information on selecting the default media, 
see page 52.
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Basic Digital Operation (Option 651/652/654)
Storing, Loading, and Playing a Waveform Segment
4. Press Load Segment From currently selected Media.

To load all files from the currently selected media into BBG media, press 
Load All From currently selected Media. 

Storing/Renaming a Waveform Segment to Internal or USB Media

Use the following steps to store a copy of a file in BBG memory to the currently selected media 
(page 52). If you have not downloaded a waveform segment, either refer to the Programming Guide, 
or use one of the factory- supplied segments. 

1. Press Mode > Dual ARB > Select Waveform > Waveform Segments.

2. Press Load Store to highlight Store.

3. Using the arrow keys, highlight the waveform segment you want to store.

4. Optionally, rename the segment.

If there is already a copy of this segment in the currently selected media and you do not want to 
overwrite it, rename the waveform segment before you store it:

a. Press More > Rename Segment > Clear Text.
b. Enter a name for the waveform segment.
c. Press Enter > More.
d. Highlight the waveform segment that was renamed.

5. Press Store Segment to currently selected Media.

6. Repeat Step 3 through Step 5 for all segments that you want to store.

To save all segments from BBG media to the currently selected media, press 
Store All to currently selected Media.

Playing a Waveform Segment
1. Press Mode > Dual ARB > Select Waveform.

2. In the Segment on BBG Media column, highlight the waveform segment you want to play.

3. Press Select Waveform.

4. Set ARB Off On to On.

This plays the selected waveform segment. Both the I/Q and ARB annunciators turn on, and the 
waveform modulates the RF carrier. 

Current waveform selection

Annunciators display with active waveform (ARB On)
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Storing, Loading, and Playing a Waveform Segment
5. Configure the RF Output: 

Set the RF carrier frequency and amplitude, and turn on the RF output.

The waveform segment is now available at the signal generator’s RF Output connector. 
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Waveform Sequences
Waveform Sequences

Figure 8-3 Waveform Sequence Softkeys

A waveform sequence is a file that contains pointers to one or more waveform segments or other 
waveform sequences, or both. This lets the signal generator play multiple waveform segments, or 
other sequences, or both thereby eliminating the need to stop waveform playback just to select 
another waveform.

The segments that a waveform sequence points to are not automatically stored when you store the 
sequence; you must also store the individual segments or they are lost when you turn off or reboot 
the signal generator. If the segments are located in internal/external media, you must load them into 
BBG media prior to selecting a waveform sequence (see page 84). If you attempt to play a sequence 
without the segments loaded into BBG media, the signal generator reports: ERROR: 629, File 
format invalid. If this happens and the segments are not stored in internal/external media, you 
must recreate the segments using the same file names that the sequence points to before you can 
play the sequence. 

For details on each key, use key help
as described on page 26.

Mode > 
Dual ARB

Sequence name

Sequence contents

see page 109

To display this softkey, select a waveform sequence.

This is the 2nd Arb 
menu.
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Waveform Sequences
Creating a Sequence

A waveform sequence can contain up to 1,024 segments and have both segments and other sequences 
(nested sequences). The signal generator lets you set the number of times the segments and nested 
sequences repeat during play back. But there is a difference between repeating a segment versus 
repeating a nested sequence. Each segment can repeat up to 65,535 times, but no matter how many 
times a segment repeats, it counts as a single segment. However each repetition of a nested sequence 
counts as additional segments.

The maximum number of times that a nested sequence can repeat is based on the number of 
segments in the nested sequence and the remaining number of allowed segments (1,024). For 
example, with a sequence that contains 24 segments and one nested sequence with 4 segments, the 
nested sequence is limited to 250 repetitions:

24 + (4 × 250) = 1,024 maximum number of segments per sequence

Even though there is a limiting factor on the maximum number of times that a nested sequence can 
repeat, each segment within the nested sequence can repeat up to 65,535 times.

Example

Use the following procedure to create and store a waveform sequence using one repetition each of 
two different segments.

Assumption: The waveform segments are in BBG media (volatile memory). For information on loading 
waveform segments into BBG media, see page 84. 

1. Select the first segment:

a. Press Mode > Dual ARB > More > Waveform Sequences > Build New Waveform Sequence > Insert 
Waveform.

b. Highlight the desired waveform segment and press Insert.

2. Select the second segment:

a. Highlight the next desired waveform segment and press Insert.

b. Press Done Inserting

3. Name and store the waveform sequence to the Seq file catalog:

a. Press More > Name and Store.

b. Enter a file name and press Enter.

See also, “Viewing the Contents of a Sequence” on page 89 and “Setting Marker Points in a Waveform 
Segment” on page 103.

Waveform
Sequence

Sequence A

Sequence B

Sequence A
repeated 4x

Segment 1

Segment 2

Segment 3

2 segments

9 segments

11 segments

8 Segments
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Waveform Sequences
Viewing the Contents of a Sequence

There are two ways to view the contents of a waveform sequence:

Through the Waveform Sequences Softkey
1. Press Mode > Dual ARB > More > Waveform Sequences.

2. Highlight the desired sequence.

3. Press Show Waveform Sequence Contents.

Using the Select Waveform Softkey
1. Press Mode > Dual ARB > Select Waveform.

2. In the Sequence On column, highlight the desired waveform sequence.

3. Press Show Waveform Sequence Contents.

Editing a Sequence

When editing a waveform sequence, you can:

• change the number of times each segment or nested sequence plays
• delete segments or nested sequences from the sequence
• add segments or nested sequences to the sequence
• toggle markers on and off (described on page 109)
• save changes either to the current waveform sequence or as a new sequence

If you exit the sequence editing menu before saving changes, the changes are lost.

Sequences save to the Seq file catalog.

CAUTION If you edit and resave a segment used in a sequence, the sequence does not 
automatically update the RMS value in its header. You must select and update the 
sequence header information (page 91).

Use the following steps to edit a sequence that has two different segments so that the first segment 
repeats 100 times and the second segment repeats 200 times, then save the changes.

Assumption: A waveform sequence that has two different segments has been created and stored (see 
previous example on page 88).

1. Select the sequence: 
Press Mode > Dual ARB > More > Waveform Sequences > highlight the desired sequence > 
Edit Selected Waveform Sequence.

2. Change the first segment so that it repeats 100 times: 
Highlight the first segment entry and press Edit Repetitions > 100 > Enter.

The cursor moves to the next entry. 

3. Change the repetition for the selected entry to 200: 
Press Edit Repetitions > 200 > Enter.

4. Save the changes made in the previous steps: 
Press More > Name and Store > Enter.
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Waveform Sequences
To save the changes as a new sequence: 

a. Press More > Name and Store > Clear Text.
b. Enter a file name (for example, SINE100+RMP200).
c. Press Enter.

The edited sequence saves as a new waveform sequence. 

Playing a Sequence

If you have not created a waveform sequence, refer to “Creating a Sequence” on page 88.

NOTE To play a waveform segment individually or as part of a waveform sequence, the segment 
must reside in BBG media. See also, “Loading a Waveform Segment into BBG Media” on 
page 84.

1. Select a waveform sequence:

a. Press Mode > Dual ARB > Select Waveform.

b. Highlight a waveform sequence (for this example, SINE100+RMP200) from the Sequence On 
column.

c. Press Select Waveform.

The display shows the currently selected waveform (for example, Selected Waveform: 
SEQ:SINE100+RMP200).

2. Generate the waveform: 
Press ARB Off On to On. 

This plays the selected waveform sequence. During the waveform sequence generation, both the 
I/Q and ARB annunciators turn on, and the waveform modulates the RF carrier. 

3. Configure the RF output: 

a. Set the RF carrier frequency.
b. Set the RF output amplitude.
c. Turn on the RF output.

The waveform sequence is now available at the signal generator’s RF OUTPUT connector. 

Current waveform selection

Annunciators display with active waveform (ARB On)
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Saving a Waveform’s Settings & Parameters
Saving a Waveform’s Settings & Parameters
This section describes how to edit and save a file header. When you download only a waveform file 
(I/Q data, which the signal generator treats as a waveform segment), the signal generator 
automatically generates a file header and a marker file with the same name as the waveform file. 
Initially the file header has no signal generator settings saved to it, and the marker file consists of all 
zeros. For a given waveform, you can save signal generator settings and parameters in its file header 
and marker settings in its marker file (page 96); when you load a stored waveform file into BBG 
media, the file header and marker file settings automatically apply to the signal generator so that the 
dual ARB player sets up the same way each time the waveform file plays. 

Figure 8-4 Header Utilities Softkeys

When you create a waveform sequence (as described on page 88), the signal generator automatically 
creates a waveform sequence header that takes priority over the individual waveform segment 
headers. During a waveform sequence playback, the segment headers are ignored, except to verify 
that all required options are installed. Storing a waveform sequence also stores its file header. 

Some of the current signal generator settings shown in the file header appear as part of the softkey 
labels, and others appear in the dual ARB summary display, shown in the following example.

page 93

Mode > Dual ARB > 
More > 
Header Utilities

For details on each key, 
use key help
as described on 
page 26.

ARB summary, file
header settings

Softkey labels,
file header
settings

Softkey label,
file header
setting

All settings in this menu can be stored to 
the file header (Table 8-1 on page 92 lists 
all settings stored in a file header)

The Waveform 
Runtime Scaling 
softkey is only 
available under the 
Dual ARB menu.
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Saving a Waveform’s Settings & Parameters
Table 8-1 File Header Entries 

32- Character Description A description entered for the header, such as a the waveform’s function (saved/edited with the Edit 
Description softkey, see Figure 8- 4).

Sample Rate The waveform playback rate. This is the ARB sample clock rate, set in the Arb Setup menu (shown 
in Figure 8- 1 on page 83).

Runtime Scaling The Runtime scaling value is applied in real- time while the waveform is playing. This setting can be 
changed only for files playing in the dual ARB player (see page 132).

RMS When the modulator attenuation setting (see page 83) is set to Auto, this value is used to calculate 
the I/Q modulator attenuation setting to optimize ACPR. Value: 0 to 1.414213562

Marker 1...4 Polarity Marker polarity can be positive or negative (described on page 108). 

ALC Hold Routing Which marker, if any, implements the ALC hold function (described on page 98), which holds the 
ALC at its current level when the marker signal is low. All waveforms generated in the signal 
generator have a marker on the first sample point. To see the results from the three routing 
selections, you may need to select a range of sample (marker) points (see “Setting Marker Points in 
a Waveform Segment” on page 103). 

RF Blank Routing Which marker, if any, implements the RF blanking function (described on page 106) when the 
marker signal is low. RF blanking also uses ALC hold. There is no need to select the ALC Hold 
Routing for the same marker when you are using the RF Blank Routing function. When the marker 
signal goes high, RF blanking discontinues. 

Mod Attenuation The I/Q modulator attenuation setting (set in the Arb Setup menu shown in Figure 8- 1 on page 83).

BB Freq Offset The baseband frequency offset, in Hz (see page 135).

AWGN: State Indicated whether real- time noise is on (1) or off (0) (see page 163).

AWGN: C/N Ratio Carrier to noise ration, in dB (see page 166).

AWGN: Carrier BW Bandwidth over which the noise power is integrated, in Hz (see page 166).

AWGN: Noise BW Bandwidth of the noise, in Hz (see page 166).

AWGN: Carrier RMS The carrier RMS across the carrier bandwidth (see page 166).

Phase Noise State Indicated whether phase noise is on (1) or off (0) (see page 170).

Phase Noise F1 The start frequency for the level mid- frequency characteristics (see page 170).

Phase Noise F2 The end frequency for the level mid- frequency characteristics (see page 170).

Phase Noise Lmid The amplitude for the level mid- frequency characteristics (see page 170).

Over- Range Protect Indicated whether DAC Over- Range Protection is on (1) or off (0) (see page 174).

Unique Waveform Id 0 = no Id; once an Id is assigned, it cannot be changed.

License Required Indicates whether a license is required to play the waveform. See also: “Viewing Options and 
Licenses” on page 24

Can be Read Out Indicates whether the waveform can be queried through SCPI or FTP.
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Saving a Waveform’s Settings & Parameters
Viewing and Modifying Header Information 

The following example uses the factory- supplied waveform file RAMP_TEST_WFM.

1. From BBG media, select the waveform RAMP_TEST_WFM: 

a. Press Mode > Dual ARB > Select Waveform.

b. In the Segment On column, highlight the waveform RAMP_TEST_WFM.

c. Press Select Waveform.

2. Open the Header Utilities menu:

Press More > Header Utilities

The Figure 8- 5 shows the default file header for the factory- supplied waveform RAMP_TEST_WFM. 
The Header Field column lists the file header parameters; use the Page Down key to see them all.

The Saved Header Settings column shows that most of the settings are Unspecified. 
Unspecified means that there is no setting saved for that particular parameter.

The Current Inst. Settings column shows the current signal generator settings. In this 
example, these are the settings that you will save to the file header. 

NOTE If a setting is unspecified in the file header, the signal generator uses its current value for 
that setting when you select and play the waveform.

Figure 8-5 Example File Header

The name of the waveform file.

The description can be up to 
32-characters.

Mode > Dual ARB > More > Header Utilities

Default header settings Current signal generator settings

Resets the saved 
header settings 
entries to default 
settings

To calculate the RMS waveform voltage:
Press Calculate

Then refer to Header Field information.

Note: For greater accuracy, if the waveform has long rise/fall times, a DC 
offset, or noise* already added to the waveform (for a bursted signal), it 
is recommended that the Edit RMS and Edit AWGN RMS Override 
softkeys are used for the best measurement accuracy. 

*Option 403 Real-time AWGN does not affect the Header Field RMS 
value. But, noise added to the waveform prior to downloading and 
playing in the signal generator does affect the Header Field RMS value.

Opens a menu for manually 
defining the carrier RMS value 
to use for calculating the 
AWGN: Carrier RMS value 
in the Header Field. 
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Saving a Waveform’s Settings & Parameters
3. Save the information in the Current Inst. Settings column to the file header:

Press Save Setup To Header.

Both the Saved Header Settings column and the Current Inst. Settings column now display 
the same values; the Saved Header Settings column lists the settings saved in the file header.

4. Edit and Update Settings

a. Return to the ARB Setup menu: 
Press Return > More > ARB Setup.

From this menu you can access some of the signal generator settings that are saved to the file 
header. Figure 8- 1 on page 83 shows the ARB Setup softkeys used in the following steps.

b. Set the ARB sample clock to 5 MHz: 
Press ARB Sample Clock > 5 > MHz.

c. Set waveform runtime scaling to 60%:
Press Waveform Runtime Scaling > 60 > %.

d. Return to the Header Utilities menu: 
Press Return > More > Header Utilities.

As shown in the following figure, the Current Inst. Settings column now reflects the 
changes to the current signal generator setup, but the saved header values have not changed.

e. Save the current settings to the file header: 
Press the Save Setup To Header softkey.

The settings from the Current Inst. Settings column now appear in the Saved Header 
Settings column. This saves the new current instrument settings to the file header.

If you change any of the signal generator settings listed in the file header after you select the 
waveform file, the changed setting(s) appear in the file header’s Current Inst. Settings column 
and are used instead of the saved header settings. To reapply the saved header settings, reselect the 
waveform for playback.

Values differ between 
the two columns
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Saving a Waveform’s Settings & Parameters
Viewing & Editing a Header without Selecting the Waveform

As described on page 93, you can view and edit a waveform’s header information after you select the 
waveform; you can also edit waveform header information without selecting a waveform, or for 
another waveform than the one that is currently selected.

1. Access the file header utilities menu:
Press Mode > Dual ARB > More > Header Utilities > More > Select Different Header.

The signal generator displays an alphabetical list of the waveform files in the media that was last 
selected. The following figure shows an example of the factory- supplied waveforms in BBG media. 

2. If the desired catalog is not displayed, select it. 

3. Highlight the desired waveform file and press Select Header.

The signal generator displays the file header for the selected waveform file. 

4. To edit the header, press More, and proceed as described in Step 4 on page 94 (Viewing and 
Modifying Header Information section).

Active waveform catalog

Active media

Type:
WFM1 = Volatile Segment
NVWFM = Non-Volatile Segment
SEQ = Sequence

Active catalog

For details on each key, use key help
as described on page 26.

Catalogs that enable you to 
view files in the active media.

For details on selecting the 
active media, see page 44.

Files in BBG media
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Using Waveform Markers
The signal generator provides four waveform markers to mark specific points on a waveform segment. 
When the signal generator encounters an enabled marker, an auxiliary signal is routed to a rear 
panel event output that corresponds to the marker number.

• Event 1 is available at both the EVENT 1 BNC connector (see page 14), and a pin on the 
AUXILIARY I/O connector (see page 15).

• Event 2 is available at both the TRIG OUT BNC connector (see page 12), and a pin on the 
AUXILIARY I/O connector (see page 15).

• Events 3 and 4 are available at pins on the AUXILIARY I/O connector (see page 15).

You can use an auxiliary output signal to synchronize another instrument with the waveform, or as a 
trigger signal to start a measurement at a given point on a waveform.

You can also configure markers to initiate ALC hold or RF Blanking (which includes ALC hold). Refer 
to “Using Waveform Markers” on page 96 for details.

When you download a waveform file that does not have a marker file associated with it, the signal 
generator creates a marker file without any marker points. Factory- supplied segments 
(RAMP_TEST_WFM and SINE_TEST_WFM) have a marker point on the first sample for all four markers.

The following procedures demonstrate how to use markers while working in the dual ARB player. 
These procedures also discuss two types of points: a marker point and a sample point. A marker 
point is a point at which a given marker is set on a waveform; you can set one or more marker 
points for each marker. A sample point is one of the many points that compose a waveform.

There are three basic steps to using waveform markers:

“Clearing Marker Points from a Waveform Segment” on page 102

“Setting Marker Points in a Waveform Segment” on page 103

“Controlling Markers in a Waveform Sequence” on page 109

This section also provides the following information:

• “Waveform Marker Concepts” on page 97

• “Accessing Marker Utilities” on page 101

• “Viewing Waveform Segment Markers” on page 102

• “Viewing a Marker Pulse” on page 105

• “Using the RF Blanking Marker Function” on page 106

• “Setting Marker Polarity” on page 108
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Waveform Marker Concepts

The signal generator’s Dual ARB provides four waveform markers for use on a waveform segment. 
You can set each marker’s polarity and marker points (on a single sample point or over a range of 
sample points). Each marker can also perform ALC hold, or RF Blanking and ALC hold.

Marker Signal Response

The signal generator aligns the marker signals with the I and Q signals at the baseband generator. 
However some settings such as amplitude, filters, and so forth within the RF output path can create 
delays between the marker EVENT output signal and the modulated RF output. When using the 
marker EVENT output signal, observe the signals (marker relative to modulated RF) for any latency, 
and if needed, reset the marker point positions, include delay (page 141), or both.

Marker File Generation

Downloading a waveform file (as described in the Programming Guide) that does not have a marker 
file associated with it causes the signal generator to automatically create a marker file, but does not 
place any marker points.

Marker Point Edit Requirements

Before you can modify a waveform segment’s marker points, the segment must reside in BBG media 
(see “Loading a Waveform Segment into BBG Media” on page 84).

Saving Marker Polarity and Routing Settings

Marker polarity and routing settings remain until you reconfigure them, preset the signal generator, 
or cycle power. To ensure that a waveform uses the correct settings when it is played, set the marker 
polarities or routing (RF Blanking and ALC Hold) and save the information to the file header 
(page 91). 

NOTE When you use a waveform that does not have marker routings and polarity settings stored in 
the file header, and the previously played waveform used RF Blanking, ensure that you set 
RF Blanking to None. Failure to do so can result in no RF output or a distorted waveform.

Marker 
File
Bit N

Marker
Polarity

Marker N 
RF Blank Off On

Marker N
Blanks RF when 
Marker is Low

EVENT N

Negative

Positive

Set Marker
On Off

Marker N 
ALC Hold Off On

Marker N
Holds ALC when 

Marker is Low

When the signal generator encounters an enabled marker (described on page 109), an 
auxiliary output signal is generated and routed to the rear panel. 

Event 1 is available at the EVENT 1 BNC connector (see page 14), and at a pin on the 
AUXILIARY I/O connector (see page 15).

Events 2 through 4 are available at pins on the AUXILIARY I/O connector (see page 15).

RF Blank Only: includes ALC Hold
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ALC Hold Marker Function

While you can set a marker function (described as Marker Routing on the softkey label) either before 
or after you set marker points (page 103), setting a marker function before setting marker points may 
cause power spikes or loss of power at the RF output.

Use the ALC hold function by itself when you have a waveform signal that incorporates idle periods, 
burst ramps, or when the increased dynamic range encountered with RF blanking (page 106) is not 
desired. 

The ALC hold marker function holds the ALC circuitry at the average value of the sampled points 
set by the marker(s). For both positive and negative marker polarity, the ALC samples the RF output 
signal (the carrier plus any modulating signal) when the marker signal goes high:

NOTE Because it can affect the waveform’s output amplitude, do not use the ALC hold for longer 
than 100 ms. For longer time intervals, refer to “Power Search Mode” on page 60.

CAUTION Incorrect ALC sampling can create a sudden unleveled condition that may create a spike 
in the RF output, potentially damaging a DUT or connected instrument. To prevent this 
condition, ensure that you set markers to let the ALC sample over an amplitude that 
accounts for the higher power levels encountered within the signal.

Positive: The signal is sampled during the on marker points.
Negative The signal is sampled during the off marker points.

Positive Polarity
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Close-up of averaging

The ALC samples the waveform when the marker signal goes 
high, and uses the average of the sampled waveform to set the 
ALC circuitry.

Here the ALC samples during the on marker points (positive 
polarity).

Marker Marker

MarkerMarker

Example of Correct Use

Waveform: 1022 points
Marker range: 95-97
Marker polarity: Positive

This example shows a marker set to sample the waveform’s area of 
highest amplitude. Note that the marker is set well before the 
waveform’s area of lowest amplitude. This takes into account any 
response difference between the marker and the waveform signal.

Pulse Unleveled

Example of Incorrect Use

Waveform: 1022 points
Marker range: 110-1022
Marker polarity: Positive

This example shows a marker set to sample the low part of the 
same waveform, which sets the ALC modulator circuitry for 
that level; this usually results in an unleveled condition for the 
signal generator when it encounters the high amplitude of the 
pulse.

MarkerMarker
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Sample range begins on first point of signal

Negative range set between signal and 
off time

Example of Incorrect Use

Waveform: 1022 points
Marker range: 110-1022
Marker polarity: Negative

This figure shows that a negative polarity marker goes low during 
the marker on points; the marker signal goes high during the off 
points. The ALC samples the waveform during the off marker 
points.

Marker On Marker On

Sampling both on and off time sets the modulator circuitry 
incorrectly for higher signal levels. Note the increased amplitude 
at the beginning of the pulse.

Marker
Off

Marker On
MarkerMarker

Off On
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Accessing Marker Utilities

Mode > Dual ARB > More > Marker Utilities

Note: This is the 
second Arb menu.

The display below shows the I and Q components of the waveform, and 
the marker points set in a factory-supplied segment.

First sample point 
shown on display

These softkeys change 
the range of waveform 
sample points shown 
on the marker display.

Each press of the 
softkey changes the 
sample range by 
approximately a factor 
of two.Marker points 

on first 
sample point

For details on each key, use key help
as described on page 26.

The settings in these menus 
can be stored to the file 
header, see page 91.

page 39
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Viewing Waveform Segment Markers

Markers are applied to waveform segments. Use the following steps to view the markers set for a 
segment (this example uses the factory- supplied segment, SINE_TEST_WFM).

1. In the second Arb menu (page 101), press Marker Utilities > Set Markers.
2. Highlight the desired waveform segment (in this example, SINE_TEST_WFM).
3. Press Display Waveform and Markers > Zoom in Max. 

The maximum zoom in range is 28 points.

Experiment with the Zoom functions to see how they display the markers.

The display can show a maximum of 460 points; displayed waveforms with a sample point range 
greater than 460 points may not show the marker locations.

Clearing Marker Points from a Waveform Segment

When you set marker points they do not replace points that already exist, but are set in addition to 
existing points. Because markers are cumulative, before you set points, view the segment (page 102) 
and remove any unwanted points. With all markers cleared, the level of the event output signal is 0V. 
To clear marker points on a segment, the segment must reside in BBG media (page 84).

Clearing All Marker Points
1. In the second Arb menu (page 101), press Marker Utilities > Set Markers.

2. Highlight the desired waveform segment (in this example, SINE_TEST_WFM).

3. Highlight the desired marker number: Press Marker 1 2 3 4.

4. For the selected marker number, remove all marker points in the selected segment:

a. Press Set Marker Off Range of Points.

Notice that the softkeys for the first and last marker points correspond with the length of the 
waveform. The factory- supplied waveform (SINE_TEST_WFM) contains 200 samples. To clear all 
set marker points, the range must equal to the length of the waveform.

b. Press Apply To Waveform > Return.

5. Repeat from Step 3 for any remaining marker points that you want to remove from the other 
markers.

Clearing a Range of Marker Points

The following example uses a waveform with marker points (Marker 1) set across points 10−20. This 
makes it easy to see the affected marker points. The same process applies whether the existing points 
are set over a range or as a single point (page 103).‘

1. In the second Arb menu (page 101), press Marker Utilities > Set Markers, then select Marker 1.

2. Set the first sample point that you want off (for this example, 13):
Press Set Marker Off Range Of Points > First Mkr Point > 13 > Enter.

3. Set the last marker point in the range that you want off to a value less than or equal to the 
number of points in the waveform, and greater than or equal to the value set in Step 2 (for this 
example, 17): 
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Press Last Mkr Point > 17 > Enter > Apply To Waveform > Return.

This turns off all marker points for 
the active marker within the range 
set in Steps 2 and 3, as shown at 
right.

How to view markers is described 
on page 102.

Clearing a Single Marker Point

Use the steps described in “Clearing a Range of Marker Points” on page 102, but set both the first 
and last marker point to the value of the point you want to clear. For example, if you want to clear 
a marker on point 5, set both the first and last value to 5.

Setting Marker Points in a Waveform Segment

To set marker points on a segment, the segment must reside in BBG media (page 84).

When you set marker points, they do not replace points that already exist, but are set in addition to 
existing points. Because markers are cumulative, before you set marker points within a segment, view 
the segment (page 102) and remove any unwanted points (page 102).

Placing a Marker Across a Range of Points
1. In the second Arb menu (page 101), press Marker Utilities > Set Markers.

2. Highlight the desired waveform segment.

3. Select the desired marker number: Press Marker 1 2 3 4

4. Set the first sample point in the range (in this example, 10):

Press Set Marker On Range Of Points > First Mkr Point > 10 > Enter.

5. Set the last marker point in the range to a value less than or equal to the number of points in 
the waveform, and greater than or equal to the first marker point (in this example, 20):

Press Last Mkr Point > 20 > Enter.

6. Press Apply To Waveform > Return.

This sets a range of waveform marker points. The marker signal starts on sample point 10, and ends 
on sample point 20, as shown in the following figure.

How to view markers is described on 
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Placing a Marker on a Single Point

On the First Point

1. In the second Arb menu (page 101), press Marker Utilities > Set Markers.

2. Highlight the desired waveform segment.

3. Select the desired marker number:
Press Marker 1 2 3 4.

4. Press Set Marker On First Point.

This sets a marker on the first point in the segment for the marker number selected in Step 3.

On Any Point

Use the steps described in “Placing a Marker Across a Range of Points” on page 103, but set both the 
first and last marker point to the value of the point you want to set. For example, if you want to set 
a marker on point 5, set both the first and last value to 5.

Placing Repetitively Spaced Markers

The following example sets markers across a range of points and specifies the spacing (skipped 
points) between each marker. You must set the spacing before you apply the marker settings; you 
cannot apply skipped points to a previously set range of points.

1. Remove any existing marker points (page 97).

2. In the second Arb menu (page 101), press Marker Utilities > Set Markers.

3. Highlight the desired waveform segment. 

4. Select the desired marker number: 
Press Marker 1 2 3 4.

5. Set the first sample point in the range (in this example, 5):
Press Set Marker On Range Of Points > First Mkr Point > 5 > Enter.

6. Set the last marker point in the range. (The last marker point value must always be less than or 
equal to the number of points in the waveform, and greater than or equal to the first marker 
point, in this example, 25):
Press Last Mkr Point > 25 > Enter.

7. Enter the number of sample points that you want skipped (in this example, 1):
Press # Skipped Points > 1 > Enter.

8. Press Apply To Waveform > Return.

This causes the marker to occur on 
every other point (one sample point is 
skipped) within the marker point range, 
as shown at right.

How to view markers is described on 
page 102.

One application of the skipped point 
feature is the creation of a clock signal 
as the EVENT output.
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Viewing a Marker Pulse

When a waveform plays (page 90), you can detect a set and enabled marker’s pulse at the rear panel 
event connector/Aux I/O pin that corresponds to that marker number. This example demonstrates 
how to view a marker pulse generated by a waveform segment that has at least one marker point set 
(page 103). The process is the same for a waveform sequence.  

This example uses the factory- supplied segment, SINE_TEST_WFM in the dual ARB Player. 
Factory- supplied segments have a marker point on the first sample point for all four markers, as 
shown.

1. In the first Arb menu (page 83), press Select Waveform.

2. Highlight the SINE_TEST_WFM segment and press Select Waveform.

3. Press ARB Off On to On.

4. Connect the Agilent MXG’s rear- panel Q OUT output to the oscilloscope’s channel 1 input.

5. Connect the signal generator’s rear- panel EVENT 1 output to the oscilloscope’s channel 2 input. 

When marker 1 is present, the Agilent MXG outputs a signal through EVENT 1 as shown in the 
following example.

Marker points on
first sample point of
waveform segment

How to view markers is described on page 102

Q OUT

Marker pulse on the Event 1 signal.
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Using the RF Blanking Marker Function

While you can set a marker function (described as Marker Routing on the softkey label in the Marker 
Utilities menu) either before or after setting the marker points (page 103), setting a marker function 
before you set marker points may change the RF output. RF Blanking includes ALC hold (described 
on page 98, note Caution regarding unleveled power). The signal generator blanks the RF output 
when the marker signal goes low. This example is a continuation of the previous example, Viewing a 
Marker Pulse.

1. Using the factory- supplied segment SINE_TEST_WFM, set Marker 1 across points 1−180 (page 103).
2. From the Marker Routing softkey menu, assign RF Blanking to Marker 1: 

In the second Arb menu (page 101), press Marker Utilities > Marker Routing > Pulse/RF Blank > Marker 
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1.

Marker Polarity = Positive
When marker polarity is positive (the default 
setting), the RF output is blanked during the off 
marker points.

200180Point 1
Marker

Segment

RF Signal

RF Signal

200180Point 1
Marker

Segment

Marker Polarity = Negative
When marker polarity is negative, the 
RF output is blanked during the on marker 
points

≈3.3V

0V

≈3.3V

0V

RF Signal

RF Signal
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Setting Marker Polarity

Setting a negative marker polarity inverts the marker signal.

1. In second Arb menu (page 101), press Marker Utilities > Marker Polarity.

2. For each marker, set the marker polarity as desired.

• The default marker polarity is positive.

• Each marker polarity is set independently.

See also, “Saving Marker Polarity and Routing Settings” on page 97.

As shown on page 106:

Positive Polarity:  On marker points are high (≈3.3V). 

Negative Polarity:  On marker points are low (0V).

RF blanking always occurs on the low part of the signal regardless of the polarity setting.
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Controlling Markers in a Waveform Sequence

In a waveform segment, an enabled marker point generates an auxiliary output signal that is routed 
to the rear- panel EVENT output (described in “Rear Panel Overview” on page 11) corresponding to 
that marker number. For a waveform sequence, you enable or disable markers on a 
segment- by- segment basis; this enables you to output markers for some segments in a sequence, but 
not for others. Unless you change the sequence marker settings or cycle the power, the marker setting 
for the last segment edited in the sequence applies to all segments in the next sequence that you 
build. For information on building a waveform sequence, see “Creating a Sequence” on page 88.

Figure 8-6 Waveform Sequence Menus for Enabling/Disabling Segment Markers

Mode > Dual ARB > 
More

Note: This is the second Arb menu.

For details on each key, use key help
as described on page 26.

Enable/Disable markers while 
creating a waveform sequence

Edit a sequence to 
enable/disable markers
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Enabling and Disabling Markers in a Waveform Sequence

Select the waveform segments within a waveform sequence to enable or disable each segment’s 
markers independently. You can enable or disable the markers either at the time of creating the 
sequence or after the sequence has been created and stored. If the sequence has already been stored, 
you must store the sequence again after making any changes. Enabling a marker that has no marker 
points has no effect on the auxiliary outputs. To set marker points on a segment, see “Setting Marker 
Points in a Waveform Segment” on page 103. This example assumes that a waveform sequence exists.

1. Ensure that all waveform segments for the sequence reside in BBG media (see page 84).

2. From the second Arb menu, press Waveform Sequences.

3. Highlight the desired waveform sequence.

4. Press Edit Selected Waveform Sequence > Enable/Disable Markers.

5. Toggle the markers: 

a. Highlight the first waveform segment.

b. As desired, press Toggle Marker 1, Toggle Marker 2, Toggle Marker 3, and Toggle Marker 4.

An entry in the Mkr column (see figure below) indicates that the marker is enabled for that 
segment; no entry in the column means that all markers are disabled for that segment.

c. In turn, highlight each of the remaining segments and repeat Step b.

6. Press Return > More > Name and Store.

7. Either rename the sequence using the text entry keys (see page 85) or just press Enter to save the 
sequence with the existing name.

The markers are enabled or disabled per the selections, and the changes saved to the sequence file.

The following figure shows a sequence built using one of the factory- supplied waveform segments; a 
factory- supplied segment has a marker point on the first sample for all four markers. In this 
example, marker 1 is enabled for the first segment, marker 2 is enable for the second segment, and 
markers 3 and 4 are enabled for the third segment.

For each segment, only the markers enabled for that segment produce a rear- panel auxiliary output 
signal. In this example, the marker 1 auxiliary signal appears only for the first segment, because it is 
disabled for the remaining segments. The marker 2 auxiliary signal appears only for the second 
segment, and the marker 3 and 4 auxiliary signals appear only for the third segment.

Sequence marker column

This entry shows that markers 
3 and 4 are enabled for this 
segment.
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Using the EVENT Output Signal as an Instrument Trigger

One of the uses for the EVENT 
output signal (marker signal) is to 
trigger a measurement instrument. 
You can set up the markers to start 
the measurement at the beginning 
of the waveform, at any single point 
in the waveform, or on multiple 
points in the waveform. To optimize 
the use of the EVENT signal for 
measurements, you may also need 
to adjust the sample rate. The 
location of the sample rate setting 
is shown in the figure at right.

The EVENT output signal can exhibit jitter of up to ±4 ns on the rising and falling edge. This jitter 
can be minimized in either of two ways. 

Method 1: Use a sample clock of 125 MHz/N where N is a positive integer and where 125 MHz/N can 
be represented exactly on the display. 
For example: 125 MHz, 62.5 MHz, 31.25 MHz, 25 MHz, and so on. 

If the result cannot be represented exactly on the display, jitter will be present.
For example: N = 6 will result in jitter, because 125 MHz/6 = 20.833 Mhz, which is truncated when 
displayed.

Method 2: Select a sample clock and waveform length that spaces the markers by a multiple of 8 ns. 
For example: A 200 point waveform with a marker on the first point and a sample clock of 50 MHz 
provides a marker every 4 µs. Because 4 µs is a multiple of 8 ns, the jitter is minimized.

When the EVENT output signal exhibits jitter and it is used as a measurement trigger, it can cause 
the waveform to falsely appear as having jitter. If this condition occurs, you can adjust the sample 
rate to a value (see above) that does not cause the jitter appearance. To maintain the integrity of the 
original waveform with a sample rate change, you will have to also recalculate the sample values. The 
following figures illustrate the marker signal jitter and its affect on the waveform.

Sample
rate 
setting

The settings in this menu 
can be stored to the file 
header, see page 91.

For details on each key, use key help as described on page 26.

The jitter is gone with
an optimal sample rate

Waveform appears to exhibit jitter when
triggered using EVENT signal with jitter.

Oscilloscope triggering on waveform Oscilloscope triggering on EVENT signal Oscilloscope triggering on EVENT signal

EVENT output signal exhibits jitter
due to a non-optimal sample rate
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Triggering a Waveform

Figure 8-7 Triggering Softkeys

Triggers control data transmission by controlling when the signal generator transmits the modulating 
signal. You can configure trigger settings so that data transmission occurs once (Single mode), 
continuously (Continuous mode), or starts and stops repeatedly (Gated and Segment Advance modes).

A trigger signal contains both positive and negative states; you can use either for triggering.

When you initially select a trigger mode or when you change from one triggering mode to another, 
you may lose the carrier signal at the RF output until the modulating signal is triggered. This is 
because the signal generator sets the I and Q signals to zero volts prior to the first trigger event. To 
maintain the carrier signal at the RF output, create a data pattern with the initial I and Q voltages 
set to values other than zero. 

When you initially turn the Arb ON or select a trigger mode or when you change from one triggering 
mode to another, you may temporarily lose the carrier signal for a few tens of milliseconds at the RF 
output. The Arb will present the idle IQrms value of the next Arb waveform to the IQ modulator. 
This ensures that the RF carrier output is at the correct amplitude level while the Arb waits for a 
trigger. When that trigger is received, the Arb begins playing the waveform and the modulated RF 
carrier exhibits no undesirable transients.

There are two parts to configuring a waveform trigger:

• Type determines the behavior of the waveform when it plays (see Trigger Type on page 113).

• Source determines how the signal generator receives the trigger that starts the modulating 
waveform playing (see Trigger Source on page 114).

Mode > Dual ARB

page 113

page 114

For details on each key, use key help
as described on page 26.
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Trigger Type

Type defines the trigger mode: how the waveform plays when triggered.

• Continuous mode repeats the waveform until you turn the signal off or select a different waveform, 
trigger mode, or response (Free Run, Trigger & Run, Reset & Run).

• Single mode plays the waveform once.

• Segment Advance mode plays a segment in a sequence only if triggered. The trigger source controls 
segment- to- segment playing (see Example: Segment Advance Triggering on page 115). A trigger 
received during the last segment loops play to the first segment in the sequence.

• Gated mode triggers the waveform at the first active triggering state, then repeatedly starts and 
stops playing the waveform in response to an externally applied gating signal. See Example: Gated 
Triggering on page 116.

Mode >
Dual ARB > 
Trigger Type

Immediately triggers and plays the waveform; triggers 
received while the waveform is playing are ignored.

Plays the waveform when a trigger is received; 
subsequent triggers are ignored.

Plays the waveform when a trigger is received; subsequent 
triggers restart the waveform.

The waveform stops during the inactive
state of the trigger source, and plays 
during the active state.

Ignores triggers 
received while a 
waveform is playing.

A trigger received while 
a waveform is playing 
waits until the current 
waveform completes, 
then plays the waveform 
once more.

A trigger received while 
the waveform is playing 
immediately restarts the 
waveform.

A segment in a sequence plays 
once, ignoring the repetition 
setting, after which the dual ARB 
player stops and waits for a 
trigger before advancing to the 
next segment. The next segment 
then plays to completion. 

If a trigger is received while a 
segment is playing, the segment 
plays to completion. The dual 
ARB player then advances to the 
next segment and plays that 
segment to completion.

A segment in a sequence plays continuously until the waveform receives another trigger. 

If a trigger is received while a segment is playing, the segment plays to completion. The 
dual ARB player then advances to the next segment and plays that segment continuously. 

For details on each key, use key help
as described on page 26.
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Trigger Source

External Trigger Polarity
• In Continuous, Single, and Segment Advance modes, use the Ext Polarity softkey to set the external 

trigger polarity.

• In Gated mode, the Active Low and Active High softkeys (page 113) determine the external 
trigger polarity. 

Mode >
Dual ARB > 
Trigger Source

Patt Trig In BNC connector 
(see page 15)

Aux I/O connector (see 
page 15)

Neg = the signal generator 
responds during the trigger signal 
low state.

Pos = the signal generator 
responds during the trigger signal 
high state.

For details on each key, use key help
as described on page 26.
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Example: Segment Advance Triggering

Segment advance triggering enables you to control the segment playback within a waveform sequence. 
This type of triggering ignores the repetition value (page 89). For example if a segment has repetition 
value of 50 and you select Single as the segment advance triggering mode, the segment still plays 
only once. The following example uses a waveform sequence that has two segments.

If you have not created and stored a waveform sequence, refer to “Creating a Sequence” on page 88.

1. Preset the signal generator.

2. Configure the RF output:

• Set the desired frequency.

• Set the desired amplitude.

• Turn on the RF output.

3. Select a waveform sequence for playback:

a. Press Mode > Dual ARB > Select Waveform.

b. In the Sequence On column, highlight a waveform sequence file.

c. Press Select Waveform.

4. Set the triggering as follows:

• Trigger Type: continuous Segment Advance
Press Trigger Type > Segment Advance > Continuous.

• Trigger source: Trigger hardkey
Press Trigger Source > Trigger Key.

5. Generate the waveform sequence: 
Press ARB Off On until On highlights.

6. (Optional) Monitor the waveform:

Connect the RF OUTPUT of the signal generator to the input of an oscilloscope, and configure the 
oscilloscope so that you can see the signal.

7. Trigger the first waveform segment to begin playing continuously: 
Press the Trigger hardkey.

8. Trigger the second segment: 
Press the Trigger hardkey.

Pressing the Trigger hardkey causes the currently playing segment to finish and the next segment 
to start.

If the last segment in the sequence is playing, pressing the Trigger hardkey causes the first 
segment in the waveform sequence to start when the last segment finishes.
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Example: Gated Triggering

Gated triggering enables you to define the on and off states of a modulating waveform.

1. Connect the output of a function generator to the signal generator’s rear- panel PATT TRIG IN 
connector, as shown in the following figure. This connection is applicable to all external triggering 
methods. The optional oscilloscope connection enables you to see the effect that the trigger signal 
has on the RF output.

2. Preset the signal generator.

3. Configure the RF output:

• Set the desired frequency.

• Set the desired amplitude.

• Turn on the RF output.

4. Select a waveform for playback (sequence or segment):

a. Press Mode > Dual ARB > Select Waveform.

b. In the Segment On or Sequence On column, highlight a waveform.

c. Press Select Waveform.

5. Set the triggering as follows:

• Trigger type: Gated
Press Trigger Type > Gated.

• Active state: Low
Press Active Low.

• Trigger source: External
Press Trigger Source > Ext.

• Input connector: Rear panel Patt Trig In BNC
Press Ext Source > Patt Trig In 1.

6. Generate the waveform: Press Return > ARB Off On until On highlights.
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7. On the function generator, configure a TTL signal for the external gating trigger.

8. (Optional) Monitor the waveform:

Configure the oscilloscope to display both the output of the signal generator, and the external 
triggering signal. You will see the waveform modulating the output during the gate active periods 
(low in this example).

The following figure shows an example display.

Modulating Waveform RF Output

Externally Applied Gating Signal
Gate Active = Low
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Example: External Triggering

Use the following example to set the signal generator to output a modulated RF signal 
100 milliseconds after a change in TTL state from low to high occurs at the PATT TRIG IN rear panel 
BNC connector

1. Connect the signal generator to the function generator as shown above.

2. Configure the RF output:

• Set the desired frequency.
• Set the desired amplitude.
• Turn on the RF output.

3. Select a waveform for playback (sequence or segment):

a. Press Mode > Dual ARB > Select Waveform.
b. In the Segment On or Sequence On column, highlight a waveform.
c. Press Select Waveform.

4. Generate the waveform: 
Press ARB Off On until On highlights.

5. Set the waveform trigger as follows:

a. Trigger Type: single
Press Trigger Type > Single > No Retrigger

b. Trigger Source: external
Press Trigger Source > Ext

c. Input connector: Rear panel Patt Trig In BNC
Press Ext Source > Patt Trig In 1.

d. External Trigger Polarity: positive
Press Ext Polarity until Pos highlights

e. External Delay: 100 ms
Press More > Ext Delay until On highlights
Press Ext Delay Time > 100 > msec

6. Configure the Function Generator:

• Waveform: 0.1 Hz square wave
• Output Level: 3.5V to 5V. 
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Clipping a Waveform
Digitally modulated signals with high power peaks can cause intermodulation distortion, resulting in 
spectral regrowth that can interfere with signals in adjacent frequency bands. The clipping function 
enables you to reduce high power peaks by clipping the I and Q data to a selected percentage of its 
highest peak, thereby reducing spectral regrowth.

• How Power Peaks Develop on page 120

• How Peaks Cause Spectral Regrowth on page 122

• How Clipping Reduces Peak- to- Average Power on page 123

• Configuring Circular Clipping on page 126

• Configuring Rectangular Clipping on page 127

Figure 8-8 Clipping Softkeys

Mode > Dual ARB > More 

Available only when 
clipping type = |I| , |Q|

For details on each key, use key help
as described on page 26.
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How Power Peaks Develop

To see how clipping reduces high power peaks, it is important to understand how the peaks develop 
as you construct a signal.

Multiple Channel Summing

I/Q waveforms can be the summation of multiple channels, as shown in the following figure. If a bit 
in the same state (high or low) occurs simultaneously in several individual channel waveforms, an 
unusually high power peak (positive or negative) occurs in the summed waveform. 

Because the high and low states of the bits in channel waveforms are random and generally result in 
a cancelling effect, high power peaks occur infrequently with multiple channel summing.
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Combining the I and Q Waveforms

When the I and Q waveforms combine in the I/Q modulator to create an RF waveform, the magnitude 

of the RF envelope is , where the squaring of I and Q always results in a positive value.

As shown in the following figure, simultaneous positive and negative peaks in the I and Q waveforms 
do not cancel each other, but combine to create an even greater peak.
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How Peaks Cause Spectral Regrowth

In a waveform, high power peaks that occur infrequently cause the waveform to have a high 
peak- to- average power ratio, as illustrated in the following figure. 

Because the gain of a transmitter’s power amplifier is set to provide a specific average power, high 
peaks can cause the power amplifier to move toward saturation. This causes the intermodulation 
distortion that generates spectral regrowth. Spectral regrowth is a range of frequencies that develops 
on each side of the carrier (similar to sidebands) and extends into the adjacent frequency bands (see 
the following figure). Clipping provides a solution to this problem by reducing the peak- to- average 
power ratio.
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How Clipping Reduces Peak-to-Average Power

You can reduce peak- to- average power, and consequently spectral regrowth, by clipping the waveform. 
Clipping limits waveform power peaks by clipping the I and Q data to a selected percentage of its 
highest peak. The Signal Generator provides two methods of clipping:

• Circular clipping is applied to the composite I/Q data (I and Q data are equally clipped).

As shown in Figure 8- 9, the clipping level is constant for all phases of the vector and appears as 
a circle in the vector representation.

• Rectangular clipping is independently applied the I and Q data.

 As shown in Figure 8- 10 on page 124, the clipping level is different for I and Q, and appears as 
a rectangle in the vector representation.

In both circular and rectangular clipping, the objective is to clip the waveform to a level that reduces 
spectral regrowth but does not compromise the integrity of the signal. The two complementary 
cumulative distribution plots in Figure 8- 11 on page 125 show the reduction in peak- to- average 
power that occurs after applying circular clipping to a waveform.

The lower the clipping value, the lower the peak power that is passed (the more the signal is 
clipped). The peaks can often be clipped without substantially interfering with the rest of the 
waveform. In many cases, data that might otherwise be lost in the clipping process is retained 
because of the error correction inherent in the coded systems. If you apply excessive clipping, 
however, lost data cannot be recovered. Experiment with clipping settings to find a percentage that 
reduces spectral regrowth while retaining needed data.

Figure 8-9 Circular Clipping
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Figure 8-10 Rectangular Clipping
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Figure 8-11 Reduction of Peak-to-Average Power
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Configuring Circular Clipping

Use this example to configure circular clipping and observe its affect on the peak- to- average power 
ratio of a waveform. Circular clipping clips the composite I/Q data (I and Q data are clipped equally). 
For more information about circular clipping, refer to “How Clipping Reduces Peak- to- Average Power” 
on page 123.

CAUTION Clipping is non- reversible and cumulative. Save a copy of the waveform file before you 
apply clipping.

Copy a Waveform File
1. Display the signal generator’s files: Press File > Catalog Type > More > Volatile Segments.

2. Highlight the waveform RAMP_TEST_WFM.

3. Press Copy File.

4. Name the copy (in this example, the name is MY_TEST_CIRC) and press Enter.

Apply Circular Clipping to the Copied Waveform File
1. Open the DUAL ARB Waveform Utilities menu: Press Mode > Dual ARB > More > Waveform Utilities.

2. In the list of files, highlight the copied file (in this example, MY_TEST_CIRC).

3. Create the CCDF plot: Press Plot CCDF. 

4. Observe the shape and position of 
the waveform’s curve (the dark line 
in the example at right).

5. Activate circular clipping: Press 
Return > Clipping > Clipping Type until 
|I+jQ| highlights.

6. Set circular clipping to 80%: 
Press Clip |I+jQ| To > 80 > %.

7. Apply 80% clipping to the I and Q 
data: Press Apply to Waveform.

8. Create the CCDF plot (see the 
example at right): Press Plot CCDF. 

9. Observe the waveform’s curve after 
clipping. 

Note the reduction in 
peak- to- average power relative to the 
previous plot.

Example waveform curve before clipping

Example waveform curve after circular clipping
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Configuring Rectangular Clipping

Use this example to configure rectangular clipping. Rectangular clipping clips the I and Q data 
independently. For more information about rectangular clipping, refer to “How Clipping Reduces 
Peak- to- Average Power” on page 123.

CAUTION Clipping is non- reversible and cumulative. Save a copy of the waveform file before you 
apply clipping.

Copy a Waveform File
1. Display the signal generator’s files: Press File > Catalog Type > More > Volatile Segments.

2. Highlight the waveform RAMP_TEST_WFM.

3. Press Copy File.

4. Name the copy (in this example, the name is MY_TEST_REC) and press Enter.

Apply Rectangular Clipping to the Copied Waveform File
1. Open the DUAL ARB Waveform Utilities menu: Press Mode > Dual ARB > More > Waveform Utilities.

2. In the list of files, highlight the copied file (in this example, MY_TEST_REC).

3. Create the CCDF plot: Press Plot CCDF. 

4. Observe the shape and position of 
the waveform’s curve (the dark line 
in the example at right).

5. Activate rectangular clipping: Press 
Return > Clipping > Clipping Type until 
|I|,|Q| highlights.

6. Set 80% clipping for the I data: Press 
Clip |I| To > 80 > %.

7. Set 40% clipping for the Q data: Press 
Clip |Q| To > 40 > %.

8. Apply the rectangular clipping to the waveform: Press Apply to Waveform.

9. Create the CCDF plot (see the 
example at right): Press Plot CCDF. 

10. Observe the waveform’s curve after 
clipping. 

Note the reduction in 
peak- to- average power relative to the 
previous plot.

Example waveform curve before clipping

Example waveform curve after rectangular clipping
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Scaling a Waveform
The signal generator uses an interpolation algorithm (sampling between the I/Q data points) when 
reconstructing a waveform. For common waveforms, this interpolation can cause overshoots, which 
may create a DAC over- range error condition. This chapter describes how DAC over- range errors 
occur and how you can use waveform scaling to eliminate these errors.

• How DAC Over- Range Errors Occur on page 130

• How Scaling Eliminates DAC Over- Range Errors on page 131

• Agilent MXG waveform scaling on page 132 and page 133:

— Waveform runtime scaling to scale a currently- playing waveform

— Waveform scaling to permanently scale either the currently playing waveform, or a non- playing 
waveform file in BBG media
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Figure 8-12 Scaling Softkeys

For details on each key, use key help
as described on page 26.

Waveform Runtime Scaling, see page 132

The settings in this menu 
can be stored to the file 
header, see page 91.

Waveform Scaling, see page 133
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How DAC Over-Range Errors Occur

The signal generator uses an interpolator 
filter when it converts digital I and Q 
baseband waveforms to analog 
waveforms. Because the clock rate of the 
interpolator is four times that of the 
baseband clock, the interpolator 
calculates sample points between the 
incoming baseband samples and smooths 
the waveform as shown in the figure at 
the right.

The interpolation filters in the DACs 
overshoot the baseband waveform. If a 
baseband waveform has a fast- rising 
edge, the interpolator filter’s overshoot 
becomes a component of the interpolated 
baseband waveform. This response 
causes a ripple or ringing effect at the 
peak of the rising edge. If this ripple 
overshoots the upper limit of the DAC 
range, the interpolator calculates 
erroneous sample points and is unable 
to replicate the true form of the ripple 
(see the figure at the right). As a result, 
the signal generator reports a DAC 
over- range error.
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How Scaling Eliminates DAC Over-Range Errors

Scaling reduces the amplitude of the baseband 
waveform while maintaining its basic shape and 
characteristics, such as peak- to- average power 
ratio. If the fast- rising baseband waveform is 
scaled enough to allow an adequate margin for 
the interpolator filter overshoot, the interpolator 
filter can calculate sample points that include 
the ripple effect and eliminate the over- range 
error (see the figure at the right).

Although scaling maintains the basic shape of 
the waveform, excessive scaling can compromise 
waveform integrity. For example, if the bit 
resolution becomes too low the waveform 
becomes corrupted with quantization noise. To 
achieve maximum accuracy and optimize 
dynamic range, scale the waveform no more 
than is required to remove the DAC over- range 
error. Optimum scaling varies with waveform 
content.
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Setting Waveform Runtime Scaling

Runtime scaling scales the waveform data during playback; it does not affect the stored data. You can 
apply runtime scaling to either a segment or sequence, and set the scaling value either while the ARB 
is on or off. This type of scaling is well suited for eliminating DAC over- range errors. Runtime scaling 
adjustments are not cumulative; the scaling value is applied to the original amplitude of the 
waveform file. There are two ways to save the runtime scaling setting: by using the save function 
(page 49) and by saving the setting to the file header (page 93). Saving to the file header saves the 
value with the waveform file, saving with the Save function stores the value as the current 
instrument setting.

Use this example to learn how to scale the currently selected waveform. 

1. Select the waveform to which you want to apply scaling:

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight the desired waveform (segment or sequence).
c. Press Select Waveform.

2. Play the selected waveform: Press ARB Off On until On highlights.

3. Set the Waveform Runtime Scaling value: 

a. Press ARB Setup > Waveform Runtime Scaling. 

b. Enter a scaling value.

The signal generator automatically applies the new scaling value to the waveform. There is no 
single value that is optimal for all waveforms. To achieve the maximum dynamic range, use 
the largest scaling value that does not result in a DAC over- range error. 

c. Press Return. 
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Setting Waveform Scaling

Waveform scaling differs from waveform runtime scaling in that it permanently affects waveform data 
and only applies to waveform segments stored in BBG media. You scale the waveform either up or 
down as a percentage of the DAC full scale (100%). If you scale your waveforms using this method, 
you may also need to change the waveform runtime scaling value to accommodate this scaling.

When you scale, the signal generator permanently modifies the waveform file’s sample values so that 
they conform to the desired scaling value. When you initiate scaling, the signal generator performs 
the following actions:

• locates the waveform file’s absolute peak sample value
• determines its current percentage of full scale
• calculates the ratio of the desired scale value to the determined absolute peak sample scale value
• multiplies each sample in the waveform file by this ratio

When you scale a waveform, you can create fractional data, lose data, or both. Fractional data occurs 
almost every time you reduce or increase the scaling value, and causes quantization errors. 
Quantization errors are more noticeable when scaling down, since you are closer to the noise floor. 
You lose data when either the signal generator rounds fractional data down or the scaling value is 
derived using the results from a power of two. This means that scaling a waveform in half (power of 
two: 21 = 2) causes each waveform sample to lose one bit. The waveform data modifications are not 
correctable and may cause waveform distortion. It is always best to make a copy of the original file 
prior to applying scaling.

Use the following examples to apply waveform scaling to a waveform file. While this process uses the 
factory- supplied waveform RAMP_TEST_WFM, it is the same for any waveform file.

Copy a Waveform File
1. Display the waveform files in BBG media: Press File > Catalog Type > More > Volatile Segments.

2. Highlight the waveform RAMP_TEST_WFM.

3. Press Copy File.

4. Name the copy (this example uses the name MY_TEST_SCAL) and press Enter.

Peak sample

85% of full scale—Prescaling

60% of full scale–Post scaling

DAC full scale 100%

Scaled sample value = scaling ratio × prescale sample val

Scaling ratio = desired scale val / current scale val
= 60 / 85
= 0.70588

Each sample in the waveform is multiplied by 0.70588 to
reach the 60% post scaling waveform amplitude.

Original ramp waveform Scaled ramp waveform

= Samples
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Apply Scaling to the Copied Waveform File

CAUTION This type of scaling is non- reversible. Any data lost in the scaling operation cannot be 
restored. Save a copy of the waveform file before scaling.

1. Open the DUAL ARB Waveform Utilities menu: 

Press Mode > Dual ARB > More > Waveform Utilities.

2. In the list of BBG Media segment files, highlight the copied file (in this example, MY_TEST_SCAL).

3. Set and apply a scaling value (in this example 70% scaling is applied): 

Press Scale Waveform Data > Scaling > 70 > % > Apply to Waveform.
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Setting the Baseband Frequency Offset
The baseband frequency offset enables you to shift the baseband frequency up to ±50 MHz within the 
BBG 100 MHz signal bandwidth, depending on the signal generator’s baseband generator option. 
While the following figure shows how to access the control using the Dual ARB player, the location of 
the Baseband Frequency Offset softkey within each arb format, through the ARB Setup softkey, is the same 
as for the Dual ARB player.

Figure 8-13 Baseband Frequency Offset Softkey for the Dual ARB Player

Common uses for the offset feature include:

• offsetting the carrier from any LO feedthrough (carrier signal spur at the carrier frequency)
• sum the baseband signal with external I and Q inputs to create a multicarrier signal
• use the signal generator’s I/Q signal as an IF

NOTE Changing the baseband frequency offset may cause a DAC over range condition that 
generates error 628, Baseband Generator DAC over range. The signal generator 
incorporates an automatic scaling feature to minimize this occurrence. For more information, 
see “DAC Over- Range Conditions and Scaling” on page 136.

The baseband frequency offset value is one of the file header parameters (page 91), which means you 
can store this value with the waveform. When you select a waveform with a stored frequency offset 
value, the signal generator changes the current value to match the stored file header value. If there 
is no stored baseband offset frequency value for the current waveform, the signal generator uses the 
last set frequency offset value. 

You can also use the Save function (page 49) to store this value as part of the signal generator setup. 

page 164

page 128

Frequency offset setting.

The settings in this menu 
can be stored to the file 
header, see page 91.

For details on each key, use key help
as described on page 26.

page 164

page 136
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When you Recall a setup stored with the Save function, the baseband frequency offset value becomes 
the current instrument setting value, disregarding the stored file header value.

Use the following steps to offset the carrier from LO/carrier feedthrough. This example uses the 
factory supplied waveform, SINE_TEST_WFM available in the Dual ARB Player. To view the output for 
this example, connect the RF OUTPUT of the signal generator to the input of a spectrum analyzer.

1. Select and play the waveform.

a. Press Mode > Dual ARB > Select Waveform.
b. In the Segment On BBG Media column, select SINE_TEST_WFM.
c. Press Select Waveform.

2. Generate the waveform: Press ARB Off On to On.

3. Configure the carrier signal:

a. Set the carrier signal to 1 GHz.
b. Set the amplitude to 0 dBm.
c. Turn on the RF OUTPUT.

4. Press ARB Setup > Baseband Frequency Offset > 20 MHz.

The modulated RF signal is now offset from the carrier frequency by 20 MHz as shown in the 
following figures.

DAC Over-Range Conditions and Scaling

When using the baseband frequency offset (at a setting other than 0 Hz), it is possible to create a 
DAC over- range condition, which causes the Agilent MXG to generate an error. To minimize this 
condition with the frequency offset feature, the Agilent MXG incorporates an automatic DAC 
over- range protection feature that scales down the I/Q data by 1/square root of 2 when the offset is 
something other than zero. Because it can scale the data by more than what is actually need, it 

Modulated carrier with 0 Hz 
baseband frequency offset

Modulated carrier with 20 MHz 
baseband frequency offset Modulated RF signal

LO/carrier feedthrough

Spectrum analyzer set to a span of 100 MHz
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typically decreases the dynamic range of the waveform. This is especially noticeable when using a 
constant amplitude signal such as GSM.

For the Dual ARB Player, this automatic over- range feature can be turned off. When on, it is active 
for the Dual ARB signal only when the offset is something other than 0 Hz. The control for the Dual 
ARB DAC over- range protection feature is located in the key path as shown in Figure 8- 14.

Figure 8-14 Dual ARB DAC Over-Range Protection Softkey Location

In the Dual ARB Player, to avoid excessive scaling or to just perform scaling manually, turn the 
feature off and use the Waveform Runtime Scaling softkey to eliminate DAC over- range conditions.

For details on each key, use key help
as described on page 26.

Default setting is On. Available only 
when Real-Time Phase Noise is on 
(see page 169).

Turn off when you want to manually 
control scaling while using the 
baseband frequency offset feature. 
Manually adjust the scaling using the 
Waveform Runtime Scaling softkey 
above.

When the DAC over-range protection is off, 
eliminate over-range conditions by 
decreasing the scaling value (see “Setting 
Waveform Runtime Scaling” on page 132).

Available only when 
Real-Time Phase Noise 
is on (see page 169).
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I/Q Modulation
The following factors contribute to the error vector magnitude:

• Differences in amplitude, phase, and delay between the I and Q channels

• DC offsets

The I/Q menu not only enables you to select the I/Q signal source and output, it also provides 
adjustments and calibrations to compensate for differences in the I and Q signals.

See also, “Modulating the Carrier Signal” on page 40.

Figure 8-15 I/Q Display and Softkeys

These selections are 
reflected in the 
I/Q Routing & 
Optimization graphic.page 141

This panel displays the current 
settings for the I/Q signal routing 
and I/Q correction optimized path.

This panel displays the current status and settings 
of the I/Q adjustments. Use the Page Up and 
Page Down keys to scroll through these 
parameters. Grey indicates an inactive (off) 
adjustment.

Used only with internally generated, 
bursted modulation formats. 
Enables/disables the RF burst modulator.

For details on each key, use key help
as described on page 26.

Each path requires different optimization values; 
when you select a path, you are selecting the 
unique optimization values required by that path. 

The signal generator applies the selected 
optimization values to both paths, which impairs 
the unselected path.

Inverts an internally generated Q signal, so that the I component lags the 
Q component by 90 degrees.

page 143
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Using the Rear Panel I and Q Outputs

NOTE The rear- panel I and Q connectors only output a signal while using the internal BBG.

In addition to modulating the carrier, the signal generator also routes the internally generated I and 
Q signals to the rear panel I and Q connectors. These output signals are post DAC, so they are in 
analog form. You can use these rear panel I and Q signals to:

• drive a system’s transmitter stage
• test individual analog I and Q components such as an I/Q modulator
• route the I and Q signals into another signal generator

The factory default setting routes the internally generated I and Q signals to the I/Q modulator and 
the rear panel I and Q output connectors. However to optimize (apply calibration factors) the rear 
panel signals, you need to select the external I/Q output path.

Select and Play a Waveform
1. Press Mode > Dual ARB > Select Waveform.
2. Highlight the desired waveform.
3. Press Select Waveform > ARB Off On to On.

Optimize the Signal Path
1. Connect cables from the rear panel I and Q connectors to either a DUT or another signal 

generator.

When you turn the ARB on, the signal generator automatically outputs the I and Q signals to the 
rear panel connectors. You can use the rear panel I and Q signals as I and Q inputs to another 
signal generator. The MXG has front panel connectors, I Input and Q Input, for this purpose.

2. Press I/Q > I/Q Correction Optimized Path > Ext I/Q Output.

When you optimize a path, the path indicator turns green.

Factory default setting—RF Output path optimized

Rear-panel I/Q path optimized
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Configuring the Front Panel Inputs

The signal generator accepts externally supplied analog I and Q signals through the front- panel I 
Input and Q Input. You can use the external signals as the modulating source, or sum the external 
signals with the internal baseband generator signals.

1. Connect I and Q signals to the front panel connectors.

a. Connect an analog I signal to the signal generator’s front- panel I Input.

b. Connect an analog Q signal to the signal generator’s front- panel Q Input.

2. Set the signal generator to recognize the front- panel input signals: 

• To Modulate onto the Carrier

Press I/Q > I/Q Source > External.

• To Sum and Modulate onto the Carrier

Press I/Q > I/Q Source > Sum.

To select and play a waveform for the BB GEN path, see page 85.

Notice that only the internal BBG (BB GEN) routes I and Q signals to the rear- panel I and Q 
outputs.

3. If you are using only the external I and Q signals (no summing), turn on the I/Q modulator: 
Press I/Q Off On to On.

4. Configure the RF output:

a. Set the carrier frequency.

b. Set the carrier amplitude.

c. Turn the RF output on.

Signal generator display: both paths are calibrated 
when the I/Q Correction Optimized Path is set to 
Ext I/Q Output (see page 139)

Note: when the optimized path is set to RF, only the 
RF Out path is calibrated.

Signal generator display: both RF paths are calibrated 
when the I/Q Correction Optimized Path is set to 
RF Output (see page 139)
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I/Q Adjustments
Use the I/Q Adjustments to compensate for or add impairments to the I/Q signal.

I/Q > I/Q Adjustments

Available only when a 
waveform is playing.

Available only
with Option 1EL

Adjusts the I signal amplitude relative to the Q 
signal amplitude. Use this as an internal 
impairment, or to compensate for differences in 
signal path loss that occur due to path 
irregularities in the external I and Q output 
cabling.

Offsets the phase of the Q signal 
relative to the phase of the I signal. 
The baseband quadrature 
adjustment key is calibrated in units 
of degrees. The external input 
quadrature adjustment is not 
calibrated. 
The function provided by this key is 
not the same as the function 
provided by the I/Q Skew key.

Skew is typically used either to create impairments, or to 
reduce error vectors on large bandwidth signals.

Provides a relative time delay correction between the I and 
Q signals. The different signal paths traveled by the I and Q 
signals result in time delay differences that show up as an 
EVM error in large bandwidth modulated signals. 

Adding an equal and opposite time delay (skew) in the I/Q 
signals during baseband generation eliminates the time 
delay error, correcting for any delays in signals that are 
generated in the internal baseband generator. 

Changes the absolute phase of both the I and Q signals with 
respect to triggers and markers. 

Positive values add delay and negative values advance the 
signals. This value affects both the baseband signal 
modulated onto the RF and the external output signals (I and 
Q). This setting cannot be used with constant envelope 
modulation and it does not affect external I and Q inputs.

Offsets are typically used to either reduce carrier leakage, or to create 
an impairment that simulates carrier leakage.

Common Mode I/Q Offset Range
This changes the adjustment range of the Common Mode I/Q Offset 
from Coarse (Default) to fine or vice versa. The Coarse range 
corresponds to the default value of ± 2.5V. The Fine range corresponds 
to a value of ± 100 mV.
Common Mode I/Q Offset
This adjusts the DC offset of both I and Q signals simultaneously.

Diff Mode I Offset
This adjusts the DC offset level of the I and I-bar output signal. I and 
I-bar cannot be adjusted independently.

Diff Mode Q Offset
This adjusts the DC offset level of the I and I-bar output signal. I and 
I-bar cannot be adjusted independently.

The DC offset values are calibrated relative to 
the RMS waveform voltage being played out of 
the ARB. See page 93.
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The I/Q adjustment, I/Q Delay, is not for adding impairments; its function is to compensate for any 
latency between the EVENT output signals (marker signals) and the RF output.

Table 8-2 I/Q Adjustments Uses

I/Q Adjustment Effect Impairment

Offset Carrier feedthrough dc offset

Quadrature Angle
EVM error phase skew

I/Q Images I/Q path delay

I/Q Skew EVM error
high sample rate phase 
skew or I/Q path delay

I/Q Gain Balance I/Q amplitude difference I/Q gain ratio
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I/Q Calibration
Use the I/Q calibration for I and Q signal corrections. What aspects of the I and Q signal is corrected 
depends on whether the signal is internally or externally generated.

When you perform an I/Q calibration, that calibration data takes precedence over the 
factory- supplied calibration data. The calibration routines improves performance that may degrade 
over time or due to temperature changes. 

Correction Internal I and Q External I and Q

Offset X X

Gain Balance X - -

Quadrature Error X X

I/Q > I/Q Calibration

Available only when
Calibration type = User

For details on each key, use key help
as described on page 26.

DC optimizes the I/Q performance for the current 
instrument settings, and typically completes in several 
seconds. Changing any instrument setting except for I/Q 
adjustments after performing a DC calibration voids the DC 
calibration and causes the signal generator to revert to the 
factory−supplied calibration data.

Presetting the instrument or cycling power is equivalent to 
pressing Revert to Default Cal Setting.

User provides a quicker calibration when a full calibration 
is not required. You can limit the calibration by specifying 
the calibration start and stop frequencies. 

When you limit the calibration to less than the instrument’s 
full frequency range, the factory−supplied calibration data 
is used for the rest of the range.

Information is retained through a preset or power cycle.

Full takes 5 minutes, executing measurements over the 
instrument’s entire frequency range. 

Information is retained through a preset or power cycle.

Deletes any user-generated 
calibration data and restores 
the factory−supplied 
calibration data.

Note

A DC calibration requires the following settings:

• I/Q: On
• Optimized Path: RF Output
• Source: Internal
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Multiple Baseband Generator Synchronization
Available in the Dual ARB menu, this feature lets you set up a master/slave system of up to sixteen 
Agilent MXGs so that the baseband generators (BBG) synchronize the playing of waveforms. The 
system count includes one Agilent MXG to function as the master (see “Equipment Setup” on 
page 147).

Figure 8-16 Multiple Baseband Generator Synchronization (BBG Synchronization) Trigger Softkeys and Menu Location

For details on each key, use key help
as described on page 26.

Greys out for slave instruments. 
Remains active for the master 
instrument.

see page 145

BBG sync automatically changes the trigger type to Trigger and Run 
if the current setting is Free Run or Gated. If desired, manually set 
differently on either the master or slaves, or both either before or 
after configuring the BBG sync setup parameters.

Free Run and Gated are unavailable choices while using BBG sync.

Master default settings. If 
desired, change these 
settings after designating the 
instrument as the master

Slave default settings. These 
settings are not accessible 
after selecting an instrument 
as a slave.

Note: The BBG sync feature automatically configures the trigger settings shown below. To avoid a settings conflict error in this 
process, manually configure the trigger settings prior to setting the BBG sync parameters shown on page 145.

see page 84

see page 112

Neg is the factory default setting. 
The slave selection changes it to 
Pos. If desired, manually change to 
Pos prior to selecting as a slave.

Note: A setting conflict error occurs 
when at the time of the master/slave 
selection, the following trigger setting(s) 
is true:
Master
• Free Run or Gated trigger type
Slave
• Free Run or Gated trigger type
• Ext Polarity Neg trigger source
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Figure 8-17 Multiple BBG Synchronization Front Panel Displays

For details on each key, use key help
as described on page 26.

Master Display and Available Softkeys

Slave Display and Available Softkeys

Select Off, Master, or Slave

Synchronizes the baseband 
generators for all instruments in the 
system. 

Note: Press only after pressing 
Listen for Sync on all slave 
instruments and the slaves show 
“Waiting For Sync” as the status.

Master shows one of the following messages:
• Out of Sync
• In Sync

Shows after pressing Sync Slaves

Master/slave indicator and setup 
diagram. 

After pressing, the slave waits for the 
synchronization signal initiated by 
the master.

Note: Press before pressing Sync 
Slaves on the master instrument.

Slave shows one of the following messages:
• Out of Sync
• Waiting for Sync

Shows after pressing Listen for Sync
• In Sync

Shows after pressing Sync Slaves on the master

Master/slave indicator and setup diagram. 
The bottom slave indicator is green on the 
last slave in the system.

Select Off, Master, or Slave

This is a persistent setting that 
survives both preset and cycling 
the power.

These are persistent settings that 
survive both preset and cycling the 
power.

Grayed-out on master, active for 
slaves.
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Understanding the Master/Slave System

System Delay

The multiple BBG synchronization feature provides a system for synchronizing the waveform 
generation capability of up to 16 signal generators to within a characteristic value of ± 8 ns between 
the master and the last slave. This minor amount of delay (± 8 ns) can be reduced further to 
picosecond resolution by using the I/Q Delay softkey located in the I/Q menu. To reduce the delay, 
check and adjust the BBG signal alignment for each signal generator in the system. For more 
information on adjusting the delay, see “I/Q Adjustments” on page 141.

The delay value includes compensation for cables that have less than 1 ns of propagation delay 
between the EVENT 1 and PAT TRIG connectors (see Equipment Setup). The recommended cable is an 
Agilent BNC cable, part number 10502A. The use of cables with greater propagation delay may not 
allow the signal generators to properly synchronize.

System Synchronization

Synchronization occurs after the master signal generator sends a one- time event pulse that 
propagates through and to each slave in the system. Prior to this event, each slave must recognize 
that it is waiting for this event pulse, which occurs during the system configuration (see “Configuring 
the Setup” on page 147). In order to properly send the synchronization pulse, the trigger source and 
the Dual ARB Player for each signal generator must be turned off.

The master/slave setup does not incorporate a feedback system between the slaves and the signal 
generator selected as the master. After synchronization, if changes occur to the Multi- BBG Sync 
Setup menu or a signal generator is added to the system, the master does not automatically 
resynchronize the setup. This may cause the signal generators in the system to incorrectly report 
their status as In Sync. 

The system can also misinterpret other signals as the synchronization pulse, which results in an 
incorrect In Sync status. These types of signals include a continuous trigger or an active Marker 
routed to the EVENT 1 connector. Improperly connected rear- panel cables can also create a false 
status.

You must resynchronize the entire system after making any change in one or all of the Multi- BBG 
Sync Setup menus, after adding a signal generator to the system, or in doubt as to the true status of 
a signal generator. Changes to parameters that are outside of the Multi- BBG Sync Setup menu such 
as waveform files, Dual ARB state, sample rate, scaling, carrier frequency or amplitude have no effect 
on the system synchronization. To resynchronize a system, see “Making Changes to the Multiple Sync 
Setup and Resynchronizing the Master/Slave System” on page 149.

System Trigger Setup

The multiple BBG synchronization feature restricts the trigger selections (see page 144) for each 
signal generator. For signal generators selected as slaves, you can only modify the trigger type (with 
restrictions). The trigger source is fixed and set to receive a trigger through the rear- panel PAT TRIG 
connector. On the master, you can change both the trigger type (with restrictions) and the trigger 
source. The trigger source provides three options for triggering the waveforms: external trigger, 
front- panel Trigger key, or the GPIB trigger.

If the trigger settings are other than what the BBG synchronization feature supports, the feature 
changes the trigger settings to what is shown on page 144. When this change occurs, the Agilent MXG 
generates a settings conflict error to alert you to the changes. To avoid the error generation, 
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appropriately configure the trigger settings prior to selecting a signal generator as the master or 
slave.

The system trigger propagates in the same manner as the synchronization pulse initiated by the 
master (see System Synchronization). So if it is not turned off during changes to the synchronization 
parameters, it can cause a false In Sync status.

The signal generator does not reset the trigger parameters when the multiple BBG synchronization 
feature is turned off. To play waveforms after disabling the feature, you must either set the trigger 
type to Free Run or provide a trigger to start the waveform play back.

Equipment Setup

Figure 8-18 Multiple Baseband Synchronization Setup

Configuring the Setup

Set the Common Parameters

Perform the following steps on all signal generators:

1. Set the frequency of the carrier signal.

2. Set the power level of the carrier signal.

3. Select the desired waveform (see page 84).

Do not turn the Dual ARB on.

There can be 1 to 15 
slaves in a setup. 

If not using the Trigger key, provide an external trigger 
source. For information on the PAT TRIG connector, 
see page 15.

PAT TRIG

PAT TRIG

PAT TRIG

10MHz Out

REF IN

10MHz Out

REF IN

REF IN

10MHz Out

EVENT 1

EVENT 1

EVENT 1

RF OUTPUT

RF OUTPUT

RF OUTPUT

RF OUTPUT

Note: To minimize synchronization delay, the Agilent BNC cable 10502A is the recommended 
cable for the rear-panel daisy chain connections (see page 146).

PAT TRIG 
or GPIB
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4. Except for triggering, set the desired waveform parameters such as markers and sample clock.

The baseband synchronization feature limits the trigger selections for both the master and slaves. 
If the current trigger settings include unsupported BBG synchronization parameters, the Agilent 
MXG generates a settings conflict error and changes the trigger settings. To avoid the settings 
conflict error, manually set the trigger parameters as shown on page 144 prior to setting the 
multiple BBG synchronization parameters.

5. Turn on the RF Output.

Set the BBG Synchronization Master Parameters
1. Press Mode > Dual ARB > ARB Setup > More > Multi-BBG Sync Setup > Multi-Bbg Sync Type > Master.

2. Set the number of slaves using the Number of Slaves softkey.

3. If desired, modify the trigger parameters (see page 144).

The master signal generator allows the modifications of both the trigger type and the trigger 
source.

a. Return to the Dual ARB menu (see page 144).

b. Set the desired trigger type and source.

c. Return to the Multi-BBG Sync Setup menu.

Set the BBG Synchronization Slave Parameters
1. Press Mode > Dual ARB > ARB Setup > More > Multi-BBG Sync Setup > Multi-BBG Sync Type > Slave.

2. Set the number of Slaves using the Number of Slaves softkey.

3. Set the slave position that the signal generator occupies.

There can be up to fifteen slaves in a system.

4. Press the Listen for Sync softkey and verify that Waiting for Sync appears in the Status area of 
the display.

5. If desired, select a different trigger type parameter:

a. Return to the Dual ARB menu (see page 144).

b. Set the desired trigger type.

c. Return to the Multi-BBG Sync Setup menu.

6. Repeat for each slave signal generator in the system.
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Synchronize the System

Perform this procedure only after setting the parameters for both the master and slave signal 
generators. If resynchronizing a system, use the procedure “Making Changes to the Multiple Sync 
Setup and Resynchronizing the Master/Slave System” on page 149.

1. On the master, press the Sync Slaves softkey.

NOTE All of the signal generators in the master/slave system must be resynchronized when any 
changes are made to the master/slave settings or with the addition of a slave instrument, 
even if In Sync appears after pressing the Listen for Sync softkey on the slave instruments.

2. On the front panel displays, ensure that all of the signal generators show In Sync as the Status.

Trigger and Play the Waveform
1. On all Agilent MXGs, press Mode > Dual ARB > ARB Off On to On.

2. Start the trigger signal going to the master signal generator.

Making Changes to the Multiple Sync Setup and Resynchronizing the Master/Slave System

If any changes are made to the master/slave parameters or a signal generator (slave unit) is added to 
the system, the system must be resynchronized even if In Sync appears in the Status portion of the 
display. 

1. Turn off the trigger source. If using the Trigger key, there is nothing to turn off.

If the trigger source is on and provides a continuous pulse stream, it may cause the signal 
generators to incorrectly display In Sync as the status after pressing the Listen for Sync softkey. 

2. On each of the signal generators, press Mode > Dual ARB > ARB Off On to Off.

If a signal generator(s) has the Dual ARB on during changes, signal generators further in the 
chain may incorrectly display In Sync after pressing the Listen for Sync softkey.

3. On each of the signal generators, press ARB Setup > More > Multi-BBG Sync Setup.

4. Make the changes in the Multi- BBG Sync Setup menu.

Out Of Sync appears as the status message.

5. On each of the slave signal generators, press Listen for Sync.

6. Ensure that all of the slaves’ Status show Waiting for Sync. If In Sync shows as the status, 
perform the following steps:

a. Check that the PATT TRIG to EVENT 1 cables are properly connected on the rear- panel.

A disconnected cable can cause a false In Sync status.

b. If the cables are connected, perform steps 1 and 2.

c. Press Listen for Sync and ensure that Waiting for Sync appears as the status.

7. On the master signal generator, press Sync Slaves.

8. Verify that In Sync appears as the status on all master/slave signal generators.

9. Perform the process “Trigger and Play the Waveform” on page 149.
Agilent N5181A/82A MXG Signal Generators User’s Guide 149



Basic Digital Operation (Option 651/652/654)
Waveform 5-Pack Licensing (Options 221-229)
Waveform 5-Pack Licensing (Options 221-229)
Waveform 5- Pack licensing enables you to create, generate, and permanently license up to 45 Signal 
Studio waveforms (e.g. Each Option 22x enables licensing of five waveforms (Option 221, 222, 223, ... 
229). 

Each Waveform 5- Pack License includes one N7699A- D01 30- day Signal Studio demo license. 
N7699A- D01 allows access to all N76xxB Signal Studio software products to create and generate 
signals for 30 days so you can build, test, and license individual waveforms of your choice.

To redeem Option 22x and N7699A- D01, refer to the N5182A- 22x Entitlement Certificate that comes 
with the N5182A- 22x order. 

Use the signal generator to manage the licensing of these waveforms. For example, you can use the 
signal generator to select individual waveforms for licensing and you can view a list of all currently 
licensed waveforms. 

Understanding Waveform 5-Pack Licensing

Waveforms licensed with 5- Pack cannot be exchanged. Once a waveform is licensed, that license is 
permanent and cannot be revoked or replaced. Option 22x waveform licenses are signal generator 
specific (i.e. signal generator serial number specific).

Waveform 5- Pack licensing enables you to create and generate signals which can be saved for 
unlimited use in a signal generator (i.e. Waveform 5- Pack Option 22x is a perpetual fixed waveform 
license). 

Use the Signal Studio software to build and download waveforms to the signal generator’s volatile 
memory to be played. When you are satisfied with the waveform, it must be stored to non- volatile 
memory before it can be licensed.

If a licensed Option 22x waveform file is transferred to another signal generator, the file must be 
licensed by a separate Option 22x that is in the other signal generator before it can be played. For 
more information on extracting and downloading waveform files, refer to the Programming Guide.

To license additional waveforms that exceed the number permitted by an Option 22x, you must 
purchase an Option 22x that you do not already own. For example if you already own Option 221 
with only two remaining licenses and you need ten more waveforms, purchase Options 222 and 223 
to have enough licenses to license ten more waveforms. This would leave two remaining licenses on 
Option 223. (Repurchasing Option 221 a second time, for the same signal generator, gives you no 
additional Waveform 5- Pack licenses.)

Each Option 22x comes with a redeemable certificate for the N7699A- D01 30- day Signal Studio demo 
license. The 30- day countdown for N7699A- D01, begins at the time of the redemption. For maximum 
usage when purchasing multiple Option 22x, only redeem one N7699A- D01 at a time (e.g. after the 
first 30- day N7699A- D01 license expires, redeem the 2nd, etc.). This maximizes the time allowed for 
waveform creation using the N7699A- D01 30- day Signal Studio demo license (refer to the 
N5182A- 22x Entitlement Certificate). N7699A- D01 30- day Signal Studio demo license cannot be 
purchased separately from Option 22x.

Downloaded waveforms can be licensed either during the N7699A- D01’s 30 days or after the 30 days 
expire. However, after expiration of the N7699A- D01, you cannot playback any unlicensed downloaded 
waveform until it is licensed using the Waveform 5- Pack License Option 22x.
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After licensing a waveform, you can make copies of the waveform using different file names for use 
on the same signal generator and even rename the original file without affecting the waveform 
license.

You can also use the Option 22x to license waveforms from N76xxB Signal Studio software 
downloaded during its 14- day free trial license. All of the N76xxB Signal Studio software products 
provide a 14- day trial period (trial license). This 14- day trial license lets you download and play back 
waveforms during the trial period. These waveforms are denoted by the TRL in the status message 
area of the waveform segment catalog. After the trial period expires, the TRL message is removed but 
the waveform remains. You can license these waveforms after the TRL message is gone. 

Waveform 5- Pack requires firmware version ≥A.01.20.

Installing an Option N5182A-22x Waveform 5-Pack Licensing
1. Load a Waveform 5- Pack license, Option N5182A- 22x, into the signal generator using License 

Manager or a USB media. For more information on loading the Waveform 5- Pack License, refer to 
the N5182A- 22x Entitlement Certificate.

2. Redeem the N7699A- D01 that came with your copy of Option 22x. For more information on 
redeeming the N7699A- D01, refer to the N5182A- 22x Entitlement Certificate.

Licensing a Signal Generator Waveform File
1. Create the waveform:

a. Download any of the N76xxB Signal Studio software that interest you. For downloading 
N76xxB Signal Studio software, refer to the N5182A- 22x Entitlement Certificate.

b. Create and download a waveform to a signal generator using any of the N76xxB Signal Studio 
software. Refer to your Signal Studio software Help.

Waveform 5-Pack Licensing Softkeys Overview

Figure 8-19 Waveform 5-Pack licensing Softkeys

For details on each key, use key help
as described on page 26.

page 152

Mode > Dual ARB > More > 
Waveform Utilities >

page 158

This softkey is only 
available if there is an 
Option 22x installed on the 
instrument.

Note: Waveforms licensed with 5-Pack cannot be “exchanged”. Once a waveform is 
licensed, that license is permanent and cannot be revoked or replaced. 
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Figure 8-20 Add a Waveform to 5-Pack Softkeys

For details on each 
key, use key help
as described on 
page 26.

Mode > Dual ARB > More > 
Waveform Utilities > 5-Pack 
Licensing > Add Waveforms to 
5-Pack

This softkey is only active when 
there are secure waveforms that 
can be added and a Waveform 
5-Pack license with available 
slots (i.e. if a waveform is already 
licensed or does not require 
licensing the softkey is greyed 
out). Refer to page 156.

This softkey 
displays a catalog 
of the waveform 
segments stored in 
the Int Storage or 
USB Media.

This softkey 
displays a catalog 
of the waveforms 
stored in the BBG 
memory.

Displays the name of the Waveform file and status. Refer to 
Table 8-3 on page 153.

To select a waveform 
to receive one of your 
Waveform 5-Pack 
licenses, use the 
arrow keys to highlight 
the waveform and 
then press Add 
Waveform. 

Note: Waveforms licensed with 5-Pack cannot 
be “exchanged”. Once a waveform is licensed, 
that license is permanent and cannot be 
revoked or replaced.
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Table 8-3 Waveform 5-Pack Licensing Status Messages for the “Catalog of Segment Files in Int Storage [or USB Media]” 

Status Message Meaning Notes

Empty field If no status message, then the waveform is 
licensable.

Once a Trial (TRL)a 
license expires, the 
waveform becomes 
licensable (i.e. the status 
message for the TRL 
waveform becomes an 
empty field).

If a licensed Option 22x 
waveform file is 
downloaded to another 
N5182A signal generator, 
the waveform becomes 
licensable on that other 
signal generator (i.e. the 
status message field is 
empty).

aTrial license (TRL) is not applicable to N7699A-D01. A license downloaded with N7699A-D01 always has an empty field before it is licensed 
with Option 22x. A Trial license is not licensable with Option 22x until after the 14-day trial expires.

5-Pack Licensed This waveform is licensed by Option 22x.

5-Pack License Not Required This status message applies to:

Any free waveforms provided with the 
Agilent MXG (e.g. RAMP_TEST_WFM, and 
SINE_TEST_WFM, etc.)

Any customer created waveform

Any waveforms that have a valid license (e.g. 
Trial (TRL) licenses, Advanced Design System 
(ADS), etc.). 

Once a Trial (TRL) 
license expires, the 
waveform becomes 
licensable (i.e. the status 
message for the TRL 
waveform becomes an 
empty field).

If a licensed Option 22x 
waveform file is 
downloaded to another 
N5182A signal generator, 
the waveform becomes 
licensable on that other 
signal generator (i.e. the 
status message field is 
empty).
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Example: Licensing a Signal Studio Waveform

The following steps add a single waveform file, to a Waveform 5- Pack license. Refer to Figure 8- 22 on 
page 156.

2. There are two methods to save a waveform to the internal memory:

NOTE Before you can license a waveform with the Waveform 5- Pack licensing, the waveform must 
be saved in either the internal storage or the USB media.

a. Save the file to internal storage using the Backup Waveform To Int Storage softkey:

1. Press Return > Return > More > Waveform Utilities > 5-Pack Licensing > Add Waveforms to 5-Pack.

2. Press Backup Waveform To Int Storage (refer to Figure 8- 21).

Figure 8-21Backup Waveform To Int Storage softkey

3. Go to 3 Step d.

b. If the waveform has already been stored in the signal generator using the Backup Waveform to 
Int Storage softkey then proceed to Step d. 

1. Otherwise use the ARB Segments menu Load Store softkey to store the waveform to 
internal storage. Refer to “Working with Files” on page 41.

2. Proceed to Step 3 once you’ve stored the waveform to internal storage (internal media).

3. License the waveform:

a. Press Return > Return > More > Waveform Utilities > 5-Pack Licensing > Add Waveforms to 5-Pack.

The signal generator displays a catalog of files labeled: Catalog of BBG Segment Files in 
BBG Memory.

b. Use the arrow keys to highlight and select the file to be licensed.

c. Press Add Waveform.

A warning is displayed: *** Waveform Licensing Warning!!! ***. If necessary, verify you 
have selected the correct waveform you want for licensing by pressing Return. Otherwise 
continue to the next step (refer to Figure 8- 22 on page 156).

d. Press Confirm Adding Waveform to 5-Pack.

The display returns to the Catalog of BBG Segment Files in BBG Memory and the file’s 
Status column is now labeled 5-Pack Licensed (refer to Figure 8- 22 on page 156).

Press this softkey to store the 
waveform into the Internal 
Storage and to activate the 
Confirm Adding Waveform 
To 5-Pack softkey.

The Confirm Adding 
Waveform To 5-Pack 
softkey remains inactive until 
the waveform is stored in 
internal storage.

For details on each key, use key help
as described on page 26.
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e. Make a backup copy of this waveform on a USB media or a computer (If the waveform is lost 
or deleted on the signal generator it cannot be recovered).

CAUTION It is important that a backup copy is made of any 5- Pack waveforms; the backup copy 
must be stored on a computer or other media. Do not store the backup copy on the 
signal generator. If all of the copies of the waveforms are deleted or lost, then there is 
no way to recover the waveform or reassign the license. Refer to “Working with Files” 
on page 41.
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Figure 8-22   Add Waveform to 5-Pack Softkey
Mode > Dual ARB > More > 
Waveform Utilities > 5-Pack 
Licensing > Add Waveforms to 
5-Pack

page 152

Status area for the 
waveform N7602B-WFM1 is 
empty and the Add 
Waveform softkey is active, 
indicating the waveform is 
licensable.

Note that N7602B-WFM1 has a Status of “5-Pack Licensed” 
and the Add Waveform softkey is no longer active.

This warning 
message 
indicates that 
this is the last 
chance for 
verifying that 
the waveform 
being 
licensed is the 
one you want. 
If the 
waveform 
selected has 
not been 
verified, press 
Return and 
verify the 
selection.

If the waveform 
selected for 
licensing has 
been verified as 
the waveform 
you want to be 
licensed, press 
Confirm 
Adding 
Waveform To 
5-Pack.
Caution! This 
step cannot be 
undone.

Important! Always 
backup licensed 
waveforms in a separate 
place from the 
instrument (e.g. 
computer, USB media, 
etc.).

For details on each key, use key 
help
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Basic Digital Operation (Option 651/652/654)
Waveform 5-Pack Licensing (Options 221-229)
Using Waveform 5-Pack History

The Waveform 5- Pack History softkeys can be used to manage the Waveform 5- Pack files on your 
signal generator. The 5- Pack History softkeys can be used to:

• Create a list for a specific Waveform 5- Pack licensed waveform including any renamed files that 
have been leveraged from that licensed waveform

• Create a list of all licensed and unlicensed waveforms on the signal generator

Refer to Figure 8- 23 on page 158, for a description of the Waveform 5- Pack History softkeys. 

The 5-Pack History softkey is only active, if you have previously stored a Waveform 5- Pack file in 
non- volatile memory (internal storage, or USB media). But, the softkey 5-Pack History tracks the 
history of licensed waveform files that may no longer be available in non- volatile memory (e.g. if the 
waveform file has been deleted from internal storage or is located on a USB media that is not 
attached to the instrument, the 5- Pack History softkey remains active). 5- Pack History retains a 
catalog of the Redemption Date, Waveform ID, and the Original Filename. 

NOTE You can display either a catalog of the Internal storage or of the USB media but not both at 
the same time.

If you switch from the internal storage to the USB media, and the instrument displays an 
“Error -230, Data corrupt or stale” this is typically because a file (or files) was found 
with the same name, but the file is a different waveform file (has a different Waveform ID) 
than the original 5- Pack licensed internal storage file.
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Basic Digital Operation (Option 651/652/654)
Waveform 5-Pack Licensing (Options 221-229)
Figure 8-23 Waveform 5-Pack History Softkeys

For details on each key, 
use key help
as described on page 26.

Mode > Dual ARB > More > 
Waveform Utilities > 5-Pack 
Licensing > 5-Pack History Only available when there have 

been waveforms with Waveform 
5-Pack licenses previously stored.

This area displays the date the waveform was licensed, the unique Waveform ID, and 
Original filename at the time the waveform was first redeemed. 

Displays the number of 
waveform licenses used 
and the number of total 
waveform license ‘slots’ 
available (e.g. For this 
example 3 of the 45 
licenses have been 
used).

Pressing this softkey searches for 
every copy of the highlighted 
waveform regardless of the current 
filename. If the search returns no 
results, then the original waveform has 
been deleted and cannot be found.

This screen displays all 
waveforms that are 
licensed by Option 22x. 

Location is the memory location:
*Int Storage
*BBG Memory, or
*USB Media

Note:

1) In this example, the waveform N7602B_1_COPY3 is stored in the Int Storage and playing in the BBG Memory.

2) In this example, the Int Storage has been selected as the non-volatile storage location. To view any 5-Pack waveforms stored on the USB media, the 
USB media must be selected as the default storage. Refer to page 41.

When you press Find Waveform, 
any copies of the originally saved 
waveform are displayed on the 
instrument (e.g. 
N7602B_1_COPY1, 
N7602B_1_COPY2, and 
N7602B_1_COPY3). In this 
example, the original filename 
N7602B_1 was not found because 
the original file was deleted or the 
name was changed. But three 
copies were found 
(N7602B_1_COPY3 was found in 
both the Int Storage and the 
BBG Memory).
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Basic Digital Operation (Option 651/652/654)
Waveform 5-Pack Licensing (Options 221-229)
Example: Finding the History of a Waveform 5-Pack License

Use the following procedure to create a catalog of licensed Waveform 5- Pack files in the internal 
storage or USB media. Refer to Figure 8- 24 on page 159, for the following procedure.

The following procedure generates a catalog for a Waveform 5- Pack file labeled: N7602B-WFM1.

1. On the signal generator:

a. Press Mode > Dual ARB > More > Waveform Utilities > 5-Pack Licensing > 5-Pack History

b. Use the arrow keys to highlight the cataloged file N7602B-WFM1.

c. Press Find Waveform

The instrument displays a catalog titled “Waveform 5-Pack Search Results”. This catalog 
displays a list of all of the files that are copies of the original file that was licensed with the 
Waveform 5- Pack licensing, named N7602B-WFM1. For this example, the copies are currently 
in the BBG memory and the Internal storage and named N7602B-WFM1 and 
N7602B-WFM1_COPY (respectively). Refer to Figure 8- 24 on page 159.

NOTE If no files are found, you can reload the backup copies that were made in Step e on 
page 155.

Figure 8-24 Using Waveform 5-Pack History “Find Waveform” Softkey

Mode > Dual ARB > More > 
Waveform Utilities > 5-Pack 
Licensing > 5-Pack History

The highlighted file 
N7602B-WFM1 is the 
waveform created in this 
example. (Notice the unique 
Waveform ID displayed for 
each licensed waveform.)

Notice that the originally 
5-Pack licensed waveform, 
N7602B-WFM1, has been 
changed to 
N7602B-WFM1_COPY and 
is saved in the Internal 
Storage and playing in the 
BBG Memory. 
If no waveforms are listed 
when Find Waveform is 
pressed, then the waveform 
cannot be found in BBG 
Memory, Internal 
Storage, or USB Media.

For details on each key, 
use key help
as described on page 26.

 see page 160.
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Basic Digital Operation (Option 651/652/654)
Waveform 5-Pack Licensing (Options 221-229)
Finding All Waveforms Associated with 5-Pack Licenses

The following procedure displays a catalog of all of the Waveform 5- Pack files in the BBG memory 
and the internal storage:

1. On the signal generator:

a. Press Mode > Dual ARB > More > Waveform Utilities > 5-Pack Licensing > Find All Waveforms

The instrument displays a catalog titled: Waveform 5-Pack Search Results. Refer to Figure 
8- 25. 

NOTE If no files are found, you can reload the backup copies that were made in Step e on 
page 155.

Figure 8-25 Using Waveform 5-Pack History “Find All Waveforms” Softkey

Mode > Dual ARB > More > Waveform Utilities > 
5-Pack Licensing > 5-Pack History > Find All 
Waveforms
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Basic Digital Operation (Option 651/652/654)
Waveform 5-Pack Licensing (Options 221-229)
Waveform 5-Pack Warning Messages

Figure 8-26

This standard warning is 
displayed every time a 
waveform is selected to be 
licensed. This notification 
indicates that one of the 
available “license slot[s]” is 
about to be used from 
Option 22x.

ALWAYS make 
backup copies of 
waveforms in a 
separate non-volatile 
memory in case a file 
is deleted or lost 
from the instrument’s 
internal storage.

This warning is displayed 
when an attempt is made 
to license a waveform that 
has not been saved to 
internal storage or USB 
media (i.e. waveforms 
cannot be licensed unless 
they have been stored to 
non-volatile memory). 
Press the Backup 
Waveform To Int Storage 
softkey.

This warning is displayed 
when there is insufficient 
memory or other problems 
with the internal storage, 
or USB media (non-volatile 
memory) and the 
waveform could not be 
saved to non-volatile 
memory.

This warning is displayed 
when the file being 
licensed is not backed up 
in internal storage or the 
USB media (non-volatile 
memory), but there is a file 
already in the internal 
storage or USB media, 
with the same name.
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Basic Digital Operation (Option 651/652/654)
Waveform 5-Pack Licensing (Options 221-229)
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9 Adding Real Time Noise to a Signal (Option 403)

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting the power level and frequency, refer to 
Chapter 3, “Basic Operation,” on page 25 and familiarize yourself with the information in that 
chapter.

This feature is available only in N5182A Agilent MXG Vector Signal Generators with Option 431. 
Option 431 requires Option 651, 652, or 654.

This chapter contains examples of using the additive white gaussian noise (AWGN) waveform 
generator, which is available only in vector signal generators with Option 403.

• “Adding Real- Time Noise to a Dual ARB Waveform” on page 164

• “Using Real Time I/Q Baseband AWGN” on page 167
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Adding Real Time Noise to a Signal (Option 403)
Adding Real-Time Noise to a Dual ARB Waveform
Adding Real-Time Noise to a Dual ARB Waveform

NOTE The procedures in this section that pertain specifically to adding Real- Time Noise (AWGN) to 
a waveform, are applicable to the Custom ARB, Multitone, and Two- Tone modulation 
standards too.

A vector signal generator with option 403 enables you to apply additive white gaussian noise (AWGN) 
to a carrier in real time while the modulating waveform plays in the dual ARB waveform player. This 
feature appears in each of the arb formats and as a stand- alone menu (Refer to Figure 9- 3 on 
page 167).
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Adding Real Time Noise to a Signal (Option 403)
Adding Real-Time Noise to a Dual ARB Waveform
Figure 9-1 Real Time I/Q Baseband AWGN Softkeys

For the selected carrier to noise ratio, 
the bandwidth over which the noise is 
integrated. Typically, Carrier Bandwidth 
(CBW) is the occupied bandwidth of the 
carrier.

The amount of noise power relative to 
the carrier power.

For details on each key, use key help
as described on page 26.

The state of the noise (on or off) 
is shown on the display.

The actual flat noise bandwidth (NBW), 
which should be slightly wider than the 
carrier bandwidth (typically 1.6 times 
wider). The occupied bandwidth is = 
(1.2 * the Flat Noise Bandwidth)

Figure 9-2 on page 166 
provides additional 
details on these settings.

This is the stand-alone Real-Time 
AWGN and the 2nd page of the 
Modulation Mode menu (see 
page 167).

Static graphic representation of ARB 
Real-Noise AWGN (i.e. graphic does 
not update as values change).

The relationship of the values are displayed in the static graphic of ARB Real-Time 
AWGN.

The Total Noise Power is the Noise Power over the occupied noise bandwidth (NBW * 
1.2).
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Adding Real Time Noise to a Signal (Option 403)
Adding Real-Time Noise to a Dual ARB Waveform
Figure 9-2 Carrier to Noise Ration Components

Example

Use the following steps to modulate a 1 GHz, –10 dBm carrier with the factory- supplied waveform 
SINE_TEST_WFM, and then apply noise with a 45 MHz bandwidth signal that has a 30 dB 
carrier–to–noise ratio across a 40 MHz carrier bandwidth.

1. Preset the signal generator and set the following:

• Frequency: 1 GHz
• Amplitude: −10 dBm
• RF output: on

2. Select the factory- supplied waveform SINE_TEST_WFM:

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight SINE_TEST_WFM and press Select Waveform.

3. Turn on the dual ARB player: press ARB Off On to highlight On.

4. Set the ARB sample clock to 50 MHz: Press ARB Setup > ARB Sample Clock > 50 > MHz.

5. Press Real-time Noise Setup and set the following:

• Carrier to Noise Ratio: 30 dB
• Carrier Bandwidth: 40 MHz
• Noise Bandwidth: 45 MHz
• Real- time Noise: on

The signal generator’s displayed power level (–10 dBm) includes the noise power.

Carrier BW
(CBW)

RMS 
(total carrier power)

C

Carrier BW
(CBW)

Carrier

Noise N

Noise BW 
(NBW) = 
flat noise 
bandwidth

The carrier now appears 
larger because of the 
added noise power.

Carrier Bandwidth (CBW) is typically the 
occupied bandwidth of the carrier and the Noise 
Bandwidth is the flat noise bandwidth (NBW).
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Adding Real Time Noise to a Signal (Option 403)
Using Real Time I/Q Baseband AWGN
Using Real Time I/Q Baseband AWGN

Figure 9-3 Real Time I/Q Baseband AWGN Softkeys

Use the following steps to apply 10 MHz bandwidth noise to a 500 MHz, –10 dBm carrier.

1. Configure the noise:

a. Preset the signal generator.

b. Press Mode > Real Time I/Q Baseband AWGN

c. Press Bandwidth > 10 > MHz.

2. Generate the noise:

Press AWGN Off On until On highlights.

During generation, the AWGN and I/Q 
annunciators activate (as shown at 
right). AWGN is now available to 
modulate the RF carrier.

3. Configure the RF output:

• Frequency: 500 MHz

• Amplitude: −10 dBm

• RF output: on

The carrier with AWGN is now available at the signal generator’s RF OUTPUT connector.

For details on each key, use key help
as described on page 26.
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Adding Real Time Noise to a Signal (Option 403)
Using Real Time I/Q Baseband AWGN
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10 Real-Time Phase Noise Impairments (Option 432)

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting the power level and frequency, refer to 
Chapter 3, “Basic Operation,” on page 25 and familiarize yourself with the information in that 
chapter.

This feature is available only in N5182A Agilent MXG Vector Signal Generators with Option 431. 
Option 431 requires Option 651, 652, or 654.

This chapter contains the softkey maps to locate the Phase Noise Impairment option functions and 
information on the use of this feature.

• Real- Time Phase Noise Impairment on page 170

• The Agilent MXG Phase Noise Shape and Additive Phase Noise Impairments on page 171

• Understanding the Phase Noise Adjustments on page 173

• DAC Over- Range Conditions and Scaling on page 174
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Real-Time Phase Noise Impairments (Option 432)
Real-Time Phase Noise Impairment
Real-Time Phase Noise Impairment
This feature lets you degrade the phase noise performance of the signal generator by controlling two 
frequency points and an amplitude value. The signal generator adds this phase noise to the phase 
noise normally produced by the Agilent MXG. This feature appears in each of the arb formats and as 
a stand- alone menu. While the following figure shows how to access the controls using both the 
stand- alone menu and the Dual ARB player, the location and softkeys within each arb format is the 
same as for the Dual ARB player.

Figure 10-1 Stand-Alone and Dual ARB Player Real-Time Phase Noise Softkeys

The end frequency for the flat 
mid-frequency characteristics.

The start frequency for the flat 
mid-frequency characteristics.

For details on each key, use key help
as described on page 26. 

The display updates even 
when the feature is off.

For an explanation on these 
settings see
“The Agilent MXG Phase Noise 
Shape and Additive Phase Noise 
Impairments” on page 171.

Flat Mid-Frequency Area

Denoted by f1 and f2

This softkey is 
available in all arb 
formats.

The amplitude for the flat 
mid-frequency characteristics. 
(Lmid stands for the level 
amplitude of the mid-frequency 
characteristic.)

NOTE: The phase noise impairment is added to the base phase noise of  
the signal generator.

Stand-alone menu

Use to add phase noise to the 
CW output without having to 
play a waveform.
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Real-Time Phase Noise Impairments (Option 432)
The Agilent MXG Phase Noise Shape and Additive Phase Noise Impairments
The Agilent MXG Phase Noise Shape and Additive Phase Noise Impairments

Flat mid-frequency offset

−50 dBc/Hz−50 dBc/Hz

Phase Noise Plots Without Phase Noise Impairment

The Agilent MXG demonstrates a definitive 
shape to its phase noise plot. The 
mid-frequency offsets are characterized by a 
leveling (flattening) of the phase noise 
amplitude from approximately a 3 kHz offset 
to approximately a 70 kHz offset.

Close in and far out offsets demonstrate 
slopping characteristics (areas before and 
after the mid-frequency offsets).

The signal generator degrades the phase noise by moving the mid- frequency characteristics and/or 
changing its amplitude using the following settings:

• Start frequency (f1) of the mid- frequency characteristics
• Stop frequency (f2) of the mid- frequency characteristics
• Amplitude (Lmid) of the mid- frequency characteristics

f1 f2

Mid-frequency characteristics

−50 dBc/Hz−50 dBc/Hz

Amplitude
(Lmid)

This is a plot of the unmodified phase noise 
shape that shows the location that each 
value alters.
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Real-Time Phase Noise Impairments (Option 432)
The Agilent MXG Phase Noise Shape and Additive Phase Noise Impairments
Flat mid-frequency offset 
(Lmid)

f1
f2

characteristics

Phase Noise Plots With Phase Noise Impairments

−50 dBc/Hz −50 dBc/Hz

Flat mid-frequency offset 
(Lmid)characteristics

No additive 
phase noise

Resultant phase
noise plot

When turned on, this phase noise is added 
to the base phase noise of the signal 
generator.

Even though it is only the mid-frequency 
characteristics placement that are modified, 
these changes affect the entire phase noise 
shape. The close in and far out offset 
characteristics change by exhibiting 
approximately a 20 dBc/Hz slope for each 
octave of frequency offset.

The resultant phase noise plot shown on 
the left has the following settings:

• f1 = 100 Hz
• f2 = 1 kHz
• Amplitude (Lmid) = -70 dBc

−20 dBc/Hz 
slope

f1 f2

−70 dBc

100 Hz 1 kHz

The frequency values entered for the impairments may not be the exact values when viewed on the 
RF output. The entered values are guidelines that the signal generator uses to calculate the real 
values. See “Understanding the Phase Noise Adjustments” on page 173 for more information.

To view the results of the settings (f1, f2, and Lmid), use the front panel graph (below and on 
page 170) or view the phase noise plot on a measurement instrument (shown above—Agilent E4440A 
PSA with Option 226).

−50 dBc/Hz −50 dBc/Hz

Signal generator front panel plot:

• f1 = 100 Hz
• f2 = 1 kHz
• Lmid = -70 dBc

Ensure that the f1 value is less than or 
equal to f2. If not, f2 changes its value to 
match f1. Conversely if f2 is set to a value 
that is less than f1, f1 changes its value to 
match f2.
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Real-Time Phase Noise Impairments (Option 432)
Understanding the Phase Noise Adjustments
Understanding the Phase Noise Adjustments
The signal generator bases the resultant phase noise shape on three settings, Lmid (amplitude), f1 
(start frequency), and f2 (stop frequency).

The range for Lmid is coupled to f2, so as f2 increases in value, Lmid’s upper boundary decreases. If 
the current Lmid setting is too high for the new f2 setting, the signal generator changes the Lmid 
value and generates an error to alert you to the change. In addition, the actual Lmid value can vary 
by 0.28 dBc/Hz from the entered value.

The frequency settings (f1 and f2) are really guidelines that the signal generator uses to calculate the 
real frequency offset values seen on the RF OUTPUT. This means that the entered start and stop 
frequency values are an approximation and may not be the values seen on a measurement 
instrument, however they will be close. 

The effects of the f1 and f2 parameters are based on a varying logarithmic scale. This scale is 
determined by the f2 value. The higher the f2 value the larger the scale, which makes this behavior 
more noticeable at higher frequency settings. This becomes apparent when a change in the f1 or f2 
value causes little to no change in the f1 or f2 position. This is easy to view using the signal 
generator’s front panel phase noise graph and demonstrated in Figure 10- 2. This behavior makes the 
frequency adjustments coarser as the f2 frequency value increases.

Figure 10-2 f1 and f2 Frequency Setting Behavior

The only way to make an accurate determination of the effect of the f1 and f2 values is by viewing 
the front panel graph or making a measurement. You can view the front panel graph remotely by 
using the LXI interface. For more information on the LXI interface, see the Programming Guide.

f1 and f2 softkey settings for the front 
panel phase noise graph. 

f1 did not change frequency until 
12.1 MHz was set. This means that it 
took an increase of 1.6 MHz to change 
its frequency offset.

f2 did not change frequency until 40 
MHz was set. This means that it took an 
increase of 10 MHz to change its 
frequency offset.

f1—original 10.5 MHz 
setting

f1—12.1 MHz setting that 
moved the offset position

f2—original 30 MHz 
setting

f2—40 MHz setting that 
moved the offset position

For details on each key, use key help
as described on page 26.
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Real-Time Phase Noise Impairments (Option 432)
DAC Over-Range Conditions and Scaling
DAC Over-Range Conditions and Scaling
When using phase noise impairment, it is possible to create a DAC over- range condition, which 
causes the Agilent MXG to generate an error. To minimize this condition with the phase noise 
impairment feature, the Agilent MXG incorporates an automatic DAC over- range protection feature 
that scales down the I/Q data. Because it can scale the data by more than what is actually need, it 
typically decreases the dynamic range of the waveform. This is especially noticeable when using a 
constant amplitude signal such as GSM.

For the Dual ARB Player, the automatic over- range protection can be turned off (on is the factory 
default). The control for the Dual ARB DAC over- range protection feature is located in the key path 
as shown in Figure 10- 3.

Figure 10-3 Dual ARB DAC Over-Range Protection Softkey Location

In the Dual ARB Player, to avoid excessive scaling or to just perform scaling manually, turn the 
over- range protection off and use the Waveform Runtime Scaling softkey to eliminate DAC over- range 
conditions.

When the automatic feature is disabled, the other options to eliminate a DAC over- range condition 
are to reduce the f2 value, or the Lmid value, or both until the condition corrects itself. 

For details on each key, use key help
as described on page 26.

When the DAC over-range protection is off, 
eliminate over-range conditions by 
decreasing the scaling value (see “Setting 
Waveform Runtime Scaling” on page 132).

Default setting is On. 

Turn off to manually control scaling while 
using the phase noise impairment option. 
Manually adjust the scaling using the 
Waveform Runtime Scaling softkey 
shown above.
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11 Custom Digital Modulation (Option 431)

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting the power level and frequency, refer to 
Chapter 3, “Basic Operation,” on page 25 and familiarize yourself with the information in that 
chapter.

This feature is available only in N5182A Agilent MXG Vector Signal Generators with Option 431. 
Option 431 requires Option 651, 652, or 654.

• Custom Modulation on page 176

• Using the Arbitrary Waveform Generator on page 181

• Using Finite Impulse Response (FIR) Filters on page 190

• Modifying a FIR Filter Using the FIR Table Editor on page 194
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Custom Digital Modulation (Option 431)
Custom Modulation
Custom Modulation 
Custom Modulation has built- in modulation standards such as TETRA and DECT; and pre- defined 
modulation types such as BPSK and 16QAM that can be used to create a signal in addition, it 
provides the flexibility to modify the digital format’s attributes. 

Custom Arb Waveform Generator

The signal generator’s Arb Waveform Generator mode is designed for out- of- channel test applications. 
This mode can be used to generate data formats that simulate random communication traffic and can 
be used as a stimulus for component testing. Other capabilities of the Arb Waveform Generator mode 
include: 

• configuring single or multicarrier signals. Up to 100 carriers can be configured. 

• creating waveform files using the signal generator’s front panel interface.

The waveform files, when created as random data, can be used as a stimulus for component testing 
where device performance such as adjacent channel power (ACP) can be measured. The 
AUTOGEN_WAVEFORM file, that is automatically created when you turn the Arb Waveform Generator on, 
can be renamed and stored in the signal generator’s non- volatile memory. This file can later be 
loaded into volatile memory and played using the dual ARB waveform player. 

For more information, refer to Waveform File Basics on page 82 and Modes of Operation on page 3.
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Custom Digital Modulation (Option 431)
Custom Modulation
Figure 11-1  Custom ARB Softkeys

page 178

page 135

page 82

page 187

This softkey changes, depending 

on the selected Mode of Modulation.

Available only when 
Multicarrier is On.

Available only when 
Multicarrier is Off.

page 187

Enables the current custom 
ARB settings.

For details on each key, use key help as described on page 26.

page 112

page 83
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Custom Digital Modulation (Option 431)
Custom Modulation
Figure 11-2  Quick Setup Softkeys

page 179

page 190

page 186

Mode > Custom ARB > Digital Mod Setup

page 180

This softkey label shows 
the currently selected 
modulation standard.

Press Symbol Rate 
softkey and use 
numeric keypad to 
change value as 
required. 

The default (initial) 
Symbol Rate 
maximum range value 
is dependent upon the 
modulation standard 
selected with the 
Quick Setup softkey.

When one of these pre-defined 
modulation standards is selected, 
default values for components of the 
setup (including filter, symbol rate, and 
modulation type) are automatically 
specified.

For details on each key, use key help as described on page 26.

Default: This softkey selects the 
following default settings:

Modulation Type = QPSK, 

Symbol Rate = 1 Msps, 

Filter = Root Nyquist, and 

Filter Alpha = 0.5
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Custom Digital Modulation (Option 431)
Custom Modulation
Figure 11-3 Mod Type Softkeys

page 190

page 178

page 180

Mode > Custom ARB > Digital Mod Setup

page 183

Sets the modulation depth for the 
Amplitude Shift Keying (ASK).

Sets the symmetric Frequency Shift 
Keying (FSK) frequency deviation value.

For details on each key, use key help as described on page 26.
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Custom Digital Modulation (Option 431)
Custom Modulation
Figure 11-4 Store Custom Dig Mod Softkeys

Catalog displays digital 
modulation (DMOD) files that 
have been previously saved.

page 185

Mode > Custom ARB > Digital Mod Setup > Store Custom Dig Mod State

For details on each key, use key help as described on page 26.
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Custom Digital Modulation (Option 431)
Using the Arbitrary Waveform Generator
Using the Arbitrary Waveform Generator
This section teaches you how to build dual arbitrary (ARB) waveform files containing custom TDMA, 
digital modulation for testing component designs. 

Figure 11-5 Adding Custom Modulation to a Waveform

Using Predefined Custom TDMA Digital Modulation

This section teaches you how to perform the following tasks:

• Selecting a Predefined EDGE Setup on page 181

• Generating the Waveform on page 181

• Configuring the RF Output on page 182

Selecting a Predefined EDGE Setup

1. Press Preset.

2. In the Custom ARB menu (page 181), press Digital Mod Setup > Quick Setup > EDGE.

Generating the Waveform

Press Digital Modulation Off On.

This generates a waveform with the pre- defined EDGE state selected in the step. The display changes 
to Dig Mod Setup: EDGE. During waveform generation, the DIGMOD and I/Q annunciators appear and 
the pre- defined digital modulation state is stored in volatile memory (BBG). The waveform is now 
modulating the RF carrier.

page 190

page 180

This softkey label updates to reflect 
the current modulation type.

Mode > Custom ARB > Digital Mod Setup

page 179

page 186

For details on each key, use key help as described on page 26.
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Configuring the RF Output

1. Set the RF output frequency to 891 MHz. 

2. Set the output amplitude to −5 dBm. 

3. Press RF On/Off.

The predefined EDGE signal is now available at the signal generator’s RF OUTPUT connector.
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Creating a Custom TDMA Digital Modulation State
In this procedure, you learn how to set up a single- carrier NADC digital modulation with customized 
modulation type, symbol rate, and filtering.

Figure 11-6 Modifying a Digital Modulation Type

This softkey label updates to reflect 
the current modulation standard.

Mode > Custom ARB > Digital Mod Setup

page 186

This softkey 
sets the filter 
bandwidth 
parameter, 
alpha. The 
default Alpha 
value changes 
with the 
modulation 
standard (see 
page 190) and 
modulation 
type selected 
(see 
page 179).

For details on each key, use key help as described on page 26.

This softkey sets 
the filter shape.

Note: This is the 
2nd page of the 
PSK menu.
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This section teaches you how to perform the following tasks:

• Selecting a Digital Modulation Setup on page 184

• Configuring the RF Output on page 182

• Selecting the Filter on page 184

• Configuring the RF Output on page 182

Selecting a Digital Modulation Setup

1. Press Preset.

2. In the Custom Arb menu (page 183), press Digital Mod Setup > Quick Setup > NADC.

Modifying the Modulation Type and Symbol Rate

1. In the Custom ARB menu (page 183), press Digital Mod Setup > Modulation Type > PSK > QPSK and 
OQPSK > QPSK.

2. Press Symbol Rate > 56 > ksps.

Selecting the Filter

1. In the Setup Mod menu (page 183), press Filter > Select > Nyquist.

2. Press Return > Return.

Generating the Waveform

Press Digital Modulation Off On.

This generates a waveform with the custom, single- carrier NADC, digital modulation state created in 
the previous sections. The display changes to Dig Mod Setup: NADC (Modified). During waveform 
generation, the DIGMOD and I/Q annunciators appear and the custom single- carrier digital modulation 
state is stored in volatile memory. The waveform is now modulating the RF carrier.

For instructions on storing this custom, single- carrier NADC, digital modulation state to the 
non- volatile memory catalog, see Storing a Custom TDMA Digital Modulation State on page 184. 

Configuring the RF Output

1. Set the RF output frequency to 835 MHz. 

2. Set the output amplitude to 0 dBm. 

3. Press RF On/Off.

The user- defined NADC signal is now available at the RF OUTPUT connector.

Storing a Custom TDMA Digital Modulation State
Using this procedure, you learn how to store a custom digital modulation state and a custom 
multicarrier digital modulation state to non- volatile memory.

If you have not created a custom, single- carrier, digital modulation state, complete the steps in the 
previous section, Creating a Custom TDMA Digital Modulation State on page 183.
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Figure 11-7 Storing a Custom Digital Modulation State

1. Return to the top- level Custom ARB menu, where Digital Modulation Off On is the first softkey.

2. In the Custom ARB menu (page 185), press Digital Mod Setup > Store Custom Dig Mod State > Store To 
File.

If there is already a file name from the Catalog of DMOD Files occupying the active entry 
area, press the following key: Clear Text

3. Enter a file name (for example, NADCQPSK) using the alpha keys and the numeric keypad with a 
maximum length of 23 characters.

4. Press Enter.

The user- defined, single- carrier, digital modulation state is now stored in non- volatile memory.

NOTE The RF output amplitude, frequency, and operating state settings are not stored as part of a 
user- defined, digital modulation state file.

Catalog displays DMOD files that 
have been previously saved by 
the user.

Mode > Custom ARB > Digital Mod Setup

page 27

These keys manage the table 
of DMOD files in internal 
storage.

For details on each key, use key help as described on page 26.
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Recalling a Custom TDMA Digital Modulation State
Using this procedure, you will learn how to recall a custom digital modulation state from signal 
non- volatile memory.

If you have not created and stored a user- defined, single- carrier, digital modulation state, complete 
the steps in the previous sections, Creating a Custom TDMA Digital Modulation State on page 183 
and Storing a Custom TDMA Digital Modulation State on page 184, then preset the signal generator 
to clear the stored user- defined, digital modulation waveform from volatile ARB memory.

Figure 11-8 Recalling a Custom TDMA Digital Modulation State

1. In the Quick Setup menu, press Custom Digital Mod State.

2. Highlight the desired file (for example, NADCQPSK).

3. Press Select File > Return.

4. Press Digital Modulation Off On until On is highlighted.

The instrument regenerates the custom, digital modulation waveform in volatile memory. After 
waveform generation, the custom, digital modulation waveform is available to be modulated on the 
RF output.

For instruction on configuring the RF output, see Configuring the RF Output on page 182.

Mode > Custom ARB > Digital Mod Setup > Quick Setup

Loads the highlighted file 
into the instrument 

memory.

These keys manage the table 
of DMOD files in internal 
storage.

For details on each key, use key 
help as described on page 26.
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Using the Arbitrary Waveform Generator
Creating a Custom Multicarrier TDMA Digital Modulation State

In this procedure, you learn how to customize a predefined, multicarrier, digital modulation setup by 
creating a custom, 3- carrier EDGE, digital modulation state.

This section teaches you how to perform the following tasks:

• “Creating a Multicarrier Digital Modulation Setup” on page 187

• “Modifying Carrier Frequency Offset” on page 188

• “Modifying Carrier Power” on page 188

• “Generating the Waveform” on page 188

• “Configuring the RF Output” on page 188

Figure 11-9 Creating a Multicarrier Digital Modulation Setup

Creating a Multicarrier Digital Modulation Setup

1. Press Preset.

Mode > Custom ARB

Becomes active when a change 
has been made to the 
Multicarrier Setup table values 
or to the multicarrier menu 
values (i.e. Carrier Setup, # of 
Carriers, Freq Spacing, or to the 
Carrier Phases).

For details on each key, use key help as described on page 26.
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2. Press Mode > Custom ARB > Multicarrier Off On to On.

3. Press Multicarrier Define > Initialize Table > Carrier Setup > EDGE > Done.

Modifying Carrier Frequency Offset

1. Highlight the Freq Offset value (500.000 kHz) for the carrier in row 2.

2. Press -625 > kHz.

Modifying Carrier Power

1. Highlight the Power value (0.00 dB) for the carrier in row 2.

2. Press -10 > dB.

You now have a custom 2- carrier EDGE waveform with a carrier at a frequency offset of 
−625 kHz and a power level of −10.00 dBm, as shown in the following figure.

Generating the Waveform

Press Return > Digital Modulation Off On.

This generates a waveform with the custom, multicarrier, EDGE state created in the previous 
sections. The display changes to Dig Mod Setup: Multicarrier (Modified). During waveform 
generation, the DIGMOD and I/Q annunciators appear and the new custom, multicarrier, EDGE state 
is stored in volatile memory. The waveform is now modulating the RF carrier.

For instructions on storing this custom, multicarrier, EDGE state to non- volatile memory, see “Storing 
a Custom Multicarrier TDMA Digital Modulation State” on page 189. 

Configuring the RF Output

1. Set the RF output frequency to 890.01 MHz. 

2. Set the output amplitude to −10 dBm. 

3. Press RF On/Off.

The custom multicarrier EDGE signal is now available at the RF OUTPUT connector.

If Digital Modulation is already on, you 
must press Apply Multicarrier to apply 
the changes and generate a new 
custom multicarrier digital modulation 
waveform based on the updated 
values.

For details on each key, use key 
help as described on page 26.
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Storing a Custom Multicarrier TDMA Digital Modulation State
Using this procedure, you learn how to store a custom, multicarrier, TDMA, digital modulation state 
to non- volatile memory.

If you have not created a custom, multicarrier, digital modulation state, complete the steps in the 
previous section, “Creating a Custom Multicarrier TDMA Digital Modulation State” on page 187.

Figure 11-10 Storing a Custom Multicarrier Softkeys

1. Return to the top- level Digital Modulation menu, where Digital Modulation Off On is the first softkey.

2. Press Multicarrier Define > More > Load/ Store > Store To File.

If there is already a file name from the Catalog of MDMOD Files occupying the active entry 
area, press the following key: Clear Text

3. Enter a file name (for example, EDGEM1) using the alpha keys and the numeric keypad with a 
maximum length of 23 characters.

4. Press Enter.

The user- defined, multicarrier, digital modulation state is now stored in non- volatile memory.

NOTE The RF output amplitude, frequency, and operating state settings are not stored as part of a 
user- defined, digital modulation state file.

Applying Changes to an Active Multicarrier TDMA Digital Modulation State
If the digital modulation format is currently in use (Digital Modulation Off On set to On) while changes 
are made in the Multicarrier Setup table editor, you must apply the changes before the updated 
waveform will be generated.

From the Multicarrier Setup table editor, press Apply Multicarrier to apply the changes and generate 
a new custom multicarrier digital modulation waveform based on the updated values.

page 27

Fixed: All the carriers are set to a 
phase of 0.

Random: All of the carriers are 
set to a random phase value.

For details on each key, use key help as 
described on page 26.
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Using Finite Impulse Response (FIR) Filters
Finite Impulse Response filters can be used to refine the symbol of the generated waveforms. 

Figure 11-11 Filter Menu

Creating a User-Defined FIR Filter Using the FIR Table Editor
In this procedure, you use the FIR Values table editor to create and store an 8- symbol, windowed 
sync function filter with an oversample ratio of 4.

Accessing the Table Editor

1. Press Preset.

2. Press Mode > Custom ARB > Digital Mod Setup > Quick Setup > NADC.

3. Press Filter > Define User FIR. 

4. Press More 1 of 2 > Delete All Rows > Confirm Delete of All Rows. 

This will initialize the table editor as shown in Figure 11- 12.

Mode > Custom ARB > Digital Mod Setup > Filter

This 
replaces the 
current FIR 
filter with the 
factory 
installed 
default filter 
settings for 
the current 
modulation 
type.

This softkey changes, depending 

on the selected filter-type.

Available only when the filter selected =
Root Nyquist or Nyquist

Available only when the 
filter selected = Gaussian

page 194

page 191

When a 
modulation 
standard is 
selected the 
instrument 
selects a 
corresponding 
default filter 
type.

For details on each key, use key help as described on page 26.
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Figure 11-12Creating a User-Defined FIR Filter Using the FIR Filter Table Editor

Entering the Coefficient Values

1. Press the Return softkey to get to the first page of the table editor. 

2. Use the cursor to highlight the Value field for coefficient 0. 

3. Use the numeric keypad to type the first value (−0.000076) from Table 11- 1. As you press the 
numeric keys, the numbers are displayed in the active entry area. (If you make a mistake, you can 
correct it using the backspace key.)

4. Continue entering the coefficient values from the table in step 1 until all 16 values have been 
entered.

Table 11-1

Coefficient Value Coefficient Value

0 −0.000076 8 −0.035667

1 −0.001747 9 −0.116753

2 −0.005144 10 −0.157348

3 −0.004424 11 −0.088484

4 0.007745 12 0.123414

5 0.029610 13 0.442748

6 0.043940 14 0.767329

7 0.025852 15 0.972149

Mode > Custom ARB > Digital Mod Setup > Filter > Define User FIR > 
More 1 of 2 > Delete All Rows > Confirm Delete of All Rows

Opens a menu that 
enables you to select 
and load a saved file 
into volatile memory. 
See page 27.

page 195

Active only when:
FIR filter coefficient table 
has minimum of two 
values visible.

For details on each key, use key help as described on page 26.
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Duplicating the First 16 Coefficients Using Mirror Table

In a windowed sinc function filter, the second half of the coefficients are identical to the first half in 
reverse order. The signal generator provides a mirror table function that automatically duplicates the 
existing coefficient values in the reverse order.

1. Press Mirror Table. The last 16 coefficients (16 through 31) are automatically generated and the 
first of these coefficients (number 16) highlights, as shown in Figure 11- 13 on page 192. 

Figure 11-13

Setting the Oversample Ratio

The oversample ratio (OSR) is the number of filter coefficients per symbol. Acceptable values range 
from 1 through 32; the maximum combination of symbols and oversampling ratio allowed by the table 
editor is 1024. The instrument hardware, however, is actually limited to 32 symbols, an oversample 
ratio between 4 and 16, and 512 coefficients. So if you enter more than 32 symbols or 512 
coefficients, the instrument is unable to use the filter. If the oversample ratio is different from the 
internal, optimally selected one, then the filter is automatically resampled to an optimal oversample 
ratio.

For this example, the desired OSR is 4, which is the default, so no action is necessary.

Displaying a Graphical Representation of the Filter

The signal generator has the capability of graphically displaying the filter in both time and frequency 
dimensions.

1. Press More 1 of 2 > Display FFT (fast Fourier transform). 

Refer to Figure 11- 14 on page 193.

FIR table coefficient 
values, may be from the 
factory default values or 
entered by the user.

Use the Goto Row 
menu to move around 
and make changes to 
the FIR Values 
coefficient table.For details on each key, use key help as described on page 26.
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Figure 11-14

2. Press Return.

3. Press Display Impulse Response. 

Refer to Figure 11- 15.

Figure 11-15

4.  Press Return to return to the menu keys.

Storing the Filter to Memory

 Use the following steps to store the file.

1. Press Load/Store > Store To File. The catalog of FIR files appears along with the amount of memory 
available.

2. As described in Storing, Loading, and Playing a Waveform Segment on page 84, name and store 
this file as FIR_1.

The FIR_1 file is the first file name listed. (If you have previously stored other FIR files, additional 
file names are listed below FIR_1.) The file type is FIR and the size of the file is 260 bytes. The 
amount of memory used is also displayed. The number of files that can be saved depends on the size 
of the files and the amount of memory used. Refer to Figure 11- 16.

For details on each key, use key 
help as described on page 26.

For details on each key, use key 
help as described on page 26.
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Figure 11-16

Memory is also shared by instrument state files and list sweep files.

This filter can now be used to customize a modulation format or it can be used as a basis for a new 
filter design. 

Modifying a FIR Filter Using the FIR Table Editor
FIR filters stored in signal generator memory can easily be modified using the FIR table editor. You 
can load the FIR table editor with coefficient values from user- defined FIR files stored in 
non- volatile memory or from one of the default FIR filters. Then you can modify the values and store 
the new files. 

Catalog displays FIR files that 
have been previously saved by 
the user.

These keys manage the table 
of DMOD files in internal 
storage.

For details on each key, use key help as described on page 26.
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Loading the Default Gaussian FIR File

Figure 11-17 Loading the Default Gaussian FIR File

1. Press Preset.

2. Press Mode > Custom ARB > Digital Mod Setup > Quick Setup > NADC.

3. Press Filter > Define User FIR > More 1 of 2 > Load Default FIR > Gaussian.

4. Press Filter BbT > 0.300 > Enter.

Mode > Custom ARB > Digital Mod Setup

These softkeys select a 
window function 
(apodization function) for 
a filter.

For details on each key, use key help as described on page 26.
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5. Press Filter Symbols > 8 > Enter.

6. Press Generate. 

NOTE The actual oversample ratio during modulation is automatically selected by the instrument. A 
value between 4 and 16 is chosen dependent on the symbol rate, the number of bits per 
symbol of the modulation type, and the number of symbols.

7. Press Display Impulse Response (refer to Figure 11- 18).

Figure 11-18

8. Press Return.

Modifying the Coefficients

1. Using the front- panel arrow keys, highlight coefficient 15.

2. Press 0 > Enter.

3. Press Display Impulse Response.

Figure 11-19

For details on each key, use key 
help as described on page 26.

For details on each key, use key 
help as described on page 26.
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Refer to Figure 11- 19 on page 196. The graphic display can provide a useful troubleshooting tool 
(in this case, it indicates that a coefficient value is missing, resulting in an improper Gaussian 
response).

4. Press Return.

5. Highlight coefficient 15. 

6. Press 1 > Enter. 

Storing the Filter to Memory

The maximum file name length is 23 characters (alphanumeric and special characters).

1. Press Load/Store > Store To File. 

2. Name the file NEWFIR2.

3. Press Enter. 

The contents of the current FIR table editor are stored to a file in non- volatile memory and the 
catalog of FIR files is updated to show the new file. 
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12 Multitone and Two-Tone Waveform Generator 
(Option 430)

Before using this information, you should be familiar with the basic operation of the signal generator. 
If you are not comfortable with functions such as setting the power level and frequency, refer to 
Basic Operation on page 25 and familiarize yourself with the information in that chapter.

This feature is available only in N5182A Agilent MXG Vector Signal Generators with Option 430. 
Option 430 requires Option 651, 652, or 654.

Creating a Custom Two-Tone Waveform
Using the Two-Tone menu, you can define, and modify user- defined Two- Tone waveforms. Two- Tone 
waveforms are generated by the dual arbitrary waveform generator.

The section Using Two- Tone Modulation on page 200 teaches you how to perform the following tasks:

• Creating a Two- Tone Waveform on page 201

• Viewing a Two- Tone Waveform on page 202

• Minimizing Carrier Feedthrough on page 203

• Changing the Alignment of a Two- Tone Waveform on page 204

Creating a Custom Multitone Waveform
Using the Multitone Setup table editor, you can define, modify and store user- defined multitone 
waveforms. Multitone waveforms are generated by the dual arbitrary waveform generator.

The Using Multitone Modulation on page 206 teaches you how to perform the following tasks:

• Initializing the Multitone Setup Table Editor on page 206

• Configuring Tone Powers and Tone Phases on page 207

• Removing a Tone on page 207

• Generating the Waveform on page 207

• Configuring the RF Output on page 208
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Using Two-Tone Modulation
Using Two-Tone Modulation
In the following sections, this chapter describes the two- tone mode, which is available only in 
N5182A Agilent MXG Vector signal generators with Option 430:

• Creating a Two- Tone Waveform on page 201

• Viewing a Two- Tone Waveform on page 202

• Minimizing Carrier Feedthrough on page 203

• Changing the Alignment of a Two- Tone Waveform on page 204

See also: Saving a Waveform’s Settings & Parameters on page 91

NOTE For more information about two- tone waveform characteristics, and the two- tone standard, 
download Application Note 1410 from our website by going to http://www.agilent.com and 
searching for “AN 1410” in Test & Measurement. 
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Two Tone Modulation Softkeys

Creating a Two-Tone Waveform

This procedure describes how to create a basic, centered, two- tone waveform.

1. Preset the signal generator.

2. Set the signal generator RF output frequency to 6 GHz.

3. Set the signal generator RF output amplitude to −10 dBm.

4. Press Mode > Two-Tone > Freq Separation > 10 > MHz.

5. Press Two Tone Off On to On.

6. Turn on the RF output.

The two- tone signal is now available at the signal generator RF OUTPUT connector. Figure 12- 1 on 
page 202 shows what the signal generator display should look like after all steps have been 
completed. Notice that the T-TONE, I/Q, annunciators are displayed; the RF ON, MOD ON LEDs are on; 
and the parameter settings for the signal are shown in the status area of the signal generator display.

Becomes active when a change is made to 
the Freq Separation or Alignment Softkeys 
are changed. Becomes active when Two Tone is 

turned On.

Active when 
Two-Tone enabled.

page 164

For softkey usage,
see page 83

For details on each key, use key help as described on page 26.

page 206

page 170

see page 83
(Two-Tone’s Arb Setup is similar to the Dual Arb Setup.) 

Exceptions: 
> No Waveform Runtime Scaling softkey, 
> No Multi-BBG Sync Setup softkey, and 
> No DAC Over-Range Protection softkey
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Using Two-Tone Modulation
Figure 12-1

Viewing a Two-Tone Waveform

This procedure describes how to configure the spectrum analyzer to view a two- tone waveform and 
its IMD products. Actual key presses will vary, depending on the model of spectrum analyzer you are 
using.

1. Preset the spectrum analyzer.

2. Set the carrier frequency to 6 GHz.

3. Set the frequency span to 60 MHz.

4. Set the amplitude for a 10 dB scale with a −10 dBm reference. 

5. Adjust the resolution bandwidth to sufficiently reduce the noise floor to expose the IMD products. 
A 9.1 kHz setting was used in our example.

6. Turn on the peak detector.

7. Set the attenuation to 4 dB, so you’re not overdriving the input mixer on the spectrum analyzer. 

You should now see a two- tone waveform with a 6 GHz center carrier frequency that is similar to the 
one shown in Figure 12- 2 on page 203. You will also see IMD products at 10 MHz intervals above and 
below the generated tones, and a carrier feedthrough spike at the center frequency with carrier 
feedthrough distortion products at 10 MHz intervals above and below the center carrier frequency.

Mode > Two-Tone

For details on 
each key, use 
key help as 
described on 
page 26.
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Figure 12-2

Minimizing Carrier Feedthrough

This procedure describes how to minimize carrier feedthrough and measure the difference in power 
between the tones and their intermodulation distortion products. Before beginning this procedure, it 
is important that a recent I/Q calibration has been performed on the instrument. The procedure for 
performing an I/Q calibration (refer to “I/Q Calibration” on page 143).

This procedure builds upon the previous procedure.

1. On the spectrum analyzer, set the resolution bandwidth for a sweep rate of about 
100- 200 ms. This will allow you to dynamically view the carrier feedthrough spike as you make 
adjustments.

2. On the signal generator, press I/Q > I/Q Adjustments > I/Q Adjustments Off On to On.

3. Press Internal Baseband Adjustments > I Offset and turn the rotary knob while observing the carrier 
feedthrough with the spectrum analyzer. Changing the I offset in the proper direction will reduce 
the feedthrough level. Adjust the level as low as possible.

4. Press Q Offset and turn the rotary knob to further reduce the carrier feedthrough level.

5. Repeat steps 3 and 4 until you have reached the lowest possible carrier feedthrough level.

6. On the spectrum analyzer, return the resolution bandwidth to its previous setting.

7. Turn on waveform averaging.

 

Intermodulation
Distortion

Two-Tone
Channels

Carrier Feedthrough
Distortion

Carrier
Feedthrough

For details on each key, use key help as described on page 26.
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8. Create a marker and place it on the peak of one of the two tones.

9. Create a delta marker and place it on the peak of the adjacent intermodulation product, which 
should be spaced 10 MHz from the marked tone.

10. Measure the power difference between the tone and its distortion product. 

You should now see a display that is similar to the one shown in Figure 12- 3 on page 204. Your 
optimized two- tone signal can now be used to measure the IMD products generated by a 
device- under- test. 

Note that carrier feedthrough changes with time and temperature. Therefore, you will need to 
periodically readjust your I and Q offsets to keep your signal optimized.

Figure 12-3

Changing the Alignment of a Two-Tone Waveform

This procedure describes how to align a two- tone waveform left or right, relative to the center carrier 
frequency. Because the frequency of one of the tones is the same as the carrier frequency, this 
alignment typically hides any carrier feedthrough. However, image frequency interference caused by 
left or right alignment may cause minor distortion of the two- tone signal. This procedure builds upon 
the previous procedure.

1. On the signal generator, press Mode > Two Tone > Alignment Left Cent Right to Left.
2. Press Apply Settings to regenerate the waveform.

 

Main Marker

Delta Marker

Minimized
Carrier
Feedthrough

For details on each 
key, use key help as 
described on page 26.
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NOTE Whenever a change is made to a setting while the two- tone generator is operating 
(Two Tone Off On set to On), you must apply the change by pressing the Apply Settings softkey 
before the updated waveform will be generated. When you apply a change, the baseband 
generator creates a two- tone waveform using the new settings and replaces the existing 
waveform in ARB memory.

3. On the spectrum analyzer, temporarily turn off waveform averaging to refresh your view more 
quickly. You should now see a left- aligned two- tone waveform that is similar to the one shown in 
Figure 12- 4.

Figure 12-4

Carrier
Frequency

Upper Tone
Aligned with

Intermodulation
Distortion

Two-Tone
Channels

Carrier
Frequency

For details on each key, use key help as described on page 26.
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Using Multitone Modulation

Multitone Modulation Softkeys

Initializing the Multitone Setup Table Editor
1. Press Preset.

2. Press Mode > Multitone

3. Press Initialize Table > Number of Tones > 5 > Enter.

4. Press Freq Spacing > 20 > kHz.

page 207

page 206

This softkey is active if changes have been 
made to the current Multitone waveform in 
the table editor. The softkey must be 
pressed to apply those changes.

page 208

page 208

Active when 
Multitone enabled.

For softkey usage,
see page 82

page 82

see page 83
(Multitone’s ARB Setup is similar to Dual Arb Setup.) 

Exceptions: 
> No Waveform Runtime Scaling softkey, 
> No Multi-BBG Sync Setup softkey, and 
> No DAC Over-Range Protection softkey

For details on each key, use key help as 
described on page 26.
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Multitone and Two-Tone Waveform Generator (Option 430)
Using Multitone Modulation
Figure 12-5

5. Press Done.

You now have a multitone setup with five tones spaced 20 kHz apart. The center tone is placed at 
the carrier frequency, while the other four tones are spaced in 20 kHz increments from the center 
tone.

Configuring Tone Powers and Tone Phases
1. Highlight the value (0 dB) in the Power column for the tone in row 2.

2. Press Edit Table > Edit Item > -4.5 > dB.

3. Highlight the value (0) in the Phase column for the tone in row 2.

4. Press Edit Item > 123 > deg.

Removing a Tone
1. Highlight the value (On) in the State column for the tone in row 4.

2. Press Toggle State.

Generating the Waveform

Press Return > Multitone Off On until On is highlighted.

This generates the multitone waveform with the parameters defined in the previous sections. During 
waveform generation, the M-TONE and I/Q annunciators activate and the multitone waveform is 
stored in volatile ARB memory. The waveform is now modulating the RF carrier.

The Random Seed 
softkey--that affects the 
Multitone’s phase 
values--is not used in the 
following examples and is 
shown for reference, only.

For details on each key, use key help as described on page 26.
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Configuring the RF Output
1. Set the RF output frequency to 100 MHz.

2. Set the output amplitude to 0 dBm. 

3. Press RF On/Off.

The multitone waveform is now available at the signal generator’s RF OUTPUT connector.

Applying Changes to an Active Multitone Signal

If the multitone generator is currently in use (Multitone Off On set to On) while changes are made in 
the Multitone Setup table editor, you must apply the changes before the updated waveform will be 
generated.

From the Multitone Setup table editor, press the following key to apply the changes and generate a 
multitone waveform based on the updated values: Apply Multitone

Storing a Multitone Waveform

In this example, you learn how to store a multitone waveform. If you have not created a multitone 
waveform, complete the steps in the previous section, Creating a Custom Multitone Waveform on page 
199.

1. Press Load/Store > Store To File.

If there is already a file name from the Catalog of MTONE Files occupying the active entry 
area, press the following keys (see page 27):

Edit Keys > Clear Text

2. Enter a file name (for example, 5TONE) using the alpha keys and the numeric keypad with a 
maximum length of 23 characters (see page 27).

3. Press Enter.

The multitone waveform is now stored in the Catalog of MTONE Files.

NOTE The RF output amplitude, frequency, and operating state settings are not stored as 
part of a multitone waveform file. Similarly, the multitone settings are not stored as 
part of the instrument state. Therefore, in most cases you should save both the 
instrument states and the multitone settings to be able to restore all of your settings 
later.
208 Agilent N5181A/82A MXG Signal Generators User’s Guide



Multitone and Two-Tone Waveform Generator (Option 430)
Using Multitone Modulation
Recalling a Multitone Waveform

Using this procedure, you learn how to recall a multitone waveform from the signal generator’s 
memory catalog.

If you have not created and stored a multitone waveform, complete the steps in the previous 
sections, Creating a Custom Multitone Waveform on page 199 and Storing a Multitone Waveform on 
page 208, then preset the signal generator to clear the stored multitone waveform from volatile ARB 
memory.

1. Press Mode > Multitone.

2. Press Load/Store.

3. Highlight the desired file (for example, 5TONE).

4. Press Load From Selected File > Confirm Load From File.

5. Press Multitone Off On until On is highlighted.

The firmware generates the multitone waveform in ARB memory. After waveform generation, the 
multitone waveform is available to be modulated on the RF output.

For instruction on configuring the RF output, see Configuring the RF Output on page 208.
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13 Working in a Secure Environment

• Understanding Memory Types on page 212

• Removing Data from Memory (Option 006 Only) on page 214

• Using the Secure Display (Option 006 Only) on page 217
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Understanding Memory Types
Understanding Memory Types
The signal generator has several memory types, and each is used to store a specific type of data. 
Before removing sensitive data, you should to understand how each memory type is used. The 
following tables describe each memory type used in the base instrument, and optional baseband 
generator.

Table 13-1 Base Instrument Memory 

Memory 
Type and 
Size
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Purpose/Contents Data Input Method Location in Instrument and Remarks

Main 
Memory 
(RAM)

32 MB

Yes No firmware operating memory

no user data

operating system CPU board, not battery backed.

Main 
Memory 
(Flash)

8 MB

Yes Yes factory 
calibration/configuration data

auser file system, which 
includes flatness calibration, 
instrument states, and sweep 
lists

firmware upgrades 
and user- saved 
dataa

CPU board (same chip as firmware memory, 
but managed separately)

Because this memory chip contains 8 MB of 
user data (described here) and 8 MB of 
firmware memory, a full- chip erase is not 
desirable. User data areas are selectively and 
completely sanitized when you perform the 
Erase and Sanitize function.

Firmware 
Memory 
(Flash)

8 MB

No Yes main firmware image factory installed or 
firmware upgrade

CPU board (same chip as main flash memory, 
but managed separately)

During normal operation, this memory cannot 
be overwritten. It is only overwritten during 
the firmware installation or upgrade process.

Because this memory chip contains 8 MB of 
user data and 8 MB of firmware memory 
(described here), a full- chip erase is not 
desirable. User data areas are selectively and 
completely sanitized when you perform the 
Erase and Sanitize function.

Bootrom 
Memory 
(EEPROM)

8 kB

No Yes CPU bootup parameters

no user data

factory programmed CPU board

During normal operation, this memory cannot 
be overwritten or erased except for LAN 
configuration. This read- only data is 
programmed at the factory.

Yes Yes LAN configuration Front panel entry or 
remotely

Calibration 
Data
(Flash)

256 kB

No Yes factory 
calibration/configuration data 
backup

no user data

factory or service 
only

RF Board
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LCD 
Display 
Memory 
(RAM)

160 kB

No No display buffer operating system RF board, not battery backed.

Front Panel 
Memory 
(Flash)

32 kB

No No front panel keyboard 
controller firmware

no user data

operating system Front Panel board

aAnalog instruments only

Table 13-2 Baseband Generator Memory (Options 651,652, 654) 

Memory 
Type and 
Size
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Purpose/Contents Data Input Method Remarks

Waveform 
Memory 
(RAM)

≤ 320 MB

Yes No waveforms (including 
header and marker data)

normal user 
operation

Not battery backed.

Persistent 
Memory 
(Flash)

512 MB

Yes Yes all user data normal user 
operation

User data is completely sanitized when you 
perform the Erase and Sanitize function.

Calibration 
Data Memory 
(Flash)

128 kB

No Yes no user data factory or service 
only

Table 13-1 Base Instrument Memory  (Continued)

Memory 
Type and 
Size
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Purpose/Contents Data Input Method Location in Instrument and Remarks
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Removing Data from Memory (Option 006 Only)
Removing Data from Memory (Option 006 Only)
When moving the signal generator from a secure development environment, there are several security 
functions you can use to remove classified proprietary information from the instrument. Security 
functions also have equivalent SCPI commands for remote operation (“System Subsystem (:SYSTem)” 
commands; refer to the SCPI Command Reference)

CAUTION The signal generator has several memory types (described in Table 13- 1 on page 212, 
and Table 13- 2 on page 213), and each is used to store a specific type of data. Before 
removing sensitive data, understand how each memory type is used.

Erase All

Removes:  All user files, user flatness calibrations, user I/Q calibrations

Resets:   All table editors with original factory values, ensuring that user data and 
configurations are not accessible or viewable

Does Not:  Sanitize memory

Time to Erase:   typically < 1 minute, depending on the number of files.

To Start:  Press File > More > Security > Erase All > Confirm Erase

NOTE This is not File > Delete All Files, which deletes all user files but does not reset table editors.

page 215

Below

See 
Secure Mode on 
page 216

page 44

For details on each key, 
use key help as described on 
page 26.
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Erase and Overwrite All

This performs the same actions as Erase All, plus it clears and overwrites the various memory types 
in accordance with Department of Defense (DoD) standards, as follows:

CPU Flash  Overwrites all addressable locations with random characters and then erases the 
flash blocks. This accomplishes the same purpose as a chip erase. System files are 
restored after erase.

To Start:  Press File > More > Security > Erase and Overwrite All > Confirm Erase

Erase and Sanitize All

This performs the same actions as Erase and Overwrite All and then adds more overwriting actions. 
After executing this function, you must manually perform the additional steps described below for the 
sanitization to comply with Department of Defense (DoD) standards.

To Start:  Press File > More > Security > Erase and Sanitize All > Confirm Sanitize

Removing Persistent State Information Not Removed During Erase

Persistent State

The persistent state settings contain instrument setup information that can be toggled within 
predefined limits such as display intensity, contrast and the GPIB address. In vector models, the user 
IQ cal is also saved in this area.

The following key presses or SCPI commands can be used to clear the IQ cal file and to set the 
operating states that are not affected by a signal generator power- on, preset, or *RST command to 
their factory default:

Instrument Setup
• On the Agilent MXG front panel, press: Utility > Power On/Preset > Restore System Settings to Default 

Values > Confirm Restore Sys Settings to Default Values

• Or send this command to the Agilent MXG: :SYSTem:PRESet:PERSistent

LAN Setup

The LAN setup (hostname, IP address, subnet mask, and default gateway) information is not 
defaulted with a signal generator power- on or *RST command. This information can only be changed 
or cleared by entering new data.

CPU Flash Overwrites all addressable locations with random characters and then erases the 
flash blocks. This accomplishes the same purpose as a chip erase. System files 
are restored after erase.

BBG Persistent 
Memory (Flash)

(Vector instruments only) Overwrites all addressable locations with random 
characters and then erases the flash blocks. This accomplishes the same purpose 
as a chip erase. System files are restored after erase.
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User IQ Cal File (Vector Models Only)

When a user- defined IQ calibration has been performed, the cal file data is removed by setting the 
cal file to default, as follows:

• On the front panel, press: I/Q > I/Q Calibration > Revert to Default Cal Settings

• Or send this command to the Agilent MXG: :CAL:IQ:DEF

Secure Mode

CAUTION Once you activate secure mode (by pressing Confirm), you cannot deactivate or decrease 
the security level; the erasure actions for that security level execute at the next power 
cycle. Once you activate secure mode, you can only increase the security level until you 
cycle power. For example, you can change Erase to Overwrite, but not the reverse.

After the power cycle, the security level selection remains the same, but secure mode is 
not activated.

Secure mode automatically applies the selected Security Level action the next time the instrument’s 
power cycles. 

To Set the Level:  Press File > More > Security > Security Level and choose from the following:

— None = factory preset, no user information is lost
— Erase = Erase All
— Overwrite = Erase and Overwrite All
— Sanitize = Erase and Sanitize All

To Activate:  Press File > More > Security > Enter Secure Mode > Confirm

The softkey changes to Secure Mode Activated.

Securing a Nonfunctioning Instrument

If the instrument is not functioning and you are unable to use the security functions, you must 
physically remove the processor board and, for vector instruments, the A4 Memory Chip from the 
instrument. Once these assemblies are removed, choose one of the following options:

• Discard the board (or boards) and send the instrument to a repair facility. A new board (or 
boards) will be installed and the instrument will be repaired and calibrated. If the instrument is 
still under warranty, you will not be charged for new boards.

• If you have another working instrument, install the board (or boards) into that instrument and 
erase the memory. Then reinstall the board (or boards) back into the nonworking instrument and 
send it to a repair facility for repair and calibration. If you discover that one or both of the 
boards do not function in the working instrument, discard the nonfunctioning board and note on 
the repair order that it caused the instrument failure. If the instrument is still under warranty, 
you will not be charged for new boards.

For instructions on how to remove and replace boards, refer to the Service Guide.
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Using the Secure Display (Option 006 Only)
This function prevents unauthorized personnel from reading the instrument display and tampering 
with the current configuration through the front panel. The display blanks, except for the message 
shown in the following figure, and the front panel keys are disabled. 

To re- enable the display and front panel keys, cycle the power.

Figure 13-1 Secure Display Softkeys
For details on each key, use key help
as described on page 26.
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14 Troubleshooting

• Display on page 220

• Signal Generator Lock- Up on page 220

• RF Output on page 221

— No RF Output
— Power Supply Shuts Down
— No Modulation at the RF Output
— RF Output Power too Low
— Distortion
— Signal Loss While Working with a Spectrum Analyzer
— Signal Loss While Working with a Mixer on page 222

• Sweep on page 224

— Cannot Turn Off Sweep
— Sweep Appears Stalled
— Incorrect List Sweep Dwell Time
— List Sweep Information is Missing from a Recalled Register
— Amplitude Does Not Change in List or Step Sweep on page 224

• Internal Media Data Storage on page 225

— Instrument State Saved but the Register is Empty or Contains the Wrong State

• USB Media Data Storage on page 225

— Instrument Recognizes USB Media Connection, but Does Not Display Files

• Preset on page 225

— The Signal Generator Does Not Respond
— Pressing Preset Performs a User Preset

• Error Messages on page 226

• Front Panel Tests on page 227

• Self Test on page 227

• Licenses on page 228

• Contacting Agilent Technologies on page 229

— Returning a Signal Generator to Agilent
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Display
Display

The Display is Too Dark to Read

Both brightness and contrast may be set to minimum. Use the figure in “Display Settings” on page 18 
to locate the brightness and contrast softkeys and adjust their values so that you can see the display.

The Display Turns Black when Using USB Media

Removing the USB media when the instrument begins to use it can cause the screen to go black. 
Cycle instrument power.

Signal Generator Lock-Up
• Ensure that the signal generator is not in remote mode (the R annunciator shows on the display). 

To exit remote mode and unlock the front panel, press Local Cancel/(Esc).

• Ensure that the signal generator is not in local lockout, which prevents front panel operation. For 
information on local lockout, refer to the Programming Guide.

• If a progress bar appears on the signal generator display, an operation is in progress.

• Preset the signal generator.

• Cycle power on the signal generator.
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RF Output
RF Output

No RF Output
• Check the RF ON/OFF LED (shown on page 4). If it is off, press RF On/Off to turn the output on.

• Ensure that the amplitude is set within the signal generator’s range.

• If the instrument is playing a waveform, ensure that marker polarity and routing settings are 
correct (see “Saving Marker Polarity and Routing Settings” on page 97).

Power Supply Shuts Down

If the power supply does not work, it requires repair or replacement. If you are unable to service the 
instrument, send the signal generator to an Agilent service center for repair (see page 229).

No Modulation at the RF Output

Check both the Mod On/Off LED and the <modulation> Off On softkey, and ensure that both are on. 
See also, page 40.

For digital modulation on a vector signal generator, ensure that the internal I/Q modulator is on (the 
I/Q annunciator displays).

If using an external modulation source, ensure that the external source is on and that it is operating 
within the signal generator’s specified limits.

RF Output Power too Low
• If the AMPLITUDE area of the display shows the OFFS indicator, eliminate the offset:

Press Amptd > More 1 of 2 > Amptd Offset > 0 > dB. See also, “Setting an Output Offset” on page 61.

• If the AMPLITUDE area of the display shows the REF indicator, turn off the reference mode:

1. Press Amptd > More > Amptd Ref Off On until Off highlights.

2. Reset the output power to the desired level.

See also, “Setting an Output Reference” on page 62.

• If you are using the signal generator with an external mixer, see page 222.

• If you are using the signal generator with a spectrum analyzer, see page 222.

• If pulse modulation is on, turn off the ALC, and check that pulse width is within specifications.

Distortion

If you edit and resave a segment in a waveform sequence, the sequence does not automatically 
update the RMS value stored in it’s header. This can cause distortion on the output signal. Display 
the sequence header information and recalculate the RMS value (see page 91).
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RF Output
Signal Loss While Working with a Spectrum Analyzer

The effects of reverse power can cause problems with the RF output when you use the signal 
generator with a spectrum analyzer that does not have preselection. Use an unleveled operating mode 
(described on page 59).

A spectrum analyzer can have as much as +5 dBm LO feedthrough at its RF input port at some 
frequencies. If the frequency difference between the LO feedthrough and the RF carrier is less than 
the ALC bandwidth, the LO’s reverse power can amplitude modulate the signal generator’s RF output. 
The rate of the undesired AM equals the difference in frequency between the spectrum analyzer’s LO 
feedthrough and the signal generator’s RF carrier.

Reverse power problems can be solved by using one of the unleveled operating modes. 

See:

• “ALC Off Mode” on page 59

and

• “Power Search Mode” on page 60

Signal Loss While Working with a Mixer

To fix signal loss at the signal generator’s RF output during low- amplitude coupled operation with a 
mixer, add attenuation and increase the RF output amplitude.

The figure at right shows a 
configuration in which the 
signal generator provides a 
low amplitude signal to a 
mixer.

The internally leveled signal 
generator RF output (and ALC 
level) is −8 dBm. The mixer is 
driven with an LO of +10 dBm 
and has an LO- to- RF isolation 
of 15 dB. The resulting 
−5 dBm LO feedthrough 
enters the signal generator’s 
RF output connector and 
arrives at the internal 
detector.

Depending on frequency, it is 
possible for most of this LO 
feedthrough energy to enter the detector. Because the detector responds to its total input power 
regardless of frequency, this excess energy causes the ALC to reduce the RF output. In this example, 
the reverse power across the detector is actually greater than the ALC level, which can result in loss 
of signal at the RF output.

Mixer

LO 

ALC Level 
= −8 dBm

RF Level 
Control

Signal Generator
Output Control

Detector 
measures 
−8 dBm
ALC level

Detector 
measures 
−5 dBm
reverse 
power

LO Feedthru
= −5 dBm

RF Output
= −8 dBm

LO Level
= +10 dBm

IF 

Effects of Reverse Power on ALC
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RF Output
The solution at right shows a 
similar configuration with the 
addition of a 10 dB 
attenuator connected between 
the RF output of the signal 
generator and the input of 
the mixer. The signal 
generator’s ALC level 
increases to +2 dBm and 
transmits through a 10 dB 
attenuator to achieve the 
required −8 dBm amplitude 
at the mixer input. 

Compared to the original 
configuration, the ALC level 
is 10 dB higher while the 
attenuator reduces the LO 
feedthrough (and the signal 
generator’s RF output) by 10 
dB. Using the attenuated 
configuration, the detector is exposed to a +2 dBm desired signal versus the −15 dBm undesired LO 
feedthrough. This 17 dB difference between desired and undesired energy results in a maximum 
0.1 dB shift in the signal generator’s RF output level.

Mixer

LO 

ALC Level/ 
RF Output
= +2 dBm

RF Level 
Control

Signal Generator
Output Control

Detector 
measures 
+2 dBm
ALC level

Detector 
measures 
−15 dBm
reverse 
power

LO Feedthru
= −5 dBm

RF Output
= −8 dBm

LO Level
= +10 dBm

IF 

Reverse Power Solution

10 dB 
ATTEN
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Sweep
Sweep

Cannot Turn Off Sweep

Press Sweep > Sweep > Off.

Sweep Appears Stalled

The current status of the sweep is indicated as a shaded rectangle in the progress bar (see 
“Configuring a Swept Output” on page 31). If the sweep appears to stall, check the following:

1. Turn on the sweep with one of the following key sequences:

Sweep > Sweep > Freq
Sweep > Sweep > Amptd
Sweep > Sweep > Waveform (vector instruments only)

2. If the sweep is in single mode, press the Single Sweep softkey. 

3. If the sweep trigger (indicated by the Sweep Trigger softkey) is not set to Free Run, set it to Free 
Run to determine if a missing sweep trigger is blocking the sweep.

4. If the point trigger (indicated by the Point Trigger softkey) is not set to Free Run, set it to Free 
Run to determine if a missing point trigger is blocking the sweep.

5. Set the dwell time to one second to determine if the dwell time was set to a value that was too 
slow or too fast to see.

6. Ensure that you set at least two points in the step sweep or list sweep.

Incorrect List Sweep Dwell Time
1. Press Sweep > More > Configure List Sweep.

2. Check that the list sweep dwell values are accurate.

3. If the dwell values are incorrect, edit them.
If the dwell values are correct, continue to the next step.

4. Press More, and ensure that the Dwell Type List Step softkey is set to List.

If Step is selected, the signal generator sweeps the list points using the dwell time set for step 
sweep rather than list sweep.

See also, “Configuring a Swept Output” on page 31.

List Sweep Information is Missing from a Recalled Register

List sweep information is not stored as part of the instrument state in an instrument state register. 
Only the current list sweep is available to the signal generator. You can store list sweep data in the 
instrument catalog (see “Loading (Recalling) a Stored File” on page 46).

Amplitude Does Not Change in List or Step Sweep

Verify that sweep type is set to amplitude (Amptd); the amplitude does not change when the sweep 
type is set to frequency (Freq) or waveform.
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Internal Media Data Storage
Internal Media Data Storage

Instrument State Saved but the Register is Empty or Contains the Wrong State

If the register number you intended to use is empty or contains the wrong instrument state, recall 
register 99. If you selected a register number greater than 99, the signal generator automatically saves 
the instrument state in register 99.

See also, “Working with Instrument State Files” on page 48.

USB Media Data Storage

Instrument Recognizes USB Media Connection, but Does Not Display Files

If the USB media works on other instruments or computers, it may simply be incompatible with the 
signal generator; try a different USB media. Refer to http://www.agilent.com/find/mxg for details on 
compatible USB media.

Preset

The Signal Generator Does Not Respond

If the signal generator does not respond to a preset, the instrument may be in remote mode, which 
locks the keypad. 

To exit remote mode and unlock the preset keys, press Local Cancel/(Esc).

Pressing Preset Performs a User Preset

This behavior results from the use of a backward- compatible SCPI command. To return the signal 
generator to normal use, send the command :SYST:PRESet:TYPE NORM. 

For information on SCPI commands, refer to the SCPI Command Reference.
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Error Messages
Error Messages

Error Message Types

Events do not generate more than one type of error. For example, an event that generates a query 
error does not generate a device- specific, execution, or command error.

Query Errors (–499 to –400) indicate that the instrument’s output queue control has detected a 
problem with the message exchange protocol described in IEEE 488.2, Chapter 6. Errors in this class 
set the query error bit (bit 2) in the event status register (IEEE 488.2, section 11.5.1). These errors 
correspond to message exchange protocol errors described in IEEE 488.2, 6.5. In this case:

• Either an attempt is being made to read data from the output queue when no output is either 
present or pending, or

• data in the output queue has been lost.

Device Specific Errors (–399 to –300, 201 to 703, and 800 to 810) indicate that a device operation 
did not properly complete, possibly due to an abnormal hardware or firmware condition. These codes 
are also used for self- test response errors. Errors in this class set the device- specific error bit (bit 3) 
in the event status register (IEEE 488.2, section 11.5.1).

The <error_message> string for a positive error is not defined by SCPI. A positive error indicates that 
the instrument detected an error within the GPIB system, within the instrument’s firmware or 
hardware, during the transfer of block data, or during calibration.

Execution Errors (–299 to –200) indicate that an error has been detected by the instrument’s 
execution control block. Errors in this class set the execution error bit (bit 4) in the event status 
register (IEEE 488.2, section 11.5.1). In this case:

• Either a <PROGRAM DATA> element following a header was evaluated by the device as outside of 
its legal input range or is otherwise inconsistent with the device’s capabilities, or

• a valid program message could not be properly executed due to some device condition.

Execution errors are reported after rounding and expression evaluation operations are completed. 
Rounding a numeric data element, for example, is not reported as an execution error.

Command Errors (–199 to –100) indicate that the instrument’s parser detected an IEEE 488.2 
syntax error. Errors in this class set the command error bit (bit 5) in the event status register (IEEE 
488.2, section 11.5.1). In this case:

• Either an IEEE 488.2 syntax error has been detected by the parser (a control- to- device message 
was received that is in violation of the IEEE 488.2 standard. Possible violations include a data 
element that violates device listening formats or whose type is unacceptable to the device.), or

• an unrecognized header was received. These include incorrect device- specific headers and 
incorrect or unimplemented IEEE 488.2 common commands.

Error Message File

A complete list of error messages is provided on the CDROM supplied with the instrument. In the 
error message file, an explanation is generally included with each error to further clarify its meaning. 
The error messages are listed numerically. In cases where there are multiple listings for the same 
error number, the messages are in alphabetical order. 
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Troubleshooting
Front Panel Tests
Front Panel Tests

Self Test
The self test is a series of internal tests that checks different signal generator functions.

Set all display pixels to the selected color. 
To return to normal operation, press any key.

Blink RF On/Off, Mod on/Off, and More LEDs

Correct operation:
Full CCW = −10
Full CW = 10

Displays a keyboard map. 
As you press a key, the map indicates the key location.

For details on each key, use key help
as described on page 26.

It takes about 5 minutes to run the self test.

If a failure occurs:
1. Ensure that all external cables, including GPIB, LAN, and 

USB cables, are disconnected from the signal generator and 
perform the self-test again.

2. If the self-test continues to fail, the signal generator requires 
service. If you are unable to service the instrument, send the 
signal generator to an Agilent service center for repair, with 
a detailed description of the failed test(s) and any other error 
messages that appeared on the display.

Refer to “Contacting Agilent Technologies” on page 229.

Displays the details of the 
currently selected test.
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Troubleshooting
Licenses
Licenses

A Time-Based License Quits Working
• The instrument’s time or date may have been reset forward causing the time- based license to 

expire.

• The instrument’s time or date may have been reset backward more than approximately 25 hours, 
causing the instrument to ignore time- based licenses.

See page 20 for details and cautions on setting time and date.

Cannot Load a Time-Based License

The instrument’s time or date may have been reset backward more than approximately 25 hours, 
causing the instrument to ignore time- based licenses.

See page 20 for details and cautions on setting time and date.
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Troubleshooting
Contacting Agilent Technologies
Contacting Agilent Technologies
• assistance with test and measurements needs, and information on finding a local Agilent office:

http://www.agilent.com/find/assist

• accessories or documentation: http://www.agilent.com/find/mxg

• new firmware releases: http://www.agilent.com/find/upgradeassistant.

If you do not have access to the Internet, please contact your field engineer.

NOTE In any correspondence or telephone conversation, refer to the signal generator by its model 
number and full serial number. With this information, the Agilent representative can 
determine whether your unit is still within its warranty period.

Returning a Signal Generator to Agilent

Use the following steps to return a signal generator to Agilent Technologies for servicing:

1. Gather as much information as possible regarding the signal generator’s problem. 

2. Call the phone number listed on the Internet (http://www.agilent.com/find/assist) that is specific 
to your geographic location. If you do not have access to the Internet, contact your Agilent field 
engineer. 

After sharing information regarding the signal generator and its condition, you will receive 
information regarding where to ship your signal generator for repair.

3. Ship the signal generator in the original factory packaging materials, if available, or use similar 
packaging to properly protect the signal generator.
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Glossary

A

Active Entry The currently selected, and 
therefore editable, entry or parameter

ARB Arbitrary waveform generator

AWG Arbitrary waveform generator. Additive 
white Gaussian noise

B

BBG Media Baseband generator media. Volatile 
memory, where waveform files are played or 
edited.

BNC Connector Bayonet Neill- Concelman 
connector. A type of RF connector used to 
terminate coaxial cable. 

C

CCW Counterclockwise

C/N Carrier- to- noise ratio

CW Continuous wave. Clockwise

D

DHCP Dynamic host communication protocol

Dwell Time In a step sweep (see page 32), the 
time that the signal is settled and you can make 
a measurement before the sweep moves to the 
next point.

E

EVM Error vector magnitude; the magnitude of 
the vector difference at a given instant between 
the ideal reference signal and the measured 
signal.
Agilent N5181A/82A MXG Signal Generators User’s Guide
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Filter factor Alpha The filter’s alpha coefficient. 
It is only valid for root nyquist and nyquist 
filters.

Filter Factor BbT The filter’s 
bandwidth- bit- time (BbT). It is only valid for a 
Gaussian filter (similar to alpha). BbT is defined 
by the GSM standard as 0.3 and by the DECT 
standard as 0.5.

G

Gaussian filter The Gaussian filter does not 
have a zero Inter- Symbol Interference (ISI). 
Wireless system architects must decide just how 
much of the ISI can be tolerated in a system and 
combine that with noise and interference. The 
Gaussian filter is gaussian shaped in both the 
time and frequency domains, and it does not 
ring like the root nyquist filters do. The effects 
of this filter in the time domain are relatively 
short and each symbol interacts significantly (or 
causes ISI) with only the preceding and 
succeeding symbols. This reduces the tendency 
for particular sequences of symbols to interact, 
which makes amplifiers easier to build and more 
efficient.

GPIB General purpose interface bus. An 8- bit 
parallel bus common on test equipment.

H

Hardkey A labeled button on the instrument.

I

IF Intermediate frequency

Int Media Internal media. Non−volatile signal 
generator memory, where waveform files are 
stored.

IP Internet protocol. The network layer for the 
TCP/IP protocol suite widely used on Ethernet 
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networks.

L

LAN Local area network

LO Local oscillator

LXI LAN extension for instrumentation. An 
instrumentation platform based on industry 
standard Ethernet technology designed to 
provide modularity, flexibility, and performance 
to small-  and medium- sized systems. See also, 
http://www.lxistandard.org

M

Modulation Format Custom modulation, Two 
Tone, or Multitone.

Modulation Mode Dual ARB, Custom 
modulation, Two Tone, or Multitone.

Modulation Standard Refers to a Cellular 
standard format (i.e. NADC, PDC, PHS, etc.).

Modulation Type Refers to the various I/Q 
constellation types (i.e. PSK, MSK, FSK, C4FM, 
etc.)

N

Non−volatile That which survives a power cycle 
(such as files stored in USB media).

Nyquist filter Also referred to as a cosine filter. 
These filters have the property that their 
impulse response rings at the symbol rate. 
Adjacent symbols do not interfere with each 
other at the symbol times because the response 
equals zero at all symbol times except the center 
(desired) one.

P

Persistent That which is unaffected by preset, 
user preset, or power cycle.
232
Point- to- point Time In a step sweep (page 32), 
the sum of the dwell time, processing time, 
switching time, and settling time.

R

Rectangular filter Also referred to as a ideal 
low pass filter. These filters have very steep 
cut- off characteristics. The pass band is set to 
equal the symbol rate of the signal. Due to a 
finite number of coefficients, the filter has a 
predefined length and is not truly “ideal”. The 
resulting ripple in the cut- off band is effectively 
minimized with a Hamming window. This filter 
is recommended for achieving optimal ACP. A 
symbol length of 32 or greater is recommended 
for this filter.

Root Nyquist filter Also referred to as a Root 
cosine filter. These filters have the property that 
their impulse response rings at the symbol rate. 
Adjacent symbols do not interfere with each 
other at the symbol times because the response 
equals zero at all symbol times except the center 
(desired) one. Root nyquist filters heavily filter 
the signal without blurring the symbols together 
at the symbol times. This is important for 
transmitting information without errors caused 
by ISI. Note that ISI does exist at all times 
except the symbol (decision) times. A cascade of 
two of these filters has the transfer function of 
a Nyquist filter. One is in the transmitter, the 
other in the receiver, so that the system taken 
as a whole has the zero- ISI properties of an ISI 
filter.

RMS Root mean square. A time- varying signal’s 
effective value (the equivalent DC voltage 
required to generate the equivalent heat across 
a given resistor). For a sinewave, RMS = 0.707 x 
peak value. 

S

Softkey A button located along the instrument’s 
display that performs whatever function is 
shown next to it on that display.

T
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TCP Transmission control protocol. The most 
common transport layer protocol used on 
Ethernet and the Internet.

Terminator A unit indicator (such as Hz or 
dBm) that completes an entry. For example, for 
the entry 100 Hz, Hz is the terminator.

Type- N Connector Threaded RF connector used 
to join coaxial cables.

U

USB Universal serial bus. See also, 
http://www.usb.org

User FIR Selects a user- defined set of 
coefficient values. Each line in the FIR values 
table contains one coefficient value. The number 
of coefficient values listed must be a multiple of 
the selected oversampling ratio. Each coefficient 
applies to both I and Q components.

V

Volatile That which does not survive a power 
cycle (such as files stored in BBG media).
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Symbols
# points softkey, 32
# Skipped Points softkey, 101
ΦM

annunciator, 9
dc offset, removing, 69
hardkey, 67
softkeys, 67, 69

Numerics
10 MHz OUT connector, 13
100Base- T LAN cable, 22
1410, application note, 200
430, option

multitone mode, 206
two- tone, 200
two- tone mode, 200

5- Pack
history, waveform files, 157
licensing, 150
licensing, installing, 151
licensing, understanding, 150
licensing, waveform file, 151
status messages, 153
warning messages, 161

628, error, 135
651/652/654, option

description, 3
multitone mode, 206
two- tone mode, 200

670/671/672, option
description, 3

8557D GPIB only softkey, 23
8648A/B/C/D GPIB only softkey, 23
8656B,8657A/B GPIB only softkey, 23

A
AC power receptacle, 11
ACP, 176
Activate Secure Display softkey, 18
active

entry, 231
entry area, 8

Active High softkey, 113
Active Low softkey, 113
Add Comment To softkey, 48
additive white Gaussian noise. See AWGN
address, GPIB, 21
Adjust Phase softkey, 29
Adjustable doublet softkey, 72
adjustments

I/Q, 78, 141
quadrature, 141
real- time phase noise, 173

advance, segment, 115

Advanced Settings softkey, 22
Aeroflex softkey, 23
Agilent MXG

modes of operation, 3
Agilent sales and service offices, 229
ALC

hold, 97, 98
OFF annunciator, 9
off mode, 59
softkeys, 29, 101

All softkey, 43
Alpha, 231
AM

annunciator, 9
connector, 12
external source, 69
hardkey, 67
softkeys, 67

amplitude
display area, 10
hardkey, 29
modulation, 67
offset, 61
reference, 62
setting, 29
softkeys, 29–34
troubleshooting sweep, 224

AMPTD hardkey, 29
Amptd softkeys, 29–34
analog modulation, 3, 67
angle, quadrature, 78
annunciators, 9
APCO 25 w/C4FM softkey, 178
APCO 25 w/CQPSK softkey, 178
apodization settings, FIR filter, 195
application notes

1410, 200
Apply To Waveform softkey, 101
ARB

definition, 231
player, dual, 82
softkeys, 82, 111, 165, 170
waveform clipping, 119

arb, 176
Arb Segment softkey, 47
Arb Sequence softkey, 47
ARMED annunciator, 9
arrow keys, 27
ATTEN HOLD annunciator, 9
Atten/ALC Control softkey, 29
Auto softkeys

(DHCP/Auto- IP), 22
Auto, 59
Recall, 66

AUTOGEN_WAVEFORM file, 176
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auto- IP, 22
Auto- IP softkey, 22
Automatically Use USB Media If Present softkey, 43
AUX I/O connector, 15
Auxiliary Software Options softkey, 24
AWGN

adding, 163
annunciator, 9
definition, 231
dual ARB player, 164
softkeys, 167

AWGN softkeys, 165

B
backspace hardkey, 27
Bandwidth softkey, 167
baseband, 15

aligning signals at, 97
clipping, 119
frequency offset

softkey location, 135
frequency offset, setting, 135
I/Q output connectors, 14
memory, 82, 212
noise, 163
noise annunciator, 9
quadrature adjustment, 141
real time I/Q AWGN, 165, 167
softkey, 135
summing signals, 140
waveforms convert to analog, 130

baseband frequency offset
DAC over range & scaling, 136
softkey, 135

baseband generator, 176
custom arb mode, 3
dual arb mode, 3
multiple BBG synchronization, 144
multitone mode, 3, 206
two- tone mode, 200

BB GEN, 140
BBG

media, 82, 84
media (definition), 231
Memory softkey, 47
Memory to USB softkey, 47
routing, 140
Segments softkey, 43, 91

BBG sync, 144
configure setup, 147
equipment setup, 147
resynchronization, 149
system, 146
system delay, 146

trigger setup, 146
BbT, 231
Binary softkey, 43
Bk Sp hardkey, 27
Bluetooth softkey, 178
BNC, 231
bootrom memory, 212
Bright Color softkey, 18
brightness adjustment, 18
Brightness softkey, 18
Buffered Trig softkey, 113
Build New Waveform Sequence softkey, 87, 109
Burst Envelope softkey, 138
Bus softkey, 31

C
C/N, 231
cables

crossover, 22
multi- BBG sync, 146

cables, 100Base- T LAN, 22
Calculate softkey, 91
calibration

data, 212
data memory, 213
I/Q, 143
softkey, 143

Calibration Type softkey, 143
Cancel hardkey, 5
carrier

bandwidth, 164
configuring, 29
feedthrough, 78
modulating, 40
softkeys, 165
to noise ratio, 164

Carrier Bandwidth softkey, 165
carrier feedthrough, minimizing, 203
Carrier to Noise softkey, 165
Catalog Type softkey, 43, 44, 47, 91
catalog, state files, 51
ccw, 231
CDPD softkey, 178
Channel Band softkey, 29
Channel Number softkey, 29
circular clipping, 123, 126
classified. See security
Clear softkeys

Error Queue(s), 53
Header, 91
Text, 27

clipping
circular, 123, 126
rectangular, 124, 127
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softkeys, 119

clock, sample rate, 15
coefficient values, entering, 191
color palette, display, 18
comments, adding & editing (instrument state), 49
component test, 176
Config Type softkey, 22
Configure softkeys

Cal Array, 56
List Sweep, 31, 34
Step Array, 56
Step Sweep, 31, 32

Confirm Load From File softkey, 46
Connection Monitoring softkey, 22
connectors

external triggering source, 116, 118
front panel, 4
rear panel, 11
routing signals, 39

Continuous softkey, 113
continuous step sweep example, 37
continuous wave

description, 3
continuous wave output, 29
contrast adjustment, 18
Contrast softkey, 18
Copy & softkeys

Play Sequence, 46
Play Waveform, 46
Select User Flatness, 46
Select User Flatness Corrections, 46

Copy softkeys
All Files, 47
File, 43
File to Instrument, 43, 47
File to USB, 47

correction array (user flatness), 57
See also user flatness correction

cosine filter. See nyquist filter
Create Directory softkey, 43, 47
crossover cable, 22
custom

multicarrier TDMA waveforms
creating, 187

TDMA digital modulation, 181
Custom ARB softkeys, 177
custom arb waveform generator, 3
custom mode, 176
cw, 231
CW (no modulation) softkey, 34
CW mode

description, 3

D
D01, 150

DAC over range error, 130, 135
DAC over range protection

baseband frequency offset, 136
phase noise, 174

Dark Color softkey, 18
data

calibration, 212
entry softkeys, 27
erasing, 214
files, 41–48
removing, 214
serial, synchronizing, 15
storage

comments, adding and editing, 49
troubleshooting, 225
type, 52
using, 41

date, setting, 20
dc offset, 78
dc offset, removing, 69
DCFMΦ/DCfM Cal softkey, 67
DECT softkey, 178
Default Gateway softkey, 22
default settings

restoring, 19, 22, 143
system, restoring, 26

Default softkey, 178
delay

I/Q, 141
multiple BBG sync, 146

Delete softkeys
All Regs in Seq, 48
All Segments On Int Media, 84
All Segments On USB Media, 84
All Sequence Files, 43
All Sequences, 48, 66
All Waveforms, 87
All Waveforms softkey, 109
File, 43
File or Directory, 43, 44, 47, 52
Item, 34
Row, 34
Selected Waveform, 87, 109
Seq Reg, 48
Waveform Sequence, 109

description & plots, phase noise, 171
DETHTR annunciator, 9
Device softkey, 29
DHCP, 22, 231
DHCP softkey, 22
Diff Mode softkeys, 141
DIGBUS annunciator, 9
digital bus, 15
digital modulation

formats, 3
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multitone, 206–209
TDMA, 181
two tone, 200–205

digital operation, 81, 150
digital signal to analog waveform, 130
display

blanking, 217
error message area, 10
memory, 212
overview, 4, 8
secure, 217
settings, 18
softkey labels, 10
softkeys, 17, 27, 101
tests, 227
text area, 10
troubleshooting, 220

Display softkeys
Case, 27
display, 17
Waveform And Markers, 101

Displayed Case softkeys, 27
distortion, troubleshooting, 221
DNS Server Override softkey, 22
DNS Server softkey, 22
documentation, xi
Domain Name softkey, 22
doublet

adjustable, 74
softkeys, 72
trigger, 74

dual ARB
multi- BBG sync, 144
player, 82
real- time noise, 164
softkeys, 83, 165, 170

dual arb, 176
dual ARB player, 3
dual arbitrary waveform generator, 3
dwell time, 34, 231
Dwell Type softkey, 34
dwell, troubleshooting, 224
Dynamic DNS Naming softkey, 22
Dynamic Hostname Services softkey, 22

E
E4428C, E4438C softkey, 23
E442xB, E443xB softkey, 23
E8241A, E8244A, E8251A, E8254A softkey, 23
E8247C, E8257C, E8267C softkey, 23
E8257D, E8267D softkey, 23
EDGE softkey, 178
Edit softkeys

Description, 91

Noise RMS Override, 91
Repetitions, 109
RMS, 91
Selected Waveform Sequence, 87, 109

Editing Keys softkey, 27
Editing Mode softkey, 27
EEPROM, 212
Enable/Disable Markers softkey, 87, 109
Enter Directory softkey, 46
entry, active, 231
equipment setup, 147
ERR annunciator, 9
Error hardkey, 53
error messages, 53

DAC over range, 130, 135
display area, 10
file, 226
message format, 53
types, 226

Esc hardkey, 5
EVENT

connector, AUX I/O, 15
connector, BNC, 14, 96
output jitter, 111
outputs, 96

EVM, 231
EVM error, 78
example

5- Pack License, adding, 154
5- Pack License, history, 159
Waveform 5- Pack License, adding, 154
Waveform 5- Pack License, history, 159

examples
FIR filters

creating, 190
modifying, 194

Execute Cal softkey, 143
EXT CLOCK connector, 14
EXT REF annunciator, 9
Ext softkeys

Delay, 114
Delay Time, 114
Ext, 31
I/Q Output, 138, 139
Pulse, 72
Source, 114

extension, file, 46
external

I and Q signals, 140
media, 52, 225
modulation source, 69
reference oscillator, using, 30
trigger source, 116, 118
triggering, 118

External softkeys
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External, 138
Input, 141
Input I Offset, 78
Input Q Offset, 78
Output, 141

F
factory defaults, restoring, 19, 22, 143
features, 2
feedthrough, 78
feedthrough, carrier, minimizing, 203
File hardkey, 43, 51
file headers

creating, 91
editing, 93
example, 93
viewing a different file, 95

files
catalog. See data storage
extensions, 46
working with, 41

filter, interpolator, 130
filters

gaussian, loading default, 195
nyquist, selecting, 184

FIR filter
apodization settings, 195
Hamming, 195
Hann, 195
Kaiser, 195
window settings, 195

FIR filters
creating, 190
modifying, 194
storing, 193

FIR table editor
accessing, 190
coefficients, duplicating, 192
coefficients, entering values, 191
coefficients, modifying, 196
files, loading, 195
filters

creating, 190
modifying, 194
storing, 193, 197

oversample ratio, setting, 192
firmware

memory, 212
upgrading, 20, 229

First Mkr Point softkey, 101
First Sample Point softkey, 101
Fixed softkey, 59
flash memory, 212
flatness correction. See user flatness correction
Flatness softkey, 56

FM
annunciator, 9
connector, 12
dc offset, removing, 69
external source, 69
hardkey, 67
softkeys, 67

Free Run softkey, 31, 64, 113
Free- Run softkey, 72
FREQ hardkey, 29
Freq softkeys, 29–34, 56
frequency

display area, 8
hardkey, 6, 7, 29
modulation, 67
multiplier, 63
offset, 61
offset, baseband, 135
offset, softkeys, 135
reference, 62
setting, 29
softkeys, 29, 29–34

front panel
disabling keys, 217
display, 8
I/Q inputs, using, 79
knob resolution, 19
overview, 4
tests, 227

FTP Server softkey, 22
fundamental operation See basic operation

G
Gated softkey, 72, 113
gated triggering, 113, 116
Gaussian

definition, 231
gaussian filter, loading default, 195
Gaussian. See AWGN
glossary, 231
Go To Default Path softkey, 43, 44, 52
Goto Row softkey, 34, 43
GPIB

connector, 13
definition, 231
setup, 21
softkeys

Address, 21
Setup, 21

green LED, 7
GSM softkey, 178
guides, content of, xi

H
hardkeys
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definition, 231
help on, 26
overview, 4
See also specific key

header utilities softkeys, 91
Help hardkey, 5, 26
Hostname softkey, 22
hostname, setting, 22
HP 3300A, emulating, 66

I
I connector, 6
I Offset softkey, 141
I OUT connector, 14
I/O Config softkey, 17
I/Q

adjustments, 78, 141
front panel inputs, using, 79, 140
modulation, 78, 138
optimizing, 139
rear panel outputs, 14
rear panel outputs, using, 139
signal path, optimizing, 139
signal, aligning, 97
softkeys, 78, 138–143
waveform, clipping, 119

ideal low- pass filter. See rectangular filter
IF, 231
images, 78
impairments

I/Q adjustments, 78
impairments, real- time

phase noise, 169
Import Waveform softkey, 109
Incr Set hardkey, 7
information, removing from memory, 214
Insert softkeys

Insert, 87
Item, 34
Row, 34
Waveform, 87
Waveform Sequence Contents, 87

Install licenses softkey, 46
installation guide content, xi
instrument

firmware, upgrading, 20
softkeys

Adjustments, 17
Info, 17
Options, 24

state
associating with waveform, 49
files, 48, 51
register. See data storage
softkey, 47

int media, 231
Int Phase Polarity softkey, 138
interface

GPIB, 21
LAN, 22

Internal Baseband Adjustments softkey, 141
internal media, 52
Internal Storage to USB softkey, 47
Internal/USB Storage Selection softkey, 43
interpolator filter, 130
IP

Address softkey, 22
address, setting, 22
auto, 22
definition, 231

J
jitter on EVENT output, 111

K
keyboard, using, 66
keys

disabling, 217
front panel, 4
help on, 26
numeric, 4
test, 227
See also specific key

knob, 7, 19, 27

L
L annunciator, 9
LAN

connector, 13
definition, 232
Services Setup softkey, 21
setup, 22
Setup softkey, 21

Last Mkr Point softkey, 101
Last softkey, 19
LCD display memory, 212
LEDs, 7

blink test, 227
front panel, 7
modulation, 40

leveling, turning off, 59
licenses

manager, 24
service software, 24
signal studio, 24
time- based, 20
troubleshooting, 228
viewing, 24
waveform, 24

line power (green) LED, 7
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linear sweep, 32
list mode values, 35
List softkey, 43
list sweep

parameters, 35
status information, 35
troubleshooting, 224
using, 34
waveform, 36

listener mode annunciator, 9
LO, 232
Load From Selected File softkey, 45, 46
Load List softkey, 46
Load softkeys

All From Int Media, 84
All From USB Media, 84
Cal Array From Step Array, 56
From Selected File, 45, 46
Load/Store, 34, 45, 46
Segment From Int Media, 84
Segment From USB Media, 84
Store, 84
Sweep List, 46

Load/Store softkey, 34, 45, 46
Local hardkey, 5
lock up, troubleshooting, 220
logarithmic sweep, 32
LXI, 232

M
main memory, 212
manual control, sweep, 38
Manual softkey, 59
Manual softkeys

Config Settings, 22
Manual, 22
Mode, 31
Point, 31

manuals, content of, xi
Marker softkeys, 101
markers, aligning signal, 97
markers, waveform, 96–111
media

BBG, 231
erasing, 214
int, 231
memory stick, 52
storage, 52
types, 82, 212
USB, 52, 225

memory
erasing data from, 214
types, 212
See also media

menu keys, 5

messages, error, 226
messages, warning

5- Pack Licensing, 161
Waveform 5- Pack Licensing, 161

mirror table, duplicating coefficients, 192
mixer, troubleshooting signal loss, 222
Mod On/Off hardkey, 6, 40
Mode hardkey, 83, 165, 167, 170
mode, modulation, 232
modes of operation, 3
Modulated softkey, 59
modulation

AM, 67
analog, 3
annunciators, 9
carrier signal, 40
digital, 3
external source, using, 69
FM, 67
generating, 40
I/Q, 78, 138
phase, 67
pulse, 3, 71
simultaneous, 41
troubleshooting, 221

Modulator Atten softkey, 167
monochrome display, setting, 18
Monochrome softkey, 18
MULT annunciator, 9
multi- BBG sync, 144

configure setup, 147
equipment setup, 147
resynchronize, 149
system delay, 146
system sync, 146
trigger setup, 146

multicarrier setup
APCO 25 w/C4FM, 187
APCO 25 w/CQPSK, 187
Bluetooth, 187
CDPD, 187
DECT, 187
Default, 187
EDGE, 187
GSM, 187
NADC, 187
PDC, 187
PHS, 187
PWT, 187
TETRA, 187

multicarrier setup softkeys, 187
multicarrier TDMA waveforms

creating, 187
multicarrier, Default softkey. See quick setup, Default
softkey, settings
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multiplier, using, 63
multitone, 176, 206–209
multitone mode, 3
Multitone softkeys, 206
multitone waveform, setup, 199

N
N7699A- D01, 150
NADC softkey, 178
Name And Store softkey, 109
Next REG softkey, 66
Next SEQ softkey, 66
No action softkey, 46
No Retrigger softkey, 113
noise, 163
noise bandwidth factor, 164
non- volatile memory, 82
non- volatile, definition, 232
number keys, 27
numeric keypad, 4
nyquist filter

definition
nyquist filter, selecting, 184

O
OFFS annunciator, 9
offset, 78
offsets

baseband frequency, 135
I/Q, 141
output, using, 61

on/off switch, 7
operation

modes of, 3
operation, basic, 25
operation, remote, 21
optimization, I/Q, 78, 138
option

430
multitone mode, 206
two tone mode, 200
two- tone mode, 200

Option 22x, 150
options

651/652/654
description, 3
multitone mode, 206
two- tone mode, 200

670/671/672, description, 3
enabling, 17, 24
resource, 2
UNT, 3
UNU, 3

Options 221- 229, 150
Options Info softkey, 24

oscillator, external reference, 30
Output Blanking softkey, 29
output, swept, 31
over range error, DAC, 130, 136, 174
overshoot, 130
overview, signal generator, 1

P
Page Up hardkey, 5
parameters, saving a waveform’s, 91
path delay, 78
PATT TRIG IN connector, 15
Patt Trig In softkeys, 114
PDC softkey, 178
peak- to- average power, reducing, 123
performance, optimizing, 55
persistent

memory, 213
persistent settings

definition, 232
resetting, 26
restoring defaults, 19

phase noise
adjustments, 173
DAC over range & scaling, 174
description & plots, 171
impairments, 169
softkeys, 170

Phase Ref Set softkey, 29
phase skew, 78
PHS softkey, 178
pixel test, 227
Plot CDDF softkey, 129
Point Trigger softkey, 31
point- to- point time, 232
polarity, external trigger, 114
polarity, marker, setting, 108
power

meter, 56, 57
on, settings, 19
peak- to- average, reducing, 123
receptacle, 11
search, 60
setting, 29
softkeys, 17, 19, 29–34, 59
supply, troubleshooting, 221
switch, 7
troubleshooting, 221

Power Search Reference softkey, 59
Power softkeys

On, 19
On/Preset, 17
Search, 59

preferences, setting, 17
preset
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hardkey location, 6
settings, 19
troubleshooting, 225
using, 26

Preset softkeys
Language, 19
List, 34, 56
Preset, 19

Prev REG softkey, 66
Prev SEQ softkey, 66
Proceed With Reconfiguration softkey, 22
programming guide content, xi
protection, DAC over range

baseband offset frequency, 136
phase noise impairment, 174

pulse
annunciator, 9
characteristics, 73
connector, 12
marker, viewing, 105
modulation, 71
narrow, 59
sync signal, 39
video signal, 39

Pulse hardkey, 72
pulse modulation, 3
Pulse softkeys, 39, 72
Pulse/RF Blank softkey, 101
PWT softkey, 178

Q
Q connector, 7
Q Offset softkey, 141
quadrature adjustment, 141
quadrature angle, 78
Quadrature Angle Adjustment softkey, 78, 141
queue, error, 53
quick setup

Default softkey
settings, 178

Quick Setup Softkeys, 178

R
R annunciator, 9
raised cosine filter. See nyquist filter
RAM, 212, 213
real- time

AWGN
softkeys, 165

I/Q Baseband AWGN softkeys, 167
noise, 164
phase noise, 169

adjustments, 173
DAC over range & scaling, 174
description & plots, 171

impairments, 169
softkeys, 170

rear panel
I/Q outputs, 139
overview, 11

Recall hardkey, 48
Recall keys

hardkey, 66
Instrument State, 43, 46
Reg, 66
State, 46

recall register, troubleshooting, 224
receiver test, 176
rectangular clipping, 124, 127
rectangular filter

definition, 232
REF annunciator, 9
REF IN connector, 13
Ref Oscillator Ext Bandwidth key, 30
Ref Oscillator Ext Freq key, 30
Ref Oscillator Source softkey, 29
reference oscillator, external, 30
reference, using, 62
references, content of, xi
regrowth, spectral, 122
remote interface, emulate HP 3300A, 66
Remote Language softkey, 21, 23
remote operation annunciator, 9
remote operation preferences, 21
Rename File softkey, 43
Rename Segment softkey, 84
Reset & Run softkey, 113
Restart on Trig softkey, 113
Restore softkeys

LAN Settings to Default Values, 22
System Settings to Default Values, 19

resynchronize, multi- BBGs, 149
Return hardkey, 7
Reverse Power Protection softkey, 19
Revert to Default Cal Settings softkey, 143
RF

blanking
marker function, 106
settings, saving, 97

hardkey, 6
output

configuring, 29
connector, 6
troubleshooting, 221

RF During Power Search softkey, 59
RF Output softkey, 138, 139
RFC NETBIOS Naming softkey, 22
ringing, 130
ripple, 130
RMS, 232
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RMS softkey, 59
Rohde & Scharz softkey, 23
roort, 232
root cosine filter. See root nyquist filter
root mean square, 232
Root Nyquist Filter

definition, 232
root nyquist filter

definition, 232
rotary knob, 27
Route Connectors softkey, 31, 72
Route To softkeys, 39, 72
routing

I/Q, 78, 138
marker

ALC hold, 98
RF blanking, 106
saving settings, 97

RPG test, 227
runtime scaling, 132

S
S annunciator, 9
sales, Agilent offices, 229
sample rate clock, 15
sample rate softkey, 111
Save hardkey, 48
SAVE Seq Reg softkey, 48
Save Setup To Header softkey, 91
Scale Waveform Data softkey, 129
scaling softkeys, 129
SCPI

enabling, 22
reference content, xi
softkey, 23

screen saver settings, 18
Screen Saver softkey, 18
search, power, 60
secure

display, 217
mode, 216

security, 211
Security softkey, 43
Segment Advance softkey, 113
segment advance triggering, 113
segments

advance triggering, 115
file headers, 91
loading, 84
softkeys, 84
storing, loading, & playing, 84

Select hardkey, 27
Select Seq softkey, 66
Select softkeys

Color Palette, 18

Different Header, 91, 95
Header, 91
Internal File(s) to Copy to USB, 47
Reg, 48
Seq, 48
Waveform, 34

self test, 227
Sequence softkey, 43, 91
sequences

editing, 89
file headers, 91
marker control, 109
playing, 90
waveform, 87

serial data, synchronizing, 15
server, enabling, 22
service

Agilent offices, 229
guide content, xi
request annunciator, 9

Set Marker softkeys, 101
settings, persistent, 232
settings, phase noise, 173
Show softkeys

Alpha Table, 27
Waveform Sequence, 87
Waveform Sequence Contents, 87, 109

signal generator
modes, 3

Signal Studio, 2
signal studio licenses, 24
sinewave, 232
Single softkey, 113
Single Sweep softkey, 31
skew, I/Q, 141
Sockets SCPI softkey, 22
sockets, enabling, 22
softkeys

definition of, 232
help on, 26
label area, 10
location, 4
See also specific key

source settled signal, 39
Source Settled softkey, 39, 72
Span softkey, 59
Specify Default Storage Path for User Media softkey, 43
spectral regrowth, 122
spectrum analyzer, troubleshooting signal loss, 222
square root raised cosine filter. See root nyquist filter
Square softkey, 72
standard, modulation, 232
standby (yellow) LED, 7
State softkey, 43
states, persistent, 232
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step array (user flatness), 57

See also user flatness correction
Step Dwell softkey, 32, 64
Step Spacing softkey, 32
step sweep

spacing, 32
troubleshooting, 224
using, 32

Step/Knob Ratio softkey, 19
Storage Type softkey, 44, 52
Store To File softkey, 45, 46
Stored Segments softkey, 43, 91
Subnet Mask softkey, 22
Sum softkey, 138
sweep

annunciator, 9
hardkey, 31
linear, 32
list parameters, 35
list status information, 35
logarithmic, 32
manual control, 38
mode, 3
out connector, 12, 39
out signal, 39
softkeys, 31–39, 72
step, 32
troubleshooting, 224
waveform, including, 36

SWEEP hardkey, 31
Sweep softkeys, 31–39, 47, 72
swept output, 31
switch, power, 7
SWMAN annunciator, 9
synchronize multi- BBGs, 144

configure setup, 147
equipment setup, 147
resynchronize, 149
system delay, 146
system sync, 146
trigger setup, 146

system defaults, restoring, 19

T
T annunciator, 9
talker mode annunciator, 9
TCP, 233
TCP Keep Alive softkeys, 22
TDMA digital modulation, 181
terminator, 233
test, self, 227
tests, front panel, 227
TETRA softkey, 178
text area (on display), 10
text entry softkeys, 84

time, dwell, 231
time, setting, 20
time/date reference point, 20
Time/Date softkey, 20
time- based license, 20, 228
Timer Trigger softkey, 31, 64
Toggle softkeys, 109
Trig

in connector, 12
out connector, 12, 39
out signal, 39

trigger
connectors, 12
hardkey, 5
initiating, 5
multiple BBG sync, 146

Trigger setup softkeys, 65
Trigger softkeys

& Run, 113
Doublet, 72
Key, 31
Out Polarity, 31
Source, 112
Triggered, 72
Type, 112

Triggered softkey, 72
triggering

gated, 113, 116
multiple BBG sync, 146

equipment setup, 147
segment advance, 113
softkeys, 112
waveforms, 112

troubleshooting, 219
two tone, 176, 200–205
two tone softkeys, 201
two- tone softkeys, 201
two- tone waveform, setup, 199
type, modulation, 232

U
UNLEVEL annunciator, 9
unleveled operation, 59
UNLOCK annunciator, 10
Unspecified softkey, 91
UNT, option, 3
UNU, option, 3
Up Directory softkey, 43, 44, 47
Update in Remote softkey, 18
urls, 2, 20, 24, 229
USB

connecting media, 52
definition, 233
device connector, 13
host connector, 4
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keyboard, using, 66
softkeys

File Manager, 43, 44
Keyboard Control, 66

to BBG Memory softkey, 47
to Internal Storage softkey, 47
troubleshooting, 225

Use softkeys
As, 46
Current Directory As Default Path, 43, 52
Only Internal Storage, 43
Only USB Media, 43

user
documentation content, xi
files, backup and restore, 41
flatness correction, 56
preset, 26
preset, troubleshooting, 225

user FIR
definition, 233

User softkeys
Current Directory As Default Path, 44
Flatness, 29, 43
Flatness Correction, 56
Flatness Corrections, 47
Span, 59
User, 19

Utility hardkey, 17

V
vector operation, 81, 150
View Next Error Page softkey, 53
View Previous Error Page softkey, 53
volatile memory, 82, 84
volatile, definition, 233
VXI- 11, enabling, 22
VXT- 11 SCPI softkey, 22

W
Waveform 5- Pack

history, using, 157
history, waveform files, 157
licensing, 150
licensing, installing, 151
licensing, understanding, 150
licensing, warning messages, 161
licensing, waveform file, 151
status messages, 153
using, 150

Waveform softkeys
Licenses, 24
Runtime Scaling, 129
Segments, 84
Sequences, 87, 109
Utilities, 129

Waveform, 31, 34
waveforms

clipping, 119
file headers, 91
from digital baseband waveform, 130
in a sweep, 36
license, 24
markers, 96, 97
memory, 213
multiple BBG synchronization, 144
multitone, 206–209
overview, 82
saving instrument state, 49
scaling, 128
segment softkeys, 84
sequence, 87
storing, loading, & playing, 84
triggering, 112
two- tone, 200–205
Waveform 5- Pack, 157

Web Server softkey, 22
window settings, FIR filter, 195
WINIT annunciator, 10

Y
yellow LED, 7

Z
Zoom softkeys, 101
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